Not Able To Install Drivers For Numark NS7 DJ Controller

By jpoole23 ยท 31 replies
Jul 24, 2013
Post New Reply
  1. jpoole23

    jpoole23 TS Rookie Topic Starter Posts: 27

    Easy restin'!
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    So that proved to be an interesting exercise. That entire latest Numark 32-bit driver update package is already incorporated into ITCH v2.2.2. (I checked closely and found all the drivers and their INF and setup files, are identical between the two packages!) ITCH v2.2.2 is a "superset". Its all the latest drivers plus all the application layer apps to support the hardware and let you DJ!

    Btw. ITCH v2.2.2 installation also includes a file ns7_midi.inf. I looked at it and it looks to me that's its for the midi driver installation. (It defines device names like "Numark NS7 MIDI" and "Numark NS7 MIDI 2.8.24") So I believe Numark midi-drivers are also already included in latest ITCH. (I wouldn't know that you would also need someone else's midi-drivers too as you heard in the Numark forums)

    That means you only need install ITCH v2.2.2.

    To best of my knowledge, we've already uninstalled all the bits left behind from your prior installation. So I'd say
    > Unplug your NS7 and NSFX from your computer
    > Download and run the ITCH v2.2.2 installer
    > Wait until the installer tells you to plug in your NS7

    Can you test the setup with just the NS7 awhile? See how that seems to work. Once yout think it seems to be OK, then plug in your NSFX as well

    If there's still any problem, I don't think you can get further support/troubleshoot unless you test your equipment on an INTEL based computer since Numark doesn't support AMD

    Good luck! Tell me how it turns out!
  3. jpoole23

    jpoole23 TS Rookie Topic Starter Posts: 27

    The software could not detect the hardware. Windows didn't automatically try and install the drivers, that was different. Though Windows did let me know 'device driver software was not successfully installed'.

    Numark may not support AMD, but I've had this working for years before the past two weeks. I just dont understand.

    Thanks for trying.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    The ITCH installer isn't clear about connecting your device and power-on? You should plug it in and turn it on immediately (within seconds). I wouldn't be surprised if device detect sequence is failing because your NS7 isn't powered on.

    Can try one more thing
    1. Uninstall from Programs and Features again. (don't do any other cleanup again)
    2. Locate and delete the file C:\WINDOWS\INF\
    3. Run the ITCH v2.2.2 install again
    4. When prompted to plug in your device, turn your device on FIRST then insert the USB cord. Let's try it that way
    Then let's see how device detection and driver install works this time. (The old drivers from your older version ITCH are already removed)

    Windows should have created a new C:\WINDOWS\INF\ file.
    > Rename it C:\WINDOWS\INF\ and upload it to your next post
    > Give me another DevManView report
    > And describe the device installation results to me
  5. jpoole23

    jpoole23 TS Rookie Topic Starter Posts: 27

    I wont let me upload the It say its a text doc and everything but your upload option wont locate it?

    The install went good at first. During installation I could tell everything was acting a bit different. Then a Windows pop up with a red header said; 'Windows cant verify the publisher of this software'. I hit continue/install/yes whatever option they had. Install was complete, Windows wasn't trying to auto install the missing drivers. I started it up and it worked perfectly. For about 10 minuets. A few dropouts then it eventually disconnected, I was heartbroken lol.

    You know, now that I think about it. I went years with an older version of ITCH 1.7.1 with no problem, then in May I tried to upgrade to 2.2.2. That's when everything went haywire. After 1/2 day of 2.2.2 I un-installed it and went back to 1.7.1 (the program I had on here when we started this convo). After the re-install of 1.7.1 I was fine again, it was a slow gradual slip to this point. You think the new drivers still being left behind from 2.2.2 from the un-install in May could have messed with the 1.7.1 program that work for me for so long?

    Attached Files:

  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Windows is a mystery. I don't know for certain why things went to s*** before when you re-installed v1.7 but it could be the new drivers still on your machine when you reinstalled v1 was the problem. You can trying reinstalling v1.7 again but this time do full cleanup first (remove from Prog and Features THEN uninstall any old Numark devices using DevManView THEN delete any Numark drivers still in DriverStore)

    Altho device detect and install sequence finally worked last time you can try these step in future
    > Start w/NS7 disconnected from USB and powered off. Run ITCH install
    > When ITCH asks you connect, plug in USB first and then turn on NS7 immediately after
    > Wait for the USB connect "ding-dong" sound (sometimes may take up to 20 or so secs, I think)
    > Once you hear it, allow the ITCH installer to proceed

    fyi info about posting any future and DevManView reports
    Let's ignore them for your last v2.2.2 attempt but for the future
    1. Pls remember I need those DevManView reports SAVEd AS Tab Delimited text (but no need repost the last one)
    2. re: file. When DevMgr installs a device, Windows 7 writes trace data into that file (only problem is that data is very cryptic and I can only (sometimes) follow some of it.
      • TechSpot should be able to upload any file with a .txt extension and (I think) upload file size limit is 1 MB.
      • Before a new test, delete to discard old data, reduce file size, plus then I know the data for the new install starts at top of the file! I would think you should be able to Browse and upload it from anywhere but, if need be, you can also try pasting onto your Desktop and uploading from there
  7. DJ Most Wanted

    DJ Most Wanted TS Rookie

    Hello, My name is Most Wanted I'm presently having this problem. I use Window 10 version 1703. I have a NS7 II with Numark drivers NS7II_2.9.64. I'm attaching a file with the necessary information you need.

    Thanking you in advance

    Attached Files:

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...