NTLDR missing on Windows Server 2000 Advanced

By maXimus4444 ยท 10 replies
Jul 14, 2006
  1. My problem is this:

    I have a server running windows server 2000 advanced. When the server boots up it throws an error at me:

    NTLDR is missing
    Ctrl+Alt+Del to restart.

    This problem doesn't happen every time it is turned on. Every so often it will boot up just fine. I don't understand this other than I think the file is corrupt. My question then is how do I replace the ntldr file?
  2. Peddant

    Peddant TS Rookie Posts: 1,446

    Microsoft describes three methods HERE including boot disk and recovery console.
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    A missing or corrupted NTLDR, ntdetect and/or boot.ini would give you consistent results. The fact this doesn't happen consistently, means it is not something as straight forward as the message claims, "NTLDR is missing". In other words, following instructions on how to fix a missing NTLDR will probably do you little good.

    Personally, I would check the hard drive. This is a common issue with failing boot drives and it wouldn't surprise me if you've the same problem. Run a diagnostic on it once.. twice.. three times. Run the test over and over again just to make sure since this issue is intermittent. And even if it passes several times, it can still be a failing drive. But at least you know if it fails, it's most definitely a bad drive.

  4. hewybo

    hewybo TS Maniac Posts: 435

    similar problem

    I'm helping my son put together a system (by remote- i'm in vegas, he's in washington), and we're having a similar problem trying to install xp home. it'll load the files, then the screen goes gray, and hangs- no error, nothing. this is on an ASUS P5P800-VM, Pentium 805 dual-core, with a new, formatted Western Digital 2500JB. you think the HDD is bad? :suspiciou

    forgot to mention- twice, while trying to install the OS, we got the "NTLDR is missing" error, which subsequently went away.
  5. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    This part makes me think memory. Memory and drive errors can appear to have similar symptoms, but memory often has the additional effect of turning the screen a pleasant variety of colors.

    Where does it hang? Is it always in the same part of the installation / loading? Some more details might help narrow down the possibilities.

    And of course, this doesn't mean the memory is necessarily bad (If it is memory related), but it may be incompatible with the particular board. Try one module at a time and try a different brand. If the issues persist, then this would point to something else.

    And this is a good way to find out if your memory is working as expected.
  6. hewybo

    hewybo TS Maniac Posts: 435


    I know this doesn't necessarily mean anything, but the 2x512 Kingston HyperX ran fine in another system, and they ARE on the mobo's "approved vendor's" list in the manual. We did try the install without the vid card and sound card, and with only one stick of RAM, same results. the last three tries, xp home has finished the file loading process, says preparing to install, turns gray, then hangs (overnight last night, no change)'

    I've been thinking mobo, but now............ :hotbounce
  7. AsitA

    AsitA TS Rookie


    Since I'm the one doing the hands on, on this particular build...I'll explain a little more deeply than my father can (hewybo)

    Last night we successfully loaded windows onto the hard drive. It went through the motion of install to the 15 second countdown of a reboot...

    This is where the problems began - The reboot didn't work...It reset the computer, but with no activity at all; Just blank screen...So I turned off the computer and restarted it, got the beep (I've been calling it that cuz when I get the beep I know the comp has turned on which is another issue I'll get into) and the ASUS screen comes up (Load screen for the comp startup) It checks my system specs and hardware, then proceeds onto to loading windows...

    The windows load screen (With the Windows logo and blue load bar) takes about 30 to 40 seconds to get to every time...Then once the windows load screen is done..It fades out like it's going to open up windows itself but it goes to a light grey screen as if the comp is trying to figure out what the hell it's doing. The windows CD-ROM in the drive spins up faster like it's processing the data to the comp, then it slows to an idle state and the screen just stays light gray.

    As my dad said, I left it on all night to no avail.
    It was still on grey screen and the comp was humming in an idle state.

    The "other" problem I've been facing is: Sometimes when I restart/reset or turn on the computer - The start up screen will come on (After "The Beep") and other times it does nothing...Just starts up all the hardware with nothing to show for it...

    Any help would be greatly appreciated. Guidance as well -

    Thanks all.

  8. pcaceit

    pcaceit TS Rookie Posts: 315

    Hi welcome.

    I you have been hitting the reset button and probably powering your system on and off by power button frequently, then chances are that you will have at least file system corruption and possibly hard disk corruption.

    You should run a disk check to see i it helps. if you have a really corrupted hdd problem then you will get the message that "the disk has one or more unrecoverable error's" then you will have to. partition,Format and reinstall windows.
  9. maXimus4444

    maXimus4444 TS Rookie Topic Starter Posts: 86

    Sorry it took me soo long to respond. Yes everything anyone has told me has not worked. I've tried several different fixes and nothing has come of it. I'll run the diagnostics on the hard drive today and repost with the results. Thanks

  10. maXimus4444

    maXimus4444 TS Rookie Topic Starter Posts: 86

    I ran the Hitachi diagnostic. It reported no errors. I'm going to run the seagate diagnostic and see what I come up with.
  11. maXimus4444

    maXimus4444 TS Rookie Topic Starter Posts: 86

    I ran the SeaTools Diagnostic and here are the logs.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...