Obscure laptop/tablet brand issue

By Trillionsin ยท 14 replies
Jun 10, 2016
Post New Reply
  1. I normally dont need to come here and ask for help, however, I am really stumped on this one. I have an iView Maximus Windows 10 tablet.

    Upon trying to configure its BIOS/UEFI to boot from USB, I did just the opposite with terrible consequences, it seems...

    I should have researched all the options I was disabling or switching, but I really didnt think that I would have disabled the keyboard along with all the USB ports.

    So the laptop still boots up, into Windows. I cant use the keyboard or any peripherals plugged into the USB ports. I've verified my USB keyboard is working and such. And the onboard keyboard/USB ports were working before hand.

    Unfortunately I turned off a few options at the same time, and I dont remember what they were. They did have to do with secure boot, as well as some USB options. I just cant believe you can disable every means of getting back into the BIOS. There's no CMOS battery for me to remove to default the BIOS. If there's a jumper, I dont have enough documentation to figure it out.

    I'm really hoping someone more resourceful than I has had experience with this brand. I cant even seem to find the model. It's an iView Maximus with model # that looks almost like a serial number: 1508-MAXIMUS-BK-WH1134

    If anyone has additional information on this laptop/tablet, it would be very appreciated. I feel so dumb for getting myself stuck in this situation. I am still searching, but no luck yet.

    BTW, What happened to the tech support thread? Did I overlook it?
  2. Trillionsin

    Trillionsin TS Evangelist Topic Starter Posts: 1,557   +236

    I cant seem to find the manual** That was a typo.

    Also, I can get a different boot option to appear, but it doesnt seem to be of any help. If I hold both volume up and down buttons while I hit the power button I get this:

    "Entering DnX mode.
    Waiting for fastboot command..."

    I'm not familiar with this either, and I still cannot seem to do anything with the USB ports and keyboard disabled.
  3. Trillionsin

    Trillionsin TS Evangelist Topic Starter Posts: 1,557   +236

    No help, huh? Bump! Anyone?
  4. cyberhack

    cyberhack TS Rookie

  5. Trillionsin

    Trillionsin TS Evangelist Topic Starter Posts: 1,557   +236

    OF COURSE... This is the first thing I tried before coming here. Did you view the page before sending me the link?

    Drivers are of no help.
    Image file is corrupt, downloaded 3 times, once with another browser, unzipped using 7zip

    I dont know where you found the manual, but its not actually in the drop down. Besides that, I ended up finding the manual elsewhere just to realize it doesn't contain information about resetting the BIOS with any other method that is functioning.

    It's just been laying here for a couple weeks or so, since I've had this post up. Pretty much given up.

    Any other ideas? This tablet is so not worth this much effort.
  6. cyberhack

    cyberhack TS Rookie

    Can you upload a photo of the tab thanks
  7. Trillionsin

    Trillionsin TS Evangelist Topic Starter Posts: 1,557   +236

  8. cyberhack

    cyberhack TS Rookie

    Started download will let you know
  9. cyberhack

    cyberhack TS Rookie

    To get into the BIOS by using an external keyboard and F10
    Firmware download stopped at 700meg
    I will look for the firmware and get back to you time for me to go home back at work on monday
  10. Trillionsin

    Trillionsin TS Evangelist Topic Starter Posts: 1,557   +236

    Unfortuntely, as I mentioned in my original post, that the USB ports were no longer working.
  11. Trillionsin

    Trillionsin TS Evangelist Topic Starter Posts: 1,557   +236

    I guess I never post about something easy... otherwise I'd have figured that out. I've already tried all the typical stuff.
  12. Cycloid Torus

    Cycloid Torus Stone age computing. Posts: 2,693   +501

    As in "Adventure" while touring the Colossal Cave, there is no help for mere mortals...

    Looked everywhere for a method to reset BIOS (or whatever is the boot sram/rom in this heathen box). It seems only the manufacturer knows for sure - and he hasn't said.

  13. cyberhack

    cyberhack TS Rookie

    Sorry have been busy I have emailed the manufacturer for the recovery usb to be sent out. Will let youknow I had a fault with a hp they did send out a usb for recovery lets hope this lot do the same.Entering DnX mode is looking for the recovery usb
  14. Trillionsin

    Trillionsin TS Evangelist Topic Starter Posts: 1,557   +236

    I'm pretty sure I still have this thing laying around. Let me know what you come up with

  15. Barry63

    Barry63 TS Rookie

    I have a similar issue with an iview maxumis, I did a Windows 10 restore but now cannot get the Touchscreen to work on it. I must have made changed the BIOS when I was screwing with it. I am needing to find a full restoration download, BIOS and windows 10. This company has support, but not good support. Any help would be appreciated.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...