Old bootable C drive not recognized in Win XP

By hi2125 ยท 4 replies
Jan 21, 2011
Post New Reply
  1. I googled a few hours but couldn't find answer so I decided to ask for help here. Any input or insight would be much appreciated.

    I just migrated my old 100GB C drive to a new 300GB one. Now I want to use the old 100GB as my storage drive, so I put it in the internal hard disk bay in my ThinkPad T42 CD Drive Bay. But Windows does not recognize it no matter what I do. I tried 2.5 inch ATA-to-USB adaptor cable to no avail. I have tried both method many times in the past and they usually recognize drives immediately. No need to set drive letters or jumpers. The only difference this time is that this drive used to be a bootable C drive.

    When I connect the drive, Windows says "New Hardware Found" and starts installing. But toward the end, it says "Unknown error occurred and drive might not work properly". Sometimes it says "Your device is installed and ready for use". In any case, if I right-click My Computer -- Manage -- Storage -- Disk Management, this drive is not listed there. If I go to Device Manager -- Disk drives, this drive is listed there. Its Properties says "This device is working properly". And the Location says 0 (0), which is the same as the new 300GB C drive. Is this why I am having this problem?

    After many failed trials, I put the old drive back to the main drive bay and Windows started fine just like before. So the old drive itself is fine. It's just not recognized. So I rebooted with Windows OS Installation Disk and formatted this drive with NTFS. Then, using EASEUS Partition Master Home Edition, I tried to create partitions but it fails to do so. Acronis True Image Home (Add New Disk) does not find the drive.

    Just to test, I took the C drive out of my other laptop (ThinkPad T40) and tried the same thing and it did not work either. So drives that are (used to be) bootable C cannot be recognized or partitioned? Is there anything I can do to use this drive?

    In Summary:
    Device Manager (Disk Drives) recognizes it
    Disk Management does not recognize it
    EASEUS finds it but fails to partition
    Acronis does not find it
    Both 300GB and 100GB have Location of 0 (0).

    Thank you for your help.
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Check the jumpers on the drive. It may be on Cable Select and might need to be forced as Master for what you are doing. Or, since you are hooking it up in a CD drive bay, maybe thats shared with the internal HD so you'd need to set it to Slave. In any case, have you tried changing the jumper to something other than what it is currently on?
  3. hi2125

    hi2125 TS Rookie Topic Starter

    Thank you, SNGX1275. I ordered some jumpers and they will come in a few days. I will post how it goes.
  4. hi2125

    hi2125 TS Rookie Topic Starter

    I got some jumpers today and tried all combinations including device 0, device 1, master, slave, cable select, etc. But none worked. So the conclusion I drew from the facts is: once a laptop HD becomes a master boot drive, it can no longer be a slave. It might be related to the MBR but when I deleted it using Super Fdisk on a smaller disk the other day, it became unusable so I don't want to do it. Funny thing is that this drive works fine as long as it's used as the main master drive. So I guess I should just use this on my old laptop. Thanks for your help.
  5. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Certainly an odd issue, sorry the jumpers didn't fix it. I have no idea why it doesn't work. But I think your conclusion is wrong... There is no technical reason why a boot drive can't be hooked up as a secondary drive in another computer (or the same computer if you have a new boot drive) without formatting - the exception would be if you had a new OS on the new boot drive and the old boot drive had a file system the new OS couldn't read (ie - ext2 or something from linux, then the new os is Windows). I've swapped hard drives around in systems many times with no issues - so something else is at play with your setup and I don't know what it is.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...