1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Old game, not working, windows 7

By justanewguy ยท 4 replies
Nov 14, 2010
Post New Reply
  1. So yeah, new to forums. Saw that problems got solved here, s'all I needed to know to jump in with my own problem.

    Whole Problem:
    For the past two days I have trying to play Dungeon Keeper 2 (Bullfrog, 1999), to no avail.

    Here's the gyst of the last two days...

    Installed, tried to play. Double clicked exe. file:
    Pitch black screen (Monitor off), black screen (Monitor on), pitch black screen (Monitor off), then back to the desktop/whatever folder was last open.

    Then, I looked it up on the intrawebs and apparently it was compatibility issue. Cool. I use Windows 7 (Computer details bottom), changing it was nice and simple. Changed compatibility mode to Windows 98 and switched on 'Run as Administrator'. Same thing happened. Switched compatiblity mode to Windows 98 and tried again.
    Got to Dungeon Keeper 2 Load screen ("Its good to be bad"), cinematics didnt happen, game load screen, then main menu...

    The buttons were there, but the background (A 3D scene of a big strategic dungeon room or something of similar description) was blacked out (I would've posted a picture but since I'm new, I cant)

    Managed to get to 'Pet Dungeon' mode, but every bit of 3D is blacked out. And some of the 2D graphics were iffy. Leaking and what not.

    I've tried searching. Tried updating. Tried DosBox. Even tried searching for a DirectX version changer (But with everyone saying that it was infected with a virus and others saying it was still pretty new and unrefined...Yeah, decided to stay away).
    Another suggestion was to turn off hardware accelaration. Instructions were:

    Control Panel>Display>Change Display Settings>AdvancedSettings>Troubleshoot>Change settings>Turn off hardware accelaration

    Sounded good. I got as far as Troubleshoot, then found 'Change settings' to be grayed out (Unselectable) with a Windows 7 admin symbol on the button as well (Grayed out).

    I do have an old computer that I know I can run it on, but I was hoping I could get it on the newer computer. Any helps, suggestions all welcome.

    But I warn you, I'm pretty sure I have tried just about everything.

    (If you need more info/pictures, just say so)

    Computer details: (I barely have a clue what all of this means. I'm only a little tech savy)

    Computer - MSI Laptop, A6205

    Operating System - Windows 7

    CPU - Intel Core i5-430M

    VGA - ATI Radeon HD5470 with 1GB DDR3 VRAM

    LCD - 15.6" HD 1366x768 (Glare Type)

    Memory - DDRIII 2GB*2

    HDD - SATA 500GB

    DirectX version 11
  2. mailpup

    mailpup TS Special Forces Posts: 7,101   +419

    What about game patches?
  3. SuSpEcT

    SuSpEcT TS Rookie

    hmmm I can Reply ...

    I run on my computer Resident Evil , Resident Evil 2 , Resident Evil 3 ... and I have Windows 7 32 bit .. :) .. and the game run without any problems and without compatibility mode to any type of windows //
  4. Relic

    Relic TechSpot Chancellor Posts: 1,379   +16

    I have DK installed on my XP machine, I'll give it a try on my Win7 system and see if I can get it to work and let ya know.
  5. justanewguy

    justanewguy TS Rookie Topic Starter


    yep, updated to 1.7

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...