Page Fault in Non Paged Area--Windows XP

By bclacquer · 13 replies
Jun 22, 2009
  1. I have tried searching for this solution and can’t find one.

    I have a problem on one of my computers at work. It is a Dell. I am running XP Pro with SP3. We have very little installed on the machine but it runs all day, everyday.

    We started that computer and after it booted up the blue screen of death came up. I got the following error:

    Page Fault in Non Paged Area with the following string:
    (0x00000050 0xFF14E000 0x804E51BB 0x00000000)

    I restarted the computer to see if it was flook, it is not. I then tried to start in “safe mode”. The first time it worked well. I thought that it was ok to run in safe mode so I shut the machine down. I restarted the machine and opened up the diagnoses partition that dell installs and ran all the tests. They all passed. I also ran check disc and that passed as well. I went online to research my error. It would appear to be related to my RAM. I found another forum that said it may be related to spyware. It said to start in safe mode and rename a few files if I find them. I tried to boot in safe mode but the process hung at “mup.sys”. By “hung” I mean the line of processes never continued and after a bit the lights stopped flashing. So I researched that. I was unable to find a way around that. The closest I came to a solution was to disable my USB controllers or unplug all USB devices prior to booting. I can’t do that because my keyboard is USB and when I tried, the keyboard would not work and I could not push F8. I tried to be faster then the computer by selecting “safe mode” and then unplugging the keyboard, no dice.

    My next thought is to open the machine up and try moving the dim stick to the other slot. (According to my BIOS I have 2 slots, but one stick). I also came across a program to run to test my memory.

    I restarted just now in the normal mode. Still crashes.

    My question is this, what is wrong with this machine?
  2. bclacquer

    bclacquer TS Rookie Topic Starter


    Ok. I got a little info from the store manager. On sat he shut the computer down using the start menu and then turned off the monitor. He did not wait to see if the computer actually shut off. This morning he came in and saw that the power button was still on. When he turned on the monitor he saw the blue screen of death.

    There has been no installation of hardware for at least a year, and no instalation of programs for about 6-9 months.

    Are the two above issues related?
    What could be the root cause of this problem?
    and, of course, how can I go about fixing the issue?

    If the problem is too bad, should it be possible to slave the HDD into another computer to get the data (documents, etc) off of it without jeopardizing that computer?
  3. mflynn

    mflynn TS Rookie Posts: 2,655

    First try a System Restore to a day or so before this issue began.

    If that works then get back to us and do not proceed below!

    If it does not work then proceed below!

    OK you seem to have eliminated a lot so lets now eliminate malware and at the same time I will see some of your configuration.

    Boot to Safe mode networking and do the below..

    Do the below

    Lets get rid of some unnecessary Services will improve performance and may turn off a culprit that could cause this.

    Left Drag mouse and Copy for Pasting all text in the box below. Make sure the slider bar goes to bottom from the @ to the end of the second exit.

    Then paste to the black screen of an open command prompt. All may not apply so ignore errors.

    @echo off
    sc config Alerter start= disabled
    sc stop Alerter
    sc config AeLookupSvc start= disabled
    sc stop AeLookupSvc
    sc config ClipBook start= disabled
    sc stop ClipBook
    sc config Dfs start= disabled
    sc stop Dfs
    sc config FastUserSwitchingCompatability start= disabled
    sc stop FastUserSwitchingCompatability
    sc config TrkWks start= disabled
    sc stop TrkWks
    sc config TrkSvr start= disabled
    sc stop TrkSvr
    sc config DNSCache start= disabled
    sc stop DNSCache
    sc config ERSvc start= disabled
    sc stop ERSvc
    sc config HidServ start= disabled
    sc stop HidServ
    sc config PolicyAgent start= disabled
    sc stop PolicyAgent
    sc config CiSvc start= disabled
    sc stop CiSvc
    sc config IsmServe start= disabled
    sc stop IsmServ
    sc config kdc start= disabled
    sc stop kdc
    sc config LicenseService start= disabled
    sc stop LicenseService
    sc config Messenger start= disabled
    sc stop Messenger
    sc config Netlogon start= disabled
    sc stop Netlogon
    sc config NetTcpPortSharing start= disabled
    sc stop NetTcpPortSharing
    sc config mnmsrvc start= disabled
    sc stop mnmsrvc
    sc config NetDDE start= disabled
    sc stop NetDDE
    sc config NetDDEdsdm start= disabled
    sc stop NetDDEdsdm
    sc config NtLmSsp start= disabled
    sc stop NtLmSsp
    sc config SysmonLog start= disabled
    sc stop SysmonLog
    sc config RSVP start= disabled
    sc stop RSVP
    sc config SSDPSRV start= disabled
    sc stop SSDPSRV
    sc config upnphost start= disabled
    sc stop upnphost
    sc config WMPNetworkSvc start= disabled
    sc stop WMPNetworkSvc
    sc config WmiApSrv start= disabled
    sc stop WmiApSrv
    sc config WmdmPmSN start= disabled
    sc stop WmdmPmSN
    sc config RemoteRegistry start= disabled
    sc stop RemoteRegistry
    sc config RemoteAccess start= disabled
    sc stop RemoteAccess
    sc config SCardSvr start= disabled
    sc stop SCardSvr
    sc config TlnSvr start= disabled
    sc stop TlnSvr
    sc config UPS start= disabled
    sc stop UPS
    sc config WebClient start= disabled
    sc stop WebClient
    sc config DNSCache start= disabled
    sc stop DNSCache
    sc config JavaQuickStarterService start= disabled
    sc stop JavaQuickStarterService
    sc delete JavaQuickStarterService
    attrib -h -s -r /s c:\jqs.*
    del /f /q /s c:\jqs.*
    sc config RpcSs start= Automatic
    sc start RpcSs
    sc config RpLocator start= Automatic
    sc start RpcLocator
    sc config MSIServer start= Automatic
    sc start MSIServer
    netsh dump >"%USERPROFILE%"\Desktop\savenetwork.txt
    netsh interface ip delete arpcache
    ipconfig /flushdns
    ipconfig /release *
    ipconfig /renew *
    ipconfig /registerdns
    nbtstat -RR
    netsh int ip reset
    Run CCleaner (get SLIM at bottom no Yahoo toolbar)
    Run twice or more on Cleanup temps, then on left click Registry then Scan for issues also repeat till clean.

    Run ATF-Cleaner Temp and Registry, repeatedly until no more found.

    Fantastic cleaner. (When installing uncheck Relevant Knowledge do not install)
    Start-Programs-Accessories-System Tools-Disk- System Restore and create a new Restore point. Name it "Cleanup at TechSpot".

    Then Start-Programs-Accessories-System Tools-Disk Cleanup
    Click OK to accept C:
    Select all Boxes
    Then click More Options
    Here click System Restore and OK to "Are you sure" and the OK to Run.

    As this runs it clears all but the most recent Restore Point but it does one other thing that can contain infested files and a huge amount of disk space.

    It clears what is known as Shadow copies which are used by specialized back up programs.

    This is if you have the Volume Shadow Copy running which is the default.

    Reboot to see if anything changed!

    If it boots to normal now continue next...

    Do the TechSpot 8 steps:

    If it does not boot to normal then back to Safe Mode networking and do the above.

  4. bclacquer

    bclacquer TS Rookie Topic Starter

    Thanks. I will try it. I do have one question. When I try to boot into regular safe mode the computer hangs at the line "...mup.sys". Will booting in safe mode with networking get past that?
  5. mflynn

    mflynn TS Rookie Posts: 2,655


    MUP.SYS is not the problem either, it is the next driver after mup that is the problem. And that is usually the Video controller.

    Boot to the Advanced Boot Menu again and try these steps in the order below.

    1st Choose Enable VGA Mode.

    Only if the above does not work

    2nd Choose Last Known good configuration.

    I'll be here another 30-45 Mins.

  6. bclacquer

    bclacquer TS Rookie Topic Starter

    I already tried "last known good configuration" didn't work. I forgot to put that in my above description.
  7. mflynn

    mflynn TS Rookie Posts: 2,655

    Then what about VGA Mode!

  8. bclacquer

    bclacquer TS Rookie Topic Starter

    I will have to try that. I was wondering if because last know good configuration didn't work would the other.

    I will have to try the above and report back. I will be unable to try these fixes until Wednesday. I will post if they work or not. In the interim, if there are any other fixes or causes you can think of, please let me know.
  9. mflynn

    mflynn TS Rookie Posts: 2,655

  10. bclacquer

    bclacquer TS Rookie Topic Starter

    ok. I had my co-worker try to start it in VGA mode. He said Check Disc ran and everything checked out. Then windows booted. After the desktop came up, two errors occurred. The first was winlogon.exe then came "a serious error has occurred". then the blue screen of death again. Same message "page fault..."
  11. bclacquer

    bclacquer TS Rookie Topic Starter

    Ok. I did a repair install of XP. When it started normally I got the "windows has recovered from a serious error" message and then "Winlogon.exe has experienced a problem..." error message. After closing both boxes, the "windows has recovered..." message popped again. This came up every time I closed. It did not go to the blue screen, but I may not have waited long enough, as in the recent past those two errors would pop then shortly after I would get a blue screen.

    The repair install fixed the issue with the safe mode start. I will now attempt to fix the other issue.

    I am trying to do your first fix, but I was reading trough the instructions and have an issue. It says to create a system restore point. I can't I tried to open system restore and it is turned off. I can't turn it on because windows crashes in regular mode.
  12. bclacquer

    bclacquer TS Rookie Topic Starter

    It works now!! Thank you. I did everything above and the computer appears to be working just fine.
  13. mishink7

    mishink7 TS Rookie

    i have the same problem as bclacquer with this page fault bsod. I tried the xp repair and i ran chkdsk and nothing works still. I still get that BSOD every time i start up in regular and safe mode.

    I ran memtest and my ram is fine also. I do not know what could be the problem. Is there a next step that I could try mflynn?

  14. WangVS

    WangVS TS Rookie

    Hey, folks... while physical memory problems can cause a wide variety of symptoms, a "Page Fault" is not a fault at all and not an indication of a physical memory problem. "Page Fault" is operating system terminology for an attempt to access memory in a page that is not presently in memory, but has to be paged in before it can be used. A page fault in a non-paged area is most indicative of a bug in the operating system, or a problem caused by an application affecting the operating system.

    I am presently having the dreaded "WIN32K.SYS Page Fault in non-paged area" BSoD. It began happening when I upgraded from a pair of 20" monitors to a pair of 24" monitors at higher res. Also around the same time I installed Ultramon, a management utility for multiple monitors. I have already increased my page file size, and next I plan to uninstall Ultramon. I already have ECC memory, so I really don't think I have memory errors, nor would memory errors necessarily cause apparent incorrect page faults.

    A page fault is not a fault in the conventional sense. It is a signal from the CPU chip to the operating system that a page has to be loaded into memory before the current process can continue. If the OS decides that the page fault occurred in relation to non-paged memory, then the OS is deciding that it has an internal problem or a problem in a particular program. Win32k.sys is a system module, probably something to do with running 32-bit apps in my 64-bit OS. My bet is on a Microsoft bug. Too bad it continues for so many people.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...