Page_Fault and Bad_Pool_Caller minidumps

By Ainex ยท 13 replies
Feb 16, 2007
  1. Hello all,
    I am at a loss as to where to proceed from this point so I've come to you. My computer has off and on had bsod errors since I built it but they were so infrequent I never got around to fixing it. Well now it's come back with a vengeance. At first I thought it might be a heating issue as my processor was running VERY hot (79 degrees C) so I bought a new heatsink which has brought that down significantly but hasn't alleviated the problem. Over the last year I've experienced Page_Fault_In_Non-Paged_Area, Bad_Pool_Callers, and IRQ_Not_Less_Than errors but by far the most common is the page fault error which I'm now seeing every time I log into non-safe mode windows. After 30s or so the computer bsods with the 0X00000050 Page fault stop error. I reseated the RAM; dusted my rig; ran memtest86, windiag, and checkdisk all with no errors found. I've dug through the help pages on oca and googled for threads regarding this error with no real help found. I am hoping one of you will analyze my minidumps and perhaps narrow down my problem to a device or driver (or whatever).

    Any help you can provide will be greatly appreciated
  2. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    All the minidumps have the same symptom. The bugcheck is different but the stack trace is exactly the same.

    b41d1c3c 805823e8 c3fffffe 00000000 e3a4b950 nt!ExFreePoolWithTag+0x23a
    b41d1c58 805928c1 e38ea7e8 e3a4b950 e102c250 nt!CmpCleanUpKcbValueCache+0x51
    b41d1c6c 8059296e e38ea7e8 e2397b60 80571f3d nt!CmpCleanUpKcbCacheWithLock+0x1a
    b41d1c78 80571f3d b41d1c8c 80571f1e e3a4b950 nt!CmpGetDelayedCloseIndex+0x16
    b41d1c80 80571f1e e3a4b950 b41d1c98 80571e4a nt!CmpAddToDelayedClose+0xa
    b41d1c8c 80571e4a e3a4b950 b41d1cb0 80572561 nt!CmpDereferenceKeyControlBlockWithLock+0x38
    b41d1c98 80572561 e3a4b950 00000000 e3ab11d8 nt!CmpDereferenceKeyControlBlock+0x12
    b41d1cb0 8056c78f e3ab11f0 00000000 e3ab11d8 nt!CmpDeleteKeyObject+0x92
    b41d1ccc 804e1957 e3ab11f0 00000000 000001be nt!ObpRemoveObjectRoutine+0xdf
    b41d1ce4 8056ea9e 884d5a20 e1665140 8988ed28 nt!ObfDereferenceObject+0x4c
    b41d1cfc 8056e9bc e1665140 e3ab11f0 000001be nt!ObpCloseHandleTableEntry+0x155
    b41d1d44 8056ea06 000001be 00000001 00000000 nt!ObpCloseHandle+0x87
    b41d1d58 804dd99f 000001be 0007fb40 7c90eb94 nt!NtClose+0x1d
    b41d1d58 7c90eb94 000001be 0007fb40 7c90eb94 nt!KiFastCallEntry+0xfc

    Probably your windows is infected with virus or spyware. If you do not find any vrius at your windows, boot your windows at safe mode and let it running for an hour. If your windows does not crash at safe mode, we can confirm that it is software error. Otherwise it is hardware problem.

    It may also related to the firmware of the BIOS. Upgrade the BIOS may resolve the problem.

    I also find your windows has the device driver PxHelp20.sys. It may belong Veritas, Sonic Device Driver, AnyDVD, component of Music Match. You can do some research at google and it maybe the culprit.

    PxHelp20.sys Wed Jun 07 04:08:29 2006 (4485E0BD)
  3. Ainex

    Ainex TS Rookie Topic Starter

    Well if it is a virus or spyware then it has managed to survive a complete reformat. The system does run stably in safe mode but I have a new problem mode hangs after loading mup.sys. Once or twice it hung there but rebooting solved the issue. Now it hangs every time I try to load safe mode. The Pxhelp20 driver may very well have come from AnyDVD which I think I've had on the comp since reformatting last but I don't know how to access it outside of safe mode. Same with flashing the bios.
  4. tweaks_sav

    tweaks_sav TS Rookie Posts: 186

    Try checking the motherboard for "busted" or "leaking" capacitors. Capacitors' tops should be flat. Any budging or leakage at the top is sign of bad mobo. Bad caps make a system uber flakey,
    Identifing Bad Caps
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    for specialized motherboards, there are places that will do a total cap replacement. But for normal boards, replacement is recommended
  6. Ainex

    Ainex TS Rookie Topic Starter

    Well repairing the windows installation got me past the mup.sys hangup allowing me to access safe mode. The system will crash while in safe mode but only if I start accessing programs like ie and firefox. So if the system runs stably at the desktop in safe mode can I exclude hardware as a problem and focus on software? I renamed and moved the pxhelp20.sys file and Nero gave an error message so I tried uninstalling Nero to no avail. I also checked my board for any leaking/bubbled capacitors and nothing looks wrong but I confess that I have never seen a broken one other than on that webpage link. As for flashing the BIOS I run into a problem: With the 'windows' mode BIOS update I get an error that says "There is a programming error" and it will not run the update. With the iso bios update I created a boot disk with the files on it but I can't seem to get it to work using the instructions on the ms support page. This problem has been persistant through two complete reformats now (although it used to be a once a week thing and is now an every time thing) so it might be a common program I install after every reformat but I'm not sure where to start looking. Here are some new mindumps...not sure if they are of any use. Any other suggestions? If it is possible that it's a hardware malfunction what should I try replacing first given a small budget and the fact that I don't have an extra mobo or vid card to plug in.
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    here's what the minidumps point to:

    Hardware Error, IP Misaligned
    Memory Corruption
    NTKRNLMP.exe- May be related also to bad memory
  8. Ainex

    Ainex TS Rookie Topic Starter

    Thanks for your help guys I'm pretty sure I've got the issue fixed. I reinstalled windows and bypassed the NTKRNLMP installation with f7 and then reenabled HT once windows was installed.

    But now I've created a new problem for myself...since I wasn't sure if I had solved the problem and because I finally had access to windows I decided to flash my BIOS using the windows express version. It all ran fine and successfully updated but now I have a half dozen device driver errors in device manager. All are Intel(R) 82801 FB/FBM PCI Express Root Ports - 2660, 2662, 2664, 2666, and 2581 respectively. I've tried updating the driver but all I get is a windows tech window saying I likely have a BIOS problem. So I ran the BIOS flash update again this time using the .iso on a bootable cd and again it said it completed the operation successfully but still did not solve the problem. Any ideas? I can't seem to find anything on a google search.

    The updates I'm installing are for the intel D915PBL board at:* XP Professional&lang=eng
  9. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    hallmark sign of bad or failing ram. Check your ram with memtest86+. Run for at least 7 passes. any errors are bad.
  10. Ainex

    Ainex TS Rookie Topic Starter

    I've already run both windiag and memtest86 for over 8 hours each with no reported errors. I've also tried removing my two old dimms and only using my two new ones. I'll try running just one stick of my new ram.
  11. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    All this may be leading to a failing motherboard or power supply too
  12. Ainex

    Ainex TS Rookie Topic Starter

    Given the mounting evidence and the fact that even with one dimm in I have the same errors I am going to surrender and try replacing the mobo and psu. Thanks again for the help.
  13. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Good Ainex,
    a good time to upgrade to something better ;)
  14. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Your windows crashes at safe mode is the symptom of hardware error. Maybe it is firwmare error of the m/b. Try upgrade the BIOS b4 you replace the m/b.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...