PC freezes randomly only when I use my Nvidia graphic card but not my default card

Hello! I have a newly built desktop (PC's specs are listed below) for around 1 month but it has been frozen randomly, like when idling, google chrome, it happens around every 5 to 12 hours (normally), sometimes it won't freeze even I leave it idle overnight for 12 hours but sometimes just few mins after reboot, nothing is working when the problem occurs, not the keyboard, mouse and just a freezing screen (no bluescreen or error window) I have to do a hard shut down everytime. However, when I plug my monitor HDMI cable from my graphic card (RTX2080) port to my motherboard HDMI port (and my device manager will show a new display adaptor: Intel(R) UHD Graphics 630), my PC won't freeze anymore (at least 24hrs so far). I am really noob about PC stuff so I wonder if it really my RTX2080 graphic card problem? I saw some people have the similar problem but not exactly same as me said SSD, PSU or motherboard is the main problem actually. So I hope if anyone can tell me how to find out the possible cause(s) in case I spending more money on a normal hardware. The methods I have tried are list below too. Thanks so much
smile.gif


new update:
  • I just found out if I leave my PC idling and not using any other program intentionally (I.e. just idling on desktop and leaving some basic softwares, programs on e.g., anti-virus software, network), my PC wont freeze even I am using the RTX 2080 graphic card
  • using FurMark for testing my RTX2080 graphic card for around 15 mins and no freezing or crashing
  • Joulemeter Taskbar shows my PC power consumption is under 200W even under the FurMark test
My PC's OS:
Windows 10 Home 64-bit Full Version Box USB

My PC's specs:
- CPU: Intel i7-8700K (3.7GHz)
- Graphic Card: MSI RTX2080 GAMING X TRIO OC Edition 8GB GDDR6 3 Fans
- MB: ASUS ROG Strix Z390F Gaming
- RAM: G.SKILL Trident Z RGB DDR4 3600MHz (2x8GB)
- SSD: Samsung 500GB 970 EVO M.2 NVMe
- HDD: WD Blue WD10SPZX 2.5" 1TB 5400rpm 128MB Cache SATA3
- Cooling: NZXT Kraken X62 Water Cooling
- PSU: Corsair RM750X 750W 80Plus Gold
- Network Adapter: ASUS PCE-AC88 AC3100 Dual-band 4x4 PCIE Wireless Adapter

Methods I have tried but all failed:
  • Memtest86 (free version) and no error founds
  • Windows Clean Boot (but some programs can't be disabled in System Configuration like "AsusUpdateCheck")
  • Reinstall Windows (clean install) (by my Windows 10 Home 64-bit Full Version Box USB)
  • Update all drivers in the Device Manager (I manually select all drivers and search updated driver software automatically)
  • Download and update my graphic card, SSD, Motherboard, Network adaptor drivers from its official website
  • Windows Update check is latest
  • Look at the Event viewer (administrative events) and no possible error/warning founds
  • Look at the Task scheduler
  • Update BIOS
  • BIOS set to default
  • In my BIOS changing "primary display" from "AUTO" to "PCIE"
  • In my BIOS changing "Above 4G Decoding" from "Disabled" to "Enabled"
  • Change my HDD SATA power Cable
  • Use avast Cleanup
  • Uninstall all third-party Anti-virus software (just leaving the Windows defender on)
  • Use 2 RAMs together OR try each RAM individually on my motherboard A2 RAM port
  • Turn on my GPU's fans by MSIAfterBurner all the time (my GPU's fans won't run if temperature is below 60°C by default)
  • Observe my CPU, graphic card & RAM's condition, the temperature, loading were normal right before freeze
  • Clean PC's temp file
  • Adjust virtual memory
  • Run windows disk check
  • Run a windows system file check
  • Turn off Link state power management
  • Set my PC power plan to highest performance or balanced
  • Set my Hard Disk "turn off hard disk after __" to never
  • Turn off all windows background apps
 

Cycloid Torus

Posts: 4,842   +1,662
You are not a noob. That is an impressive list.

Based on description, I would think it is a 'sleep' or 'hibernate' issue. The rub is that the IGP runs 24 hours clean, but there are low system use freezes with the discrete GP in use. I read, but know little, about some Micron GDDR6 issues - so a chat with MSI might be productive.

Otherwise, a few ideas (more like guesses):
- Device Manager device Properties 'Power Management' tab - are any of them checked for 'Allow the computer to turn off this device to save power'
- Control Panel / Power Options / Choose what power buttons do - check to be sure it is the away you want it

Thanks for the brain teaser.
 
Late update, if someone facing the same problem, here is a possible temporary fix:

  1. when your PC is off (shut down), you can first plug your HDMI cable to your internal GPU (to the mother board)
  2. then turn on your PC and log in windows
  3. plug the HDMI cable to the external GPU (e.g., RTX2080)
  4. Then open device manager (in my case there are two adaptors under the display adaptors: Inter(R) && NVIDIA), I hv found that the FPS of your PC will be much better if you disable the Intel(R) driver (internal GPU), but your PC wont freeze even if you keep it enable (u can test and decide yourself)

If you have the same problem as me and using this temporary method, your PC wont freeze if you keep turning it on (or even in sleep state), all softwares and tasks are fine, however, once you turn the PC off and restart, the freeze problem will occur again if u leave the cable in the external GPU port all the time. So u hv to do the above steps again. Please noticed that the above steps must be in the same order.

Notes:
I) if you restarted your PC when the HDMI cable is on the external GPU port, you may turn into black(grey) screen once u log in windows again, then u hv to shut down PC and redo the above steps (or u can just restart PC again with the cable on the external port but u will experience the random freeze problem)
ii) if u turned the internal driver off in the device manager, once u restart the PC, the driver will remain off, and if u switch the cable from internal to external GPU now, you may experience bugs in the desktop, e.g., all the icons in the desktop are gone. so u hv to turn on the internal driver when ur HDMI cable is in the internal port, then switch the cable, finally turn off the driver again
iii) I prefer to turn my monitor off (monitor only) when switching the cable from internal to external port
iv) there may be potential problem by using this temporary method but for me everything seems normal so far (for around 0.5 year) except u hv to keep restart the PC and repluging the cable.

Hope this helps