PC only recognizes one device as USB 2 the rest as USB 1.1

By IWVC ยท 17 replies
Jan 30, 2011
Post New Reply
  1. Hi
    New member who has been looking round for help for a few weeks, hope you can help me. I've looked around the forum and come across some helpful mails but nothing that has been able to solve my problem.

    I have a home built PC around an Asus A8V-VM socket 939 motherboard (VIA VT8251) and Athlon XP64 3700 processor. My problem is that it only detects one device (a multiple card reader) as a USB2 device anything else is detected as USB2, but I get a message saying "this device will work better when connected to a USB2 port" or words to that effect. Windows then shows a list of available USB ports - 7 of the 8 USB2 available are free but I can't seem to find any way of connecting anything to them. Other devices will connect and are listed under different ports, but limited to USB1.1 speeds. Device manager shows one VIA USB enhanced controller and 4 VIA rev5 or later USB Universal Host Controllers. I've tried plugging devices into all available USB connectors - 4 on back panel and 2 on expansion bracket connected to internal MB risers with the same results.

    I've installed the latest motherboard drivers I can find and ensured that USB2 options are enabled in the BIOS set up. WIndows USB power management options are disabled.

    I'm lost for other possible solutions. At present the card reader is physically connected to the USB expansion bracket having a single USB lead from a 3.5" unit that plugs into a port. This is detected OK as USB2. However the 4 port hub built into my screen which is connected to the other port on this expansion bracket generates the "this USB hub would work faster when connected to a USB2 port" message.

    Any suggestions on ways froward before I try to find another motherboard?

    Ian C
  2. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    If you suspect that your system is missing some drivers, a quick way to find out is to download a program called Drivereasy. (just search that name).
    Install it and 'scan'. It will produce a list of all the components and devices on your pc that need or have a driver. Top of the list will be red items. That means 'missing from your system'. Next, orange, that means 'needs updating'. Last, green, which means, installed and up to date.
    You can download the drivers from this site, free, but they will take a long time. (To encourage you to buy the program- fair enough), but you can write the info down and go to the maker's site to get the file there.
    Hope that helps.
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I must admit there are still many "mysteries of USB" i have yet to figure out! :confused:

    Some additional things to try after mike's suggestion of using drivereasy to update anything USB related (including both chipset and device drivers). Then try the following in order

    1. Check ASUS. See if there are any BIOS updates. If yes, check their release notes to see if anything about USB fixes/improvements to decide if it's worth trying a BIOS upgrade

    > Disconnect power from your computer (turn off, unplug AC cord, remove battery if a laptop)
    > Disconnect power from USB devices (turn them off, unplug AC, remove all batteries)
    > I'd say wait at least a couple hours (i usually just do it overnight)
    > Then put it all together again. Bring up computer first.
    > If USB devices have a switch, they should be TURNED OFF when you replug USB cable. Then turn it back ON

    3. Then do: [post=875300]How to Cleanup and Remove old USB Storage Drivers[/post]

    4. See [post=751005]How to Reinstall Your USB Controllers and Motherboard Chipset Drivers[/post]. This is much easier to do if you can use non-USB mouse/keyboard or yoiu remote connect to your computer.
  4. IWVC

    IWVC TS Rookie Topic Starter

    Thanks for the suggestions lads, however I'm not getting any solution. I tried Driver Easy which identified an out of date USB2 driver. Ah-ha I thought, this will do it but after installing the new driver I still get the same problem.

    It's mystifying since at the moment I have a generic memory card reader and a USB2 hub (integrated into the Dell Screen) connected to the same motherboard USB riser via a 2 connector extension bracket with one device, the card reader, registering on the 'VIA USB2.0 Enhanced Host Controller' and the other on the 'VIA rev 5 or later USB universal host controller' in device manager. When I plug in anything to the screen's hub Windows keeps throwing up the same message that 'this usb device can perform faster if you connect it to a Hi-Speed USB2.0 port. For a list of available ports, click here' which then shows The VIA USB2.0 Enhanced controller, Root hub(8 ports), the USB Mass storage device and 7 empty ports.

    I've checked Asus for BIOS upgrades but there are none (its an old MB which doesn't help) and found the latest (2009) motherboard drivers. Asus help suggested using the original drivers that came with the board - but I do not have the original installation CD (MB was a "tested" Ebay purchase). I've tried all manner of start up proceedures with and without USB devices connected with no difference.

    I will use the procedures on USB clean up and re-install to see if that will work, but I really can't understand why two devices plugged into the same pysical port will be sensed differently!

    Ian C
  5. IWVC

    IWVC TS Rookie Topic Starter

    Solved (I think)

    OK here's the latest. Disconnected all USB devices except mouse (printer, scanner, Topfield digital TV recorder, Logitech headphone / microphone, USB2 Memory stick) and reconnected one by one. To cut a long story of swapping connections around I think I've discovered that if one USB1.1 device is connected to the USB2.0 Screen hub, it confuses the system. My old Epson scanner is an early USB model (but which works pefectly well) as is possibly my HP deskjet printer. For convienience these were allways connected via the screen hub. Now they are connected to the ports on the back of the PC. USB printing support, mouse and Epson scanner now all link to a VIA rev 5 or later USB universal host controller whereas the Topfield, Card reader and Screen hub (after rebooting it by switching screen power off and on) and connected headphones now link to the enhanced USB controller.

    Didn't know that connecting a mix of USB 1.1 and 2.0 devices via a hib could cause such problems.

    Ian C
  6. IWVC

    IWVC TS Rookie Topic Starter

    Interesting..... When I re started later this evening I found that if anything was attached to the screen Hub (USB 2 memory stick and Logitech Headphones) it was connected as a USB1.0 device - but threw up the warning that it would work faster if connected to a USB 2 port etc. Re starting with nothing attached it is detected as a USB2 device and attached to the enhanced controller. Adding the same devices after the hub has been detected doesn't cause a problem.

    Never had this problem with my previuos build (Abit socket A board with USB2).

    Ian C
  7. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Very good. I have a Dell screen with 2 USB ports on the right hand edge, and one underneath, never used them, but will remember about this in case I ever need to.
    Good too that Drivereasy found an out of date driver, it's a handy program, even just using it for the info it gives, it's not perfect but, it's worked for me on several pc's through 2010.
  8. IWVC

    IWVC TS Rookie Topic Starter

    Just in case anyone is still following this - or comes across it looking for solutions to similar problems - I stil have problems with the Dell screen's integral USB hub. About 75~85% of the time it will be recognised as a USB1.1 device (regardless of anything being connected to it) and Windows will throw up the " this will work faster if connected to a high speed port etc." message. Device manager shows the Hub connected to a normal port. But sometimes, and through no changes of boot up sequences I can see, it will be recognised as a full high speed USB2 device and connect to the enhanced USB contorller. I've got in the habit of checking the connection when I DON'T get the warning message from Windows.

    Very frustrating, perhaps it is a Dell hub issue but it uses the standard Windows (XP SP3) drivers so it shouldn't be a drivers. I'm just learning to live with it and will probably buy a new case with USB ports on the front panel rather than use the (up to now) very useful ones on the side of the screen.

    Ian C
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I don't have the answer to yet another USB mystery. But I can offer some tools and some info (as in my own conclusions about USB, so don't take it as "gospel". If you find otherwise or reach other conclusions, please let me know!)

    >> A quick overview (as i understand things)
    1. Every USB Controller has a Root Hub. Both the controller and root hub are on your motherboard
    2. USB devices may connect directly to a USB port or to a hub (which would appear in Device Manager as a "Generic Hub")
    3. Typically the routing decision of a device from USB port to a specific Controller/Root Hub is dynamic. (i.e. the system decides how to route it when you connect the device to the port. In some earlier computers, there was some limitation e.g. front USB ports could only be routed to USB1.1 controllers
    4. USB 2.0 controllers will be named USB2 and/or have the word Enhanced as part of its name in Device Manager

    >> More stuff
    • Hubs are responsible for sensing the devices connected to them and then propagating that device info further up the USB chain till it finally reaches the Root Hub
    • A USB device must indicate its speed by pulling either the D+ or D- line high to 3.3 volts. (see USB in a NutShell). So i'd guess a problem with either a device signalling its speed OR a downstream HUB failing to sense/pass along the info could be problematic

    A very simple (yet i think little used - maybe little known?) helpful tool is telling Device Manager to display devices by CONNECTION (by default it displays by TYPE). By Connection shows you how devices are connected to one another and dependencies

    Then expand the two ACPI devices till you see the PCI bus (the computer backbone for all plug and play devices) and start expanding all your USB controllers.

    Note that (by definition) a USB device is ONLY ALLOWED to present a single device interface to Windows. So you find a single parent/child chain (e.g. USB Mass Storage -> Disk Drive) where USB Mass Storage is the single interface) OR when single USB devices needs to provide multiple interfaces (e.g. a single wireless receiver for both mouse and keyboard) the USB device presents Windows the USB Composite Device interface (USB Composite Device is the single interface to Windows. The Composite Device can have multiple "child" chains such as one chain for the keyboard and another for the mouse

    Does the Dell Monitor appear as a single Generic Hub? or might it have more then one Hub inside it?

    /* EDIT */
    Look at my screen shot example. You can see
    > I have a WD external drive connected to my computer USB port (its device connection is routed to the USB2 Controller/Root Hub)
    > I have an external USB hub. Which, itself, contains an internal USB hub within it. My wireless Logitech mouse/keyboard transceiver is connected to the external USB hub. The USB hub is routed to my USB2 controller.

    /* EDIT2 */
    I don't know that any of the above will lead to a solution for the Dell Monitor issue :confused: but you might find it interesting/educational (in which case, please let us know what you find! :) ) if you check devices by CONNECTION to see how device routing to controller varies for those times things seem to work VS. those times when it's not working correctly
  10. IWVC

    IWVC TS Rookie Topic Starter

    Hi, Thanks for the suggestions. They are a very useful summary of USB connectivity but one way or another I've already covered most of this ground over the past few weeks!

    The problem with this particular Dell Hub is that it sometimes loads as a slower speed USB device. Windows appears to recognise it is capable of higher speeds and throws up a warning that it shoul dbe connected to a high speed port. As you suggested if you look at device manager it usually appears under the low speed USB Host controller but sometimes correctly under the enhanced USB controller. Not sure if i have the correct way of posting pictures but hopefully this link http://i766.photobucket.com/albums/xx308/iwvc/Devicemgr.jpg will show my current device manager with the USB hub where it should be under the Enhanced controller. There are two generic hubs listed, the first is the Dell hub with a USB composite device (which is a Logitech headphone/ microphone in this case) and the sub-entries related to thet device. The second generic hub is internal to the Topfield Video recorder (no other ports are user accessible on this device) and is physically connected to the USB connector at the back of the PC. The third device is a generic memory card reader which is also physically connected to a different USB connector at the back of the PC.

    However more often than not the Dell hub is listed under one of the VIA rev 5 or later host controllers with anything then connected to it unable to run at higher speed.

    It is an annoying problem. As my case does not have front USB connectors I have always used the very convienient Dell ones when using USB memory devices. Restricting these to USB 1.1 speeds is frustrating. Using headphones and web cam for, say, Skype isn't a problem as they will run as USB1.1 speeds anyway.

    I'm coming to the conclusion that it must be a problem with the Dell hub being recognised - as other devices don't seem to suffer. (but why does Windows recognise it is capable of running as a faster device and display the warning?) I can either buy a separate powered USB hub to use instead of the Dell one or a new case with front ports - which I suppose would be neater but more expensive as I need a quality case to keep noise down as the PC is in the living room.

    Ian C

    Having read the link on USB in a nutshell I think my prblem must be the Dell hub failing to signall its speed properly. The hub probably identifies itself to Windows as a High speed device (its very confusing that speeds are low, full and high with two speeds avaialable in USB 1.1 ??) which throws up the message since it isn't Windows itself that determines how it is connected to the PC internals.
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Actually, that's still a good question i'm not sure i know the answer (re: Windows giving the message for USB2 devices as in your case)
    > 1. On second read, i notice a USB 2.0 device is supposed to first negotiate with the controller for a USB1 speed connection for itself
    > 2. After that's done, a USB2.0 device is supposed to "re-negotiate" with the controller for USB2 speed (also see HERE)
    That's how they do "backward compatibility".. which still doesn't explain how Windows knows its USB1 vs USB2 unless it somehow get's the message that it identified itself HI-speed via the hardware but sees its still connected to a USB1 controller (so it then generates its user message)

    That said, question is: Once the Hub is connected to the USB2 controller do you see it change sometimes on a reboot? Also, i don't know that these will make a difference but they're easy to try
    1. Look at [post=875300]How to Cleanup and Remove old USB Storage Drivers[/post]. I just tried on my own machine, i found if you also disconnect the hubs when you do the cleanup, Cleanup will also remove all the old Generic Hub drivers still installed on the machinel. If lucky, maybe that might make some difference to cleanup

    2. I;ve also seen this trick work for the case where no devices are recognized on USB ports so is just a shot in the dark for your problem, but shutdown computer. Disconnect all the USB ports. Unplug BOTH your computer as well as your Dell monitor (removing the AC plug is important). Let them stand for an hour or two without any AC power connected. Then plug stuff back in and reboot

    /* EDIT */
    Other question (just as now am curious)... Once the hub connects to a USB2 controller and things are OK, is it all a crap shoot how it connects again on reboot? Or do you do anything other then reboot when you find its connected USB1 again?

    /* EDIT 2 */
    Ooopps. Sorry, i see you already tried the cleanup. (I forgot you mentioned that. Think i've been reading too many different threads) :eek: :D
  12. IWVC

    IWVC TS Rookie Topic Starter

    Hi LookinAround, thanks for persisting in trying to solve my problems.

    It seems totally random which way it connects. Yersterday and today both USB2, most of the last month USB1.1. SOMETIMES switching the monitor off and on without rebooting PC (Dells recommmended way of re-initialising the Hub) will correct a USB 1.1 connection to USB2 but often this will make life even more frustrating by returning a "USB device not recognised" error and a full reboot required to see it at all!

    I confess I haven't yet stripped out all USB drivers and re-installed, I was sidetracked by a process of connecting devices via the different pysical connnectors on the motherboard, which improved things (see my earlier posts) and pointed at the Hub being fussy about anything connected to it at the time of booting the PC. My windows XP was installed complete with SP3 which has the latest generic USB drivers and Dell do not provide thier own drivers for the Hub. The windows driver is used sucessfully by other USB2 compatible hardware.

    Yes I've sort of tried this by shutting down everything overnight including the power to the monitor but there is no consistent effect on which way the hub is sensed on boot up.

    Having had sucessful USB2 connections for 2 days running I'm now living in hope of a consistent run :confused:

    Ian C
  13. IWVC

    IWVC TS Rookie Topic Starter

  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Wow. What a saga! Given all you've done to date, you've certainly staged a valiant effort!

    You're probably referring to [post=751005]How to Reinstall Your USB Controllers and Motherboard Chipset Drivers[/post]. It's worth a shot tho i must admit, i'm not optimistic

    Getting an external USB2.0 hub is probably the simplest solution. If you go that route
    > Get a "self-powered" hub (get one with it's own AC adapter) and
    > Get one that offers 1000mA ports.

    USB spec says that USB ports should provide up to 500mA. Problems arise when sometimes computers (more so laptops, but still any computer may) fall short of spec. Combine this with some devices like portable drives (WD portables used to be notorious for this) would sometimes exceed spec a bit. Combine a port falling short + a device wanting more = device problems.

    That's why you can find USB "Y" cables for sale which plug into 2 usb ports to provide twice the power to a power hungry USB device.

    So if you're going to get a USB2 hub anyway, may as well find one that provides the 1000mA so you have it if ever handy. I have an earlier version of this Targus hub. The two ports on top provide 1000mA, others are the 500mA spec
  15. IWVC

    IWVC TS Rookie Topic Starter

    Hi LookinAround

    You don't know the half of it! It started with me buying some photo editing software. Despite asking the PC spec required to drive it and being told that as long as I was using Win XP and had a decent amount of RAM ( I have 1 Gb) it would run I discovered that the programme needed a specific operating set within the processor and my Socket A AMD Athlon XP 3000 didn't have it. I was about to return the software when i spotted an AMD Socket 939 board with Athlon 64 processor on e-bay. As the board would allow me to use the existing RAM (DDR 400) and let me run the SATA hard disks at full speed (the previous board would only run in SATA1 form) it seemed to be a good idea...........

    Having got the board from e bay I fitted it in my existing case after a struggle with 20 pin power supply connector and 24 pin board to find ....it didn't work (this is a shortened version of events). Re-fitting my original board to the case resulted in that not working either. Much pondering and a change of power supply later, I discovered that the power on/off switch on the case had developed a fault. Dragged an old PC out and gutted case of motherboard and pentium 3 processsor to use for total rebuild. My original case had nice front mounted USB2 connectors, the old one, although a better quality case, doesn't.

    Eventually installed 939 motherboard, XP 64 processor and 2 SATA 2 hard discs in old case, reinstalled clean copy of Windows XP and SP3 and thought "at last it goes". It did but was incredibly noisy (my PC is based in the living room and was drowning out the TV for my wife) One replacement heatsink and fan later silence (almost) prevails with most of the noise coming from the power supply fan.

    Never mind I now had a more up to date, better, faster PC to play with. That's when I discovered the USB1.1 USB2 issue ...............:eek:

    Ian C


    Because of all the hassle, I still haven't got round to trying the photo editing software either :rolleyes:
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Sounds like the story of Job! (just updated a bit) :D

    Hope you manage to get it all sorted out eventually. As someone once said "Who needs a hobby when you have a PC?" :rolleyes:
  17. IWVC

    IWVC TS Rookie Topic Starter

    Oh well the latest in the saga. I gave up on using the USB hub built into the screen and replaced the floppy drive with a powered 4 port USB2 hub picking up forn the other header on the motherboard. This seems to have worked with no problems in identifying them as USB2. The Dell screen hub was still connected as USB headphones and mic are happy with 1.1 speeds and it was more convienient to plug in there rather than reaching under the desk for the new front ports. However the Dell hub then started causing other problems either not being identified (coming up as unknown device) or causing power surge on the USB Root (1.1) hub - even though nothing was connected to it. I was beginning to conclude the motherboard was the problem as booting up also became erratic with BIOS reporting overclocking failure (it's not overclocked!) or chassis intrusion (that's not fitted either). Then this morning it locked up during booting and I couldn't switch off or reboot - the faint smell of burning plastic made a panic pull out of the mains plug. Turned out the power supply had failed (It was claimed to be rated at 600w well above that needed for the system, and wasn't very old) One replacement power supply later have a working system which seems to recognise the Dell hub as a USB2 item every time I boot up ...................

    Must be more than a coincidence but odd that the Dell hub seems more sensitive to power supply variations than anything else in the PC as everything else seemed to be working OK until the PS finally went into melt down.

    Ian C
  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Thanks for the update.

    A reminder that among all the other possibilities when things go wrong (BIOS, drivers, the Dell hub) the PSU is usually still another possibility to be considered in the mix!

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...