Plug and Play BIOS Extension - Code 39

By Meilei
Oct 22, 2008
  1. Hello,

    On and off I've been having a problem with my keyboard where it will sometimes decide not to work. My friend suggested that I check to see if the USB port was the problem behind it. So, I went into the Device Manager to take a peek for a faulty USB port, but instead discovered that the "Plug and Play BIOS Extension" had a yellow exclamation mark on it.

    When I had a look at the device status on it, it said:
    "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)".

    I have no idea what to do about this. I'm not a techie person, so I'm really lost.

    On a side note, this problem has also occurred with my mouse. And for the previous times that I had to deal with this problem, I just simply plugged the keyboard/mouse into another USB port and it worked fine after that. However, I just want to get this problem resolved, it's starting to worry me.

    I would greatly appreciate any help given.
  2. griggrog

    griggrog TS Rookie

    Hi Meilei

    Have a look at this page from Microsoft, it's quite long but just scroll down to the entry for Code 39.

    Good luck!
  3. Meilei

    Meilei TS Rookie Topic Starter

    Okay, so, I had my brother check the issue out for me. But I'm still confused about this situation as the keyboard still won't respond in the 2 USB ports that I had used from before when the problem first occurred months ago. The only reason why I'm able to type is because it's plugged into another USB port that I have never plugged the keyboard into until a few days ago.

    So, here's what we did:
    We tried what was instructed on the link provided by griggrog, but nothing happened. It tried searching for drivers, but it never came up with anything, just an endless search. So, seeing as we weren't sure if the keyboard was really the problem, we uninstalled the Plug and Play BIOS Extension and then restarted. The computer reinstalled it, and when we checked to see if the problem was still there, the exclamation was gone. However, when we checked to see if the keyboard would respond in the USB ports that it refused to work in, we realized that the keyboard was still not working in them. The exclamation now showed up under the keyboard category in Device Manager.

    The puzzling part about it now is: Just a few minutes ago I was telling me friend about it, and I was going to screenshot the problem to him, but when I went back into the Device Manager, the exclamation was gone. No exclamations on anything at all, and my keyboard still won't work on the 2 USB ports that it refuses to work in.

    My brother seems to think that the keyboard is the problem/faulty.
    My friend thinks that the computer is confused between USB ports and what should be communicating with what. And also something to do with IRQ? (I'm honestly lost.)

    Someone please help. I have no idea what's going on.

    One other thing: I plugged my webcam into the USB ports that the keyboard doesn't work in to see if it would respond, and the webcam worked.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...