Hardware Printer won't power on, tried everything

I took the back cover plate off on my Canon IPF760, jiggled some wires around and it started. I left the cover plate off in case I need to do it again.
Most printers today may require a physical POR (Power on Reset). For most, this means unplugging the power source, be it a single cord or AC adapter and reconnecting.

In the case of my wife's Canon Pro 100, I had to unplug the power cord (safety first) and pop out the power module, unplug the white DC connection from the module to the printer, then simply reverse the procedure. This reset the printer, and all was good.

FYI, there really are no repairable parts inside the module. Following the above steps may save the $ for replacing the module, or trashing out a good printer.
I fixed my iP4500. I think.

I had the same problem as above. My iP4500 is only 18 months old and rarely used, although I leave it on all the time. However, following a power outage, I couldn't get it to turn on. Tried different receptacles, pressing different button sequences, nada. It was dead.

I assumed the power outage had caused a surge, possibly blowing an internal fuse. After reading the posts above, I realized there was no fuse ... and perhaps the power outage had blown a circuit board, meaning the whole printer would be replaced.

I know nothing of electronics or circuitry. But I decided I had nothing to lose ...

I placed the printer standing on its front face (where printed paper comes out) to examine the bottom. I noticed the power cord isn't directly attached -- it is a removable plug which fits on two prongs mounted on the printer. I removed the power cord, then noticed the prongs are seated in what appears to be a separate module. Turns out, this module can be easily removed -- pressing in just two plastic tabs will release it. However, it now remains attached to the printer by a white plastic slide-on connector holding four colored wires. This white connector plug is easily disconnected, and the box-shaped module is now free. It measures about 6" by 2" by 2".

On the cover you will see a small silver hex-head screw. You will need a #4 mm hex socket to unscrew it. I used a screwdriver as a wedge to pry up this cover where it is seated on the other side. Out came the circuit board ...

I didn't see any burn marks or damaged-looking components on the circuit board. And since I come from the old school of "take it apart and put it back together to see if it works," I decided to fool around.

I directly re-connected the circuit board to the dangling white connector hanging from the printer. Then I re-attached the female end of the power cord to the two prongs. Next I plugged in the power wire to a receptacle ... then hit the ON button.

Voila! The power light came on and the printer started making noises. I immediately shut it down, then re-assembled the module and re-installed it in the printer. I then took the printer to my computer, reattached the USB wire, plugged in the power cord and turned it on again. After the usual warm-up noises, the thing is printing perfectly again.

I honestly have no idea if I actually "fixed" anything. Perhaps the power cord was loose from the prongs, or perhaps the wire connector wasn't seated properly before. But this whole effort took less than 10 minutes, and I can say my printer is now working just fine again. Maybe this will help someone else ..

Dear Timroperco, just want to thank you. I even did not need to open the cover itself with the small silver hex-head screw (because I had no such type in house). Just by deconnecting and reconnecting the white plastic slide-on connector and reconnect it, push the ON button and it worked. Much cheaper than buying a new printer. Thanks.


Posts: 93   +0
Another risk is that the logic board can be damaged by a faulty print head. Repairing a Canon is going to be a gamble, neither easy or cheap. I was quite impressed that apart from four screws at the rear the printer body is held together mainly by plastic tabs - easy to take apart if you can find them all without breaking anything. Oh well, you can't win them all.:)
I have owned at least three i560 printers for around 10 years. I never had an electronics failure until a month ago when all hell broke loose.
I had a spare 560 that I just placed in service, but there was problems with the printhead regarding clogging (nothing new). This elevated into the printhead shorting out, taking out the logic board. No power at all, and it wasn't the PS.

There are at least two printhead sellers on eBay who warn of this problem. The problem is how can you test a printhead to see if it is bad without taking out a logic board?? There is no visible signs on either the logic board or the printhead.

It has gotten to a point that I'm almost afraid to swap printheads (something I did many time in the past 10 years with NO issue).

BTW, the 4300 is the SAME as the 4500 other than age (the 4500 is one year newer) and the printhead (4500 has 1,000 additional nozzles). The cost of the replacement head for a 4300 is $48. For the 4500 its around $87 (current eBay prices shipped for a boxed head from China or Hong Kong.

That was the main reason why I looked for a 4300, not a 4500. ;)
Last edited by a moderator:
Does the printer plug directly into the wall, ie - just a wire? Or is there an AC to DC converter in line? If there is a "wall wort" or "brick" on the power line do you have a multimeter to check that it is delivering the correct (or slightly higher) voltage that it says it should.

I know practically nothing of electricity, so please make your response simple to understand. :)

I have a Canon ImageClass 8050Cn which I purchased in New Jersey, and then I moved to Chile. I purchased a 1500 transformer, unit unknown, and it was working just fine. I moved again to another home in Chile, and when I went to print, the printer began turning itself on, and then it turned itself off as if it didn't like something. I tried various outlets, with exactly the same response. I think that something is wrong with the electric power, because this is a farm house, and the workmanship is very poor. What do I do?

I appreciate your help. I really need this machine. I am going to go insane if I have to go to the stationary store once again to have my stuff printed badly after great effort.:p
1. Disconnect the power cable and the USB cable.
2. With the cables off, press and hold the power button down
4. Plug the live power cable into the printer while still pressing the power button.
5. Release the power button after 3 - 6 seconds
The printer should start up now and the problem should be gone.

This is actually not mine. Just got it from Tom's Hardware. I don't want to take credit for this brilliant but simple solution. This helped me a lot. I just want to share it.
Canon MB5020 2 months Old... :'( wouldn't power on

So I fixed it by detaching the power supply. It was rather easy to detach from the printer. When I detached the power supply, I noticed the power supply had some wires attached. I reseated the wires by detaching/attaching from the power assembly and directly back to the outlet and it now powers on. *nerd*(y) I win!!!
Timroperco for President 2020

I essentially used his fix on my Canon MB2320 which wouldn't power on. Bingo!

Power Supply has two hard to see clips, pulls right out. But you can't really get it all the way out because of the little white connector, just carefully pried it loose and then untangled the wires. Reseated it and lugged in the power cable and it fired right up. Thanks a million.
My iP4700 stopped in the middle of printing a page of labels & powered off. It cannot be powered back on no matter what I try.

The address labels that did print were missing people's first names. Some had "A.A." (without the quotes) in place of the first name. IOW the data somehow got corrupted.

The PSU is part# K30314 & labeled 32V and 24V. It has 5 blue wires going to it. I opened it up & nothing was burnt. That's before I found this forum. Not sure which pins to take voltage readings across because none appear to be ground, & taking readings from any pin to ground was zero volts. The circuit board had pin 1 labeled, which was the one near the edge of the board. I tried various combinations and it appears pin 1 is DC ground.

With the 5 pin white connector unplugged, pin 3 was 23.3V and pin 5 was 31V. Pins 2 & 4 were 0V.
When connected pin 3 was 8.3V and pin 5 was 10.7V. Pins 2 & 4 were 0V.

From reading through all the postings it appears there needs to be 5V on a signal lead. I don't know which one that is and have no idea what controls it but I'm presuming it's the logic board. I removed most of the case but could not see where the logic board or any other board is located. There may not be anything visibly wrong with another board but it's worth taking a look at just in case. It looks like some people have had luck by just unplugging & replugging the PSU connector. Maybe I'll get lucky & it's a loose or poor connection to another board.

Where do I look for the logic or motherboard? What do I have to disassemble?
Thanks in advance for any suggestions.
I found the logic board. Don't know how I missed it the other day since it's right there on the side. Maybe I didn't disassemble the case enough. So I unplugged & replugged the connections. Problem is I couldn't get a small 2-wire one unplugged & ended up pulling the socket off the board. Wonderful. At least it's got 2 pins sticking up & I'll just solder on the wires. Then I'll try to power it up.
Got it all back together but still doesn't power up. Cleaned the print head but made no difference. I don't mind buying a new inkjet but so far have not found any great reviews on anything less than $100-$150.
I have a similar problem with Pixma MX722. I pulled the power adapter out disconnected the white connector, reveres ed the order of disconnection but no power. I was able to find a replacement power adapter on e-bay but before making that purchase, does anyone know which points on the input where the white connector attaches to the adapter I can test for the voltages. If there is no voltage at the connector end of the power adapter, that may indicate that I need to replace it but if there is voltage, then I will take this printer and just dump it and never purchase another Canon printer again
My power supply (K30258), either connected to the printer or not, was giving 8v 8v and 10.4v instead of 16v 24v and 32v as it says on the unit. The yellow (control) wire was at 0v, so I guess I needs that +5v mentioned in earlier threads from the logic board, to wake it up. Currently the printer (MP500) appears to be dead but holding a portable AM radio next to it and listening for interference shows the circuits are lively just not turning anything useful on. Interestingly the circuits are still lively up to a minute after disconnecting power. Also for information there were two smd fuses on the logic board labelled FU401 or something like that starting with FU (for fuse). Mine were both OK though.
Further to my above post I put 1.5v then 3v then 4.5v on to the control wire. All these three voltages woke up the power supply to give the full voltages (16v 24v 32v). However this did still not turn on my MP500 printer. I guess the print-head damaged the logic board as it wouldn't turn on even with the print-head missing.
You sound like someone with good electronics background, so don't be offended by my weird story of getting my Canon MX882 to turn on. Basically, I was making progress resetting the dreaded B200 error. Then for no reason, it did not turn on. I tried various things. no go. I brought it to the trash area, Then one day, I took it into the laundry room and plugged it in to the same outlet as a drier. It turned on! It still is working! I'll let you figure out the electronics!
You sound like someone with good electronics background, so don't be offended by my weird story of getting my Canon MX882 to turn on. Basically, I was making progress resetting the dreaded B200 error. Then for no reason, it did not turn on. I tried various things. no go. I brought it to the trash area, Then one day, I took it into the laundry room and plugged it in to the same outlet as a drier. It turned on! It still is working! I'll let you figure out the electronics!

Congratulations on getting yours working. I can only think that all that moving around must have jarred some poor connector to get it working again. (Many of the previous posts hint at poor connections, particularly on the power cable.) Another remote possibility is that some stray ink may have caused an electrical short and drying it out with time cured the problem (Excess ink should be transported out of harms way onto a giant absorbent pad in the base of the printer using a peristaltic pump.) Having dismantled a couple of inkjet printers, I know some ink can migrate, though I haven't seen on circuit boards.


Posts: 1,746   +293
Yesterday was a sad day at home because the Canon iP3600 has died after many years service. The amber paper jam light wouldn't go out and it is now going to the recycling centre. I've ordered a Canon iP7250 which is one of the very few print only inkjets that are on sale. My theory is that single function units are much more reliable than the all-in-one wonders and I have a scanner which is very little used.
Hi there, I just have this problem with my hardly used iP7250!!
I measured 10,7 and 8.7 Volts respectively. I am already confused. So, does it mean that if I measure these values, than my power unit is gone?
I cleaned the ink holders, it didn't help, neither the "reseting" by holding the power button while reattaching to the socket.
Hi there, I just have this problem with my hardly used iP7250!!
I measured 10,7 and 8.7 Volts respectively. I am already confused. So, does it mean that if I measure these values, than my power unit is gone?
I cleaned the ink holders, it didn't help, neither the "reseting" by holding the power button while reattaching to the socket.
addition: if I keeping the voltmeter connected the volt level constantly decreasing as if the condensator slowly goes empty :(
Bang goes my theory that a single function iP7250 unit will be more reliable.
anyway, I just checked in Amazon, I would get for +/- 35 euros a power unit, or +/- 70 euros for a new same printer.. the new set of ink just arrived was 75 euros :(, maybe the less painful solution is to buy a new one.


Posts: 1,746   +293
One good thing about Canon is that so far I've had no issues using compatible cartridges. Save yourself a lot of money next time you run short of ink.
Hmmm.... so, I used compatible cartridges during the last 2,5 years (just realised that the printer just over 3 years), and now I just ordered original ones since I had problems with long "warming" process and some suggestion were on using originals to fix it...


Posts: 1,746   +293
The fact that you've hardly used it may be the problem. The cartridges are separate from the print head. Unless you print occasionally the print head will gum up and that's often game over. If you buy a replacement printer go for a make where the cartridges incorporate the print head although that will be reflected in the higher cost of ink cartridges. I'm currently using an HP which had been stored for years but with new cartridges it is printing OK. HP printers are far more difficult to get suitable compatibles for. I have some that work fine but you can't check the ink levels like you can with HP originals.
Found this thread after looking around for a solution to my issue, I can't seem to find any one else describing their issue quite like mine. I have an MG 3520 that experienced a whose house power outage (and then back on and off again a couple of times). When all was back up and running, the '4" x 6" Photo Paper' light is on when the unit is plugged in, but off. If I attempt to turn the power on, the power light comes on, the 4x6 photo paper light remains on, the unit does not do its normal check of itself, and my desktop finds the unit to be offline. I've unplugged, replugged, pressed buttons, looked at manuals, popped out the power block and disconnected and reconnected the wires...... nothing is changing. The photo paper light is on, just by unit being plugged in..... any ideas? Thanks for your reply


  • MG 3520 light.1.JPG
    MG 3520 light.1.JPG
    32 KB · Views: 1