Problem with my USB mouse

By Fynall ยท 16 replies
Sep 1, 2009
  1. I'm not really sure if this is the right section to post this. I have some mouse issues, it started few days ago. Basically what happens is my mouse completly stops working (isn't recognized by windows) and I have to replug it in order for it to work again, however the problem is it happens every 20 sec and I'm going insane.

    I look around the web trying to find a solution and the only thing I found related to this and best describing my problem is here:

    However after downloading the fix, it doesn't work for me because it's too old apparently (I'm using windows xp).

    I've ofcourse tried changing usb slots (6 available slots) and I tested it with 5 different mouses wireless/non wireless and the result is the same. I don't have any problems with my keyboard or anything else. I found that link because sometimes when my mouse disconnects and reconnects the image of the "universal bus controller" shows up near the clock (found the name on the device manager from the photo).

    So my question is can anyone help me find the issue, and fix it? Maybe there is a new link from microsoft for XP, I just couldn't find it. Thanks for any help :)

    Edit: I don't know if this helps or not...
  2. pyromaster114

    pyromaster114 TS Guru Posts: 246

    Just a thought... have you tried plugging your mouse in, going to device manager, and uninstalling the drivers for it, and restarting the computer?

    I've found that doing that can fix a lot of hardware problems with HID devices... and others even. I fixed a person's video card problem doing that one time.

    It doesn't have much of a logical basis, but it basically forces windows to re-load the driver from the files it got originally from the manufacturer or Microsoft (or wherever the drivers came from), and forces it to re-write any links it makes to the file. (Or at least that's my understanding of it.)

    If that doesn't work, perhaps you have a conflict with another piece of hardware, or more specifically another HID device and/or driver. (Just an idea.)
  3. Fynall

    Fynall TS Rookie Topic Starter

    Thanks for your suggestions but I've already tried unistalling the device and it doesn't fix the problem :(
  4. pyromaster114

    pyromaster114 TS Guru Posts: 246

    Is your USB controller the one mentioned in the M$ article?

    This started randomly (seemingly at least) correct? As in your mouse was working on this installation of windows for the longest time and it just recently stopped working?

    Hmmm ... maybe there's a problem with the ports on your computer related to the power consumption of the device... do all other USB devices work fine? (Flash drives, hard disk drives powered by the USB ports, etc.) If not, there may be a power problem with your ports.
  5. Fynall

    Fynall TS Rookie Topic Starter

    I'm not sure if it's the same as in the microsoft article, I don't know what AMD OHCI is actually. I tried a mouse on a different slot (non usb) PS/2 and it works fine now however when I plug the other mouse on the usb slots it still does the same thing...So this isn't really a solution it's simply avoiding the problem, if anyone knows how to fix it please let me know.
  6. moshiso7

    moshiso7 TS Rookie

    Sorry hijacking this thread but I'm having similar problem, but it's mainly to USB ports since when transferring stuff to flash drives or external HDs it gets slow, also mouse freezes intermittently. I started having this problem after using wireless keyboard and mouse. I think the receiver might have affected the USB ports (every one of them). At first I thought the issue was on the software but after formatting the computer the problem persists. Any help will be appreciated.
  7. pyromaster114

    pyromaster114 TS Guru Posts: 246

    Okay everyone in this thread that is having USB problems, update your chipset drivers now... not that it will fix it for sure but if there's an update, go for it... these things seem to help with mysterious problems.
  8. Fynall

    Fynall TS Rookie Topic Starter

    I've already tried updating, there is no available updates.
  9. pyromaster114

    pyromaster114 TS Guru Posts: 246

    Have you tried an older version of your chipset drivers? (Is there one? Sometimes they release a bugged chipset driver, and on 1/1000 computers, it will mess something up, and downgrading it can help...)

    Also, that device with the ! by it in the device manager, what error code does it give you / what explanation when you click properties?
  10. gguerra

    gguerra TS Guru Posts: 319

    Try uninstalling USB Controller/s from device manager. Before you do this disconnect all USB devices. Your keyboard may stop working. Re-boot computer. Also why dont use use a USB/PS2 adapter and plug in mouse as PS2
  11. pyromaster114

    pyromaster114 TS Guru Posts: 246

    This is a good idea... try it and see what happens.

    As to why not use a USB/PS2 adapter... well that only masks the problem not fixes it, but as a temporary solution I'd say that's a good idea lol.
  12. Fynall

    Fynall TS Rookie Topic Starter

    I can't keep using PS/2 and I don't like having broken stuff on the comp, I'll just erase everything and re-install xp, thanks for trying to help anyways.
  13. pyromaster114

    pyromaster114 TS Guru Posts: 246

    Be aware Fynall, to watch when updates go through after you re-install XP.

    My Sony Vaio actually has a problem that if I let it install a certain update (I forget which one...), it will cause it to become unstable. I determined this after 5 or 6 reloads, so hopefully if you watch what updates you install, if one does cause the problem to re-occur, you will know or at least have some idea of what update to not install the second reload, so you don't end up with my 5 or so reloads lol.

    Good luck with it, I totally understand getting frustrated when something is broken (even if it's insignificant...) because really, who likes broken stuff? (Not me...)
  14. Fynall

    Fynall TS Rookie Topic Starter

    This is truly unbelieavable, I formatted my C:/ drive, installed vista, installed xp and the issue persists. I don't know what to do anymore :/
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Have you installed XP SP3? and run Custom Windows Update so you can also install all the Hardware Optional update it suggests????

    Then reinstall both USB Controllers and m/b chipset drivers. And note the order of the uninstall/reinstall makes a difference See [post=751005]How to Reinstall Your USB Controllers and Motherboard Chipset Drivers[/post]
  16. pyromaster114

    pyromaster114 TS Guru Posts: 246

    The problem might actually be hardware related. I take it it didn't used to do this?
    If this is some sort of hardware/firmware related issue, you might need to update your BIOS, and if that doesn't work, you may be out of luck.
    Right from when you installed XP it malfunctioned?
  17. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Sounds underpowered. Got access to a powered USB hub to test that theory?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...