Problem with my WD passport

By lee cash
Jun 14, 2012
Post New Reply
  1. I have a WD passport that is currently not allowing me to access any files within it. I am able to unlock the hard drive with my password however G drive does not appear. I am unable to save any docs to the hard drive. I have serveral files within the hard drive that I need can any one help with this problem ??
  2. gcarter

    gcarter TS Enthusiast Posts: 82   +23

    I had a similar problem with a WD external drive... as you have highlighted it just stopped being recognized as a drive. After exausting all possible problems, such as trying it on different pc's, changing the usb cable etc... I ripped open the casing, removed the hard drive, went out and bought an external usb hd caddy (essentially a new case for the hd) - and got access to the drive again.

    USB hd caddys are very cheap...
    Again if you have tried it on different pc's and tried different usb cables, then its more than likely wd's electronic innards have gone pear shaped... external caddy would be your next step...
  3. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    I have a passport, mine never shows up as a hard drive, shows up as a DVD drive, I right click it and Open (or browse) GO to the unlock.exe and put in the password and access it.

    If you are unable to get past that then try what gcarter said.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...