Problems with my D945GPM

By WaveExistence ยท 6 replies
Mar 6, 2009
  1. Awhile back I had an electrical surge that pretty much killed everything in my PC. I got a better PSU put in, two new gig sticks of DDR2, and a GeForce 8500. But the main thing I had to replace was the motherboard - an intel D945GPM. I was able to salvage the processor from my old one and put some new thermal paste on it and made sure the fan/heat sink was in place.

    Everything seemed to be working fine, albeit a little slower due to my video card (another thing I need help with) except for one thing. My new motherboard will not recognize my home theater system as 5.1 one anymore. When I go into Intel Audio Studio it says it is a PCM stereo under digital input so I only have the two channels. I can still make it play through all my speakers if I mess with my stereo's console but it sounds absolutely horrible.

    I don't know what the problem is, because before the switch I could control everything (the individual speaker levels with EQ and everything) through Intel Audio Studio. Now it doesn't make a difference what I do in it, and the windows mixer doesn't seem to make a difference either. I've tried downloading all different kinds of drivers for my mobo from Intel and updated version of IAS but nothing seems to work.

    Please help me with this, because I'd really like to have my surround sound back.

    Also, for reference it's hooked up with a coaxial cable and the system itself is a Panasonic SA-HT05. It has DRTS and Prologic II and works absolutely fine.
  2. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Any yellow symbols in Device Manager?
  3. WaveExistence

    WaveExistence TS Rookie Topic Starter

    The only ones are ethernet controller located on PCI Slot 12 (PCI bus 2, device 0, function 0) and unknown device located on Intel(R) 82801GH (ICH7DH) LPC Interface Controller - 27B0. I am pretty sure the controller is my wireless card from linksys but I have their wireless program installed so it works just fine.
  4. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Since you are having a problem, install all the motherboard drivers and see if it helps any.
  5. WaveExistence

    WaveExistence TS Rookie Topic Starter

    I've already tried doing this and checked yesterday to see if there were any updated drivers but nothing has worked.
  6. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Since you have yellow symbols next to a couple of devices, you clearly still have driver problems. If you are depending on Windows to search the internet for you, that only works sometimes. You need to manually go to the motherboard manufacturer's website to locate the motherboard drivers you need.
  7. WaveExistence

    WaveExistence TS Rookie Topic Starter

    I've already done this, as well as downloading different audio drivers from intel - the problem still exists.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...