Radeon HD 3850 crashes

By Kashemy ยท 5 replies
Aug 24, 2011
Post New Reply
  1. Hey there everyone on TechSpot...

    Recently I upgraded from a Geforce 6800 GS to an ATI Radeon HD3850 (both AGP)
    After having carefully followed all the steps required to install a new graphics card
    (i.e. deleting of old drivers, installing the new ones etc.) I still get an error. In particular this one: STOP 0x000000EA THREAD_STUCK_IN_DEVICE_DRIVER

    I even contacted the manufacturer of the card (Sapphire) but they weren't of much help, giving me a constant list to do things that I had already done.

    I uploaded the latest 2 minidumps that were created from the crashes to (possibly) help solve the issue. (edit) I also uploaded my dxdiag, in case my other system specs are gonna be requested.

    Hope you guys can help me,


    Attached Files:

  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    The AGP standard is getting old. How old is this PC?
  3. Kashemy

    Kashemy TS Rookie Topic Starter

    approximately 3 to 4 years old, other than the graphics card, that is.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Did you try updating the Radeon drivers directly from AMD/ATI's website?
  5. Kashemy

    Kashemy TS Rookie Topic Starter

    Yeah, also tried the AGP hotfix

    Rolled back to 10.9 which was the most stable according to sapphire..

    Neither worked.

    Fiddling in the BIOS with the AGP settings didn't help either
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Try using this:
    Driver Cleaner Pro

    It may let us start over with this trouble. Just deal with any and all video drivers... You can attempt to install the proper driver cleanly, to see what happens

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...