Home build gaming PC -black screens, blue + red screen of death, freezing, game crashes

Sounds like my PC is totally non functioning but it is! I really need your help figuring out the problem.

I built it 3 years ago with Radeon HD 7970 GPU - always had problems with intermittent game crashes and browsers closing down when surfing the net etc. Thought it was the GPU, got in touch with AMD followed all of their troubleshooting plus many others online but nothing worked. Came to the conclusion it was a defective GPU so upgraded to Sapphire RX 480 a few weeks ago but problems are ongoing making it unlikely to be the GPU. The crashes seem to be worse with high spec tasks like playing games (Witcher 3) - this may or may not be accurate - perhaps I'm more aware of it because it's so annoying being kicked out of the game multiple times in a row.

With the old GPU I used to get a "display driver error" pop up. With the new GPU games or the internet still close down but there is no display driver error.

The DELL U2515H monitor is also new - could that be responsible for the new black screens? They occur intermittently for 1-2 seconds and then the picture is back to normal and I can continue what I was doing.

I have tried the GPU in both available PCIe slots with no change

Memtest 10 passes 0 errors

I've uninstalled, reinstalled all the drivers/Windows 10 (this problem still occured on Windows 8 prior to upgrade)

I've made sure to disable multi-screen + internal graphics in BIOS. Running the build just with internal graphics seems to run smoothly but I'm unable to play games etc due to the spec.


Blue Screen of death errors:

PAGE FAULT IN NONPAGED AREA

NTFS.sys failed



DRIVER IRQL NOT LESS OR EQUAL

rtwlane_13.sys failed



BAD POOL CALLER


Spec:

Operating System

Windows 10 Home 64-bit

CPU

Intel Core i5 3570K @ 3.40GHz 34 °C

Ivy Bridge 22nm Technology

RAM

16.0GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)

Motherboard

ASRock Z77 Extreme4 (CPUSocket) 36 °C

Graphics

DELL U2515H (2560x1440@60Hz)

4096MB ATI Radeon RX 480 Graphics (Sapphire/PCPartner) 48 °C

PSU

XFX 650W 80+ Bronze Certified Semi-Modular ATX Power Supply

Storage

238GB PLEXTOR PX-256M5S (SSD)

1863GB Western Digital WDC WD2003FYYS-02W0B1 (SATA)

894GB SanDisk Ultra II 960GB (SSD) 25 °C



Really appreciate your help
 
Sounds like my PC is totally non functioning but it is! I really need your help figuring out the problem.

I built it 3 years ago with Radeon HD 7970 GPU - always had problems with intermittent game crashes and browsers closing down when surfing the net etc. Thought it was the GPU, got in touch with AMD followed all of their troubleshooting plus many others online but nothing worked. Came to the conclusion it was a defective GPU so upgraded to Sapphire RX 480 a few weeks ago but problems are ongoing making it unlikely to be the GPU. The crashes seem to be worse with high spec tasks like playing games (Witcher 3) - this may or may not be accurate - perhaps I'm more aware of it because it's so annoying being kicked out of the game multiple times in a row.

With the old GPU I used to get a "display driver error" pop up. With the new GPU games or the internet still close down but there is no display driver error.

The DELL U2515H monitor is also new - could that be responsible for the new black screens? They occur intermittently for 1-2 seconds and then the picture is back to normal and I can continue what I was doing.

I have tried the GPU in both available PCIe slots with no change

Memtest 10 passes 0 errors

I've uninstalled, reinstalled all the drivers/Windows 10 (this problem still occured on Windows 8 prior to upgrade)

I've made sure to disable multi-screen + internal graphics in BIOS. Running the build just with internal graphics seems to run smoothly but I'm unable to play games etc due to the spec.


Blue Screen of death errors:

PAGE FAULT IN NONPAGED AREA

NTFS.sys failed



DRIVER IRQL NOT LESS OR EQUAL

rtwlane_13.sys failed



BAD POOL CALLER


Spec:

Operating System

Windows 10 Home 64-bit

CPU

Intel Core i5 3570K @ 3.40GHz 34 °C

Ivy Bridge 22nm Technology

RAM

16.0GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)

Motherboard

ASRock Z77 Extreme4 (CPUSocket) 36 °C

Graphics

DELL U2515H (2560x1440@60Hz)

4096MB ATI Radeon RX 480 Graphics (Sapphire/PCPartner) 48 °C

PSU

XFX 650W 80+ Bronze Certified Semi-Modular ATX Power Supply

Storage

238GB PLEXTOR PX-256M5S (SSD)

1863GB Western Digital WDC WD2003FYYS-02W0B1 (SATA)

894GB SanDisk Ultra II 960GB (SSD) 25 °C



Really appreciate your help


**EDIT**
Dump files link - unable to upload as zipped file - unsure why
https://drive.google.com/drive/folders/0B-VK-pfBB9zGZ3hHVVV6ZENQWWs?usp=sharing