Random BSoDs; various error messages

By Cams · 12 replies
Jun 27, 2006
  1. My PC is crashing a few times a day. I've spent a good while browsing through this forum and it seems choc full of excellent help so I thought I'd see if anyone here could help.

    First up, system specs:

    AMD64 3500+ Winchester
    Asus A8V Deluxe Motherboard
    Nexus NX4090 Ultra Quiet PSU
    Corsair XMS4000 TwinX 1024Mb Pro
    Radeon 9600
    Terratec EWX 2496
    WinXP Pro SP2

    I'm using the onboard LAN (Marvell Yukon).

    Some of the error messages I'm getting are as follows:

    BAD_POOL_CALLER (0x000000C2)
    BAD_POOL_HEADER (0x00000019)
    RDR_FILE_SYSTEM (0x00000027)
    PFN_LIST_CORRUPT (didn't write this one down)

    Errors in the Event Viewer read as follows:

    Source: System Error
    Category: (102)
    Event ID: 1003
    Error code 00000077, parameter1 c0000185, parameter2 c0000185, parameter3 00000000, parameter4 02b2e000.

    0000: 74737953 45206d65 726f7272 72452020
    0010: 20726f72 65646f63 30303020 37303030
    0020: 50202037 6d617261 72657465 30632073
    0030: 31303030 202c3538 30303063 35383130
    0040: 3030202c 30303030 202c3030 32623230
    0050: 30303065

    I ran Memtest86+ overnight and had no errors at all.

    I've spent literally days Googling on the error messages and have got nowhere. Prior to finding this site, I didn't know about the minidumps so hopefully that should help to narrow down the problem. I have a strong feeling that it's dodgy hardware.

    A bit of history:
    When I bought the system, back in January 2005, I originally had 2 x 512 of Crucial Ballistix PC4000. I was getting BSoDs (mainly IRQ_NOT_LESS_OR_EQUAL) and, after weeks of running diagnostic tests, send the motherboard, CPU and RAM back to the retailer for testing. They found some errors but not consistent ones. It seemed to be resolved by switching the RAM for new sticks, and they sent it back to me. It then started playing up again, so I switched out the Crucial RAM for Corsair PC4000 and it was fine for a while.

    Now it's playing up again. It seems to happen most often when I'm using Remote Desktop from my family PC over the LAN, but it does happen when I'm physically at the main PC as well.

    So, I'll post this now and figure out how to attach a minidump before the machine crashes again and I lose my post!

    Hope someone can help.
  2. Cams

    Cams TS Rookie Topic Starter Posts: 27

    Here are the minidumps attached.
  3. Cams

    Cams TS Rookie Topic Starter Posts: 27

    I've had many more crashes since I last posted to the point that the PC in question is barely usable. I'm going to install a new HDD in my ClarkConnect file server and see if I can keep the dodgy one up for long enough to copy the data I need over the network to the server (the server doesn't have SATA so I can't use my SATA drives).

    Meanwhile, has anyone had any joy interpreting the minidumps I posted? It would be a great help to me.

  4. altheman

    altheman TS Rookie Posts: 425

    Your crashes are caused mainly by Memory Corruption, a sign of faulty ram. download Memtest, and test your ram for problems.

    some crashes were caused by your ATI drivers, and "amon.sys". I couldnt dig up much info on this file, but I think its releated to NOD32. Another crash was caused by "rdbss.sys", a file part of Windows.

    There were also 3 crashes at "ntkrnlpa.exe", and one crash referenced hardware.

    However, check your ram first for errors.

    btw, mindumps are read by Windbg, and not by notepad :D, their extensions should not be changed.
  5. Cams

    Cams TS Rookie Topic Starter Posts: 27

    Sorry about changing the minidumps' extension :blush:. I read a long thread about device drivers and thought that that was the way things were done. My bad.

    I ran memtest86+ overnight and had no errors. Then today I ran plain old memtest86 for 12 hours and, again, no issues to report.

    I do indeed run Nod32 and it has something called AMON, which is its File system monitor. I tried scanning my system this morning with Nod32 before running memtest86 and got a BSoD with the stop message: 0x0000008E

    I've updated the drivers for the ATI Radeon 9600 to the latest version, but the problem persisted both before and after the upgrade. I've also upgraded the firmware for my D-Link DGL-4300 router and the Marvell Yukon onboard ethernet controller.

    I'll reboot the system in a minute and upload the latest minidump files that are new since I last attached the last batch (and in the right format this time!) I've been running the Prime CPU stress tester from the Ultimate Boot CD for the last hour and, once again, no problems. I know an hour is far too short, so I'll run it overnight once I've tried copying data to the server.

    If anyone can shed any more light on my minidumps, I'd be most grateful.

  6. altheman

    altheman TS Rookie Posts: 425

    A kernel mode program generated an exception which the error handler didn’t catch. These are nearly always hardware compatibility issues (which sometimes means a driver issue or a need for a BIOS upgrade).

    If you upgraded nod32 from a previous version, try unsinstalling it completely, and reinstalling it, or try a temporary alternative (avast, avg, etc.) Also upgrade your bios if you can. it could be that nod32 has hardware issues with your pc.

    Upgrading directly can sometimes cause problems. uninstall your display drivers, then use Driver Cleaner to remove ati drivers, and then reinstall the latest version.
  7. Cams

    Cams TS Rookie Topic Starter Posts: 27

    Thanks for the suggestions altheman.

    I'm running the latest BIOS for my motherboard, but there is a later one out that's in beta. Might that be worth trying?

    I used the Driver Cleaner to remove the ATI drivers and reinstalled the latest version using Windows rather than the ATI exe (so driver only and no Catalyst Control Centre). Things were running well and I left it switched on overnight and came back to it still on. I then tried synching two directories with MS SyncToy and got a BSoD:
    PFN_LIST_CORRUPT (0x0000004E).

    I do have an earlier version of Nod32 which I could try - I've only been using the new version since I reinstalled Windows a couple of months ago.

    Could someone have a look at my latest minidumps to see whether we're on the right track? According to two memtest86 sessions, my RAM is fine, but I guess it might be faulty video card? I checked the voltage of my PSU using speedfan and it seems to be okay as well.

    Many, many thanks for helping me out with this.
  8. altheman

    altheman TS Rookie Posts: 425

    One crash caused my "amon.sys", one by memory corruption, and one by "ntkrnlpa.exe."

    i still think faulty ram is the problem. some faulty ram can pass memtest. try some suggestions given in this post: https://www.techspot.com/vb/post202735-2.html.

    did you uninstall nod32 and install another AV software. If you didnt, then try that as well.

    edit: is your system getting sufficiant power? use the calculator here or here to check.
  9. Cams

    Cams TS Rookie Topic Starter Posts: 27

    Thanks again altheman

    I had a few more crashes last night. I uninstalled Nod32 and rebooted but it was still showing up as a running process, so I killed that and have removed the ESET directory from my program files directory. Seems the uninstall routine doesn't work very well.

    One of last night's crashes indicated that I had a virus (after I'd uninstalled Nod32):

    Microsoft Error Message

    So I followed the instructions there (boot to safe mode with networking, go to safety.live.microsoft.com and run the AV scanner) and it found nothing worse than JS Loop.

    I'm now running with only one stick of RAM and I'll see how that goes. My PSU is powerful enough for my system and seems stable.

    It's a tough business diagnosing system crashes. If only they'd make it easier.
  10. altheman

    altheman TS Rookie Posts: 425

  11. Cams

    Cams TS Rookie Topic Starter Posts: 27

    After running the system for several hours with the single stick of RAM, I thought I'd test the other one. And, joy of joys, it wouldn't get as far as loading Windows! (strange that such a thing should make someone so happy!).

    I tried four times, and each time, it would almost load into Windows and then BOOM - a Blue Screen of Death!

    So, seems you were right all along altheman. It's such a relief to have figured out what was causing the instability, although I'm a little surprised that memtest didn't fail. And I'm also a little surprised that I should have TWO faulty batches of RAM from different companies on my system. I deliberately coughed up for some decent RAM (Crucial Ballistix and then Corsair XMS Pro) in order to keep things stable and smooth.

    And now, bizarrely, my system seems to be running a lot faster than ever before on only 512 MB of RAM. So 1 GB of dual channel is slower? Nah, I guess that's down to the faulty RAM, at least I hope it is!

    As for the virus thing, I ran the live MS scanner in safe mode and I think I'm pretty much okay. I'll run Trend Housecall this evening and see whether it picks up anything. I really like the thread you pointed me to though about posting a Hijack This log. These forums really are excellent and I'm glad I've found them. Hopefully I'll be able to give a little back once the dust settles and I learn about more about how things work around here.

    Many thanks.
  12. altheman

    altheman TS Rookie Posts: 425

    I'm glad to hear you found the source of the bsods. If you have warrenty, I recommend you return it and get a new stick.

    Some bad ram can pass Memtest, but it still is an excellent tool for finding faulty RAM.
    Anyway, glad you got it sorted. :)
  13. Cams

    Cams TS Rookie Topic Starter Posts: 27

    Yes, it's still under warranty. I've already arranged to have it sent back, and the vendor even offered to loan me some RAM during the downtime of getting it replaced. Hopefully I'll be able to borrow some from work though.

    Great service though, once again, from Kustom PCs in the UK.

    Thanks again for the help.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...