1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Realtek 97 drivers working no sound grayed out boxes

By toygod ยท 4 replies
Aug 26, 2010
Post New Reply
  1. ive been searching for 2 days trying different things
    first problem was driver enabled but has not been started fixed that by getting rid of the ghost soundcards in sound/media
    now my driver are enabled and functioning properly
    but im still not abled to access the playback / recoding drop down

    ive done sfc /scannow ---no problem
    combofix--- no probelms
    even repaired xp from disc in dos (reinstall over current)

    my onboard sound is enabled
    ive tried soundblaster live installed drivers (no problems) ---no drop down to select same as above
    my midi is working
    my soundman has audio test for speakers and it plays sound on my speakers
    my pnp emu is running on startup auto

    im not able to get msinfo32 to run havnt tried it in safemod yet
    my dx9 txt attact

    current drivers are ALC850_V5870_WHQL
    on a8n-sli_premium motherboard
    winxp sp2 pro

    Attached Files:

  2. toygod

    toygod TS Rookie Topic Starter

    i got my msinfo32 to work

    posted txt
    posted images

    Attached Files:

  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Look here [post=926040]Reference Guides to Help Setup and Troubleshoot Windows Audio and Sound Cards[/post]. Then post back if none of the Help Guides seem to help
  4. toygod

    toygod TS Rookie Topic Starter

    im going to upgrade to sp3
  5. toygod

    toygod TS Rookie Topic Starter

    i updated to sp3 still no sound so i did a google
    ms Kernel Audio issues

    re: Microsoft Kernel Audio issues
    Saturday, December 5, 2009 at 4:57 am
    Posted by Nee (1 messages posted)

    I had a similar problem (code 42 to microsoft kernel ...) and it was due to duplicate
    "plug and play software device
    enumerator" entry in device manager->system devices.
    If it's the same for you:
    1. Check in each of those Properties->Details->Device instance ID.
    The only one that should be present is the one with Device instance ID = Root\System\0000.
    2. In order to remove the other one (which lets say is Root\System\0005), run regedt32
    (you'll need to change permissions of a folder so don't use regedit simple).
    3. Select my computer, save your registry (File->Export... to a backup file which
    needs to be run in case of a problem..).
    4. Search (Edit/Find or F3) for swenum and press F3 to search for next until in left
    panel it shows something like 0005 (from the device instance id like above). This
    should be HKey_Local_MachineHKLM->System->ControlSet002->Enum->Root->System->0005.
    5. Right click on 0005, choose permissions..., select Allow at full control, OK.
    6. again right click on 0005 and choose Delete.
    7. Close the regedit window and all the others, restart your pc.
    8. Install your audio drivers (you might have to restart again the computer).
    It should work fine now.
    Regarding the duplicate plug and play software device enumerator, this appeared
    because I followed some instructions where was supposed to be applied JUST/ONLY in
    case the only pnp sd enumerator was corrupted or missing...in my case it was working
    fine, but since in those instructions it wasn't specified when to be applied, just
    in case of "no audio", I didn't bother to check first if that enumerator was ok or
    Good luck.

    now i have sound
    you may close this

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...