Realtek HD Audio input

By Bill Gable ยท 10 replies
Sep 12, 2006
  1. This is a e-mail I sent to "" and they refused to answer, at least 4 times. I wonder if any one else has had this problem?
    Does anyone know how to solve this problem?

    Dear Sir,
    The problem I am having with your "Realtek HD Audio input" I can not get the microphone working, it shows it but it is grayed out. I have tried every thing I know to do. According to every thing I have read on the Internet a lot of people are having the same trouble. Can you help???????

    I have Microsoft Windows XP Professional
    Version 2002
    Service Pack 2
    AMD Athlon(tm) 64x2 Dual
    Core Processor 3800+
    2.00 Ghz, 2.00 GB of Ram
    Physical Address Extension

    MSI Mainboard K9VGM-V
    VIA K8M890+VT8237A Chipset Based
    MSI NX6200TC TD64E
  2. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Hi Bill,
    According to MSI's web page, that motherboard has an ALC883 audio chip.

    These chips have what's known as "smart port sensing" for what is plugged into what port/jack. It does this by sensing various tidbits of what's plugged in (such as draw, amps, etc.etc.).

    Usually, you can find a SoundMAX or Audio Console with the reference audio drivers, or the ones on MSI's website. With this tool, you will likely have to override the port/jack sensor's findings (likely no microphone or no audio input device) which should then allow windows to pick-up the mic.

    Check your systray, start menu or control panel to see if you can find the RealTek (or MSI) audio panel/settings window. It's usually a big, colorful application with an Equalizer, some 3d sound demos and a tab with a row of jacks and little hammer icons. You'll have to click on the hammer for wherever you have your microphone connected and hardset-it to microphone (not line-in) to get it to work.. if it'll let you.
  3. Bill Gable

    Bill Gable TS Rookie Topic Starter

    I have tried to get in touch with "Realtek" 4 or 5 times and all E-mail comes back unanswered. With "MSI" you have to fill out 4 or 5 pages and be a computer technician which I am not. So I have given up on them ever helping me.
    I have a question. I have "Realtek HD Audio" on my computer, "Microphone" is grayed out, it is there just grayed out. Every thing else in audio works fine.
    I have a friend who has the same system as mine just a couple years older.
    He has "Realtek AC97 Audio" and his "Microphone" works just fine. It is not grayed out. Question can I uninstall my "Realtek HD Audio" on my computer and install "Realtek AC97 Audio" on my computer.
    Thanks Sharkfood for your help.
  4. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    You want the HD Audio as you have the higher-series chip. AC'97 is for the non-HD chips. (like ALC850 or below).

    You probably do not have to install or uninstall anything, just locate your Realtek audio console or settings program. It's apparent it's smart-port sensing can't recognize your plugged-in microphone, so the system just leaves it blank/greyed out.

    The RealTek audio console can usually be found in the Control Panel, Sound Speech & Audio Devices section. Or you may find it in C:\Program Files\RealTek. Look for an exe like "HDConsole.exe" or similar with an icon that looks like expanding radar/sonar waves lol. It could also be on your Start Menu somewhere.

    Once you've found it, it's a pretty simple to use application. It will have various tabs at the top or side, one being for the connectors. Somewhere it'll have little hammers under the colored connectors (that correspond to the jacks on the back of your PC).. just find the color your microphone is plugged into, click on the Hammer and change it to "Microphone"... as the auto-sensor isn't working. From here, you should have your microphone control with any luck.
  5. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Worst case scenario- hit this link:

    Click on the "2000/XP" link under "Realtek High Definition Audio Driver" and download this file.

    Then go ahead and uninstall the RealTek HD Audio from control panel/add-remove programs.. reboot.. and re-install this one. It should then hopefully present it's audio console in control panel, on the systray (bottom right) or on the start menu where you can find it!

    Good luck.
  6. Bill Gable

    Bill Gable TS Rookie Topic Starter

    Sharkfood I tried this but had the same problem "Microphone" is grayed out, it is there just grayed out. Every thing else in audio works fine.
    Question several of my friends have "Conexant AMC Audio" and it works just fine. Is it possible to get "Conexant AMC Audio" and uninstall "Realtek HD Audio" on my computer and install "Conexant AMC Audio" on my computer.
    Thanking you in advance for the answer.
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    try a USB Mic... They're not too expensive and they work great :) Logitech makes the model I use
  8. Bill Gable

    Bill Gable TS Rookie Topic Starter

    was you having trouble with your regular microphone working, before you got a USB Logitech mic.
  9. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    I bought a Logitech USB Mic, and it works perfectly. I was having problems with feed back
  10. MagNet

    MagNet TS Rookie

    Hey sharkfood, could you upload the HDConsole.exe somewhere? It's not in my realtek installation folder and I have the grayout problems too :p
  11. zachmain02

    zachmain02 TS Rookie

    hey guys, i joined here just for this problem.
    i am having this same problem. problem is the smart port sensing that realtek has. I have no fix for this, the only thing that has worked for me is to restart, go into the BIOS, disable the onboard audio, boot up, restart, and go into BIOS again and re-enable it. i tried all the different drivers i could get my hands on from asus and realtek, but none worked.

    if anyone knows if any of the HD drivers came WITHOUT the smart port sensing, that would be nice.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...