SBS 2003 won't detect usb drives

By will3265
Nov 26, 2008
  1. First post so I hope I give all details necessary, I'll give it a go.
    The place I work at use external usb drive to back up data daily.

    The current drives are full so I bought 2 new 500Gb Seagate FreeAgent drives

    Plugged in the new drives and nothing happened.
    I waited a while, and nothing came up, I went to disk management and nothing was there.
    I went to device manager and the device was there but not installed yet.
    Waited a bit longer and noticed the machine slowing down.
    Opened Process Explorer and Services.exe was using 100% of processor 1.
    Opened to see what threads and the umpnpmgr.dll was using all of the processor time.

    I left it for a half hour and still nothing happened.

    I rebooted and tried again.

    I tried a different usb drive, then a flash drive but still same issue.

    I tried updating driver but it said the update function was already in action.

    I think the problem is a faulty service but I am not sure which one.
    I cannot restart the plug and play service.

    The system had a strain of cutwail on it which was cleaned a few weeks ago but I don't know how that affected the services.

    Any help or suggestions would be greatly appreciated.

  2. will3265

    will3265 Topic Starter

    ok so i tried to manually install the drivers for the drive but they are already there.

    Anyone got an idea on how to add a device in the registry manually?
    Perhaps I can get the device id while its plugged into another machine and then put it into the registry somewhere along with a pointer to the driver.
    I have no idea how to do this or if it is possible but i would love any help any one can give.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...