Scandisk 1.0 GB Cruzer Mini Flash Drive not working

By banka_ravi ยท 17 replies
Jul 19, 2005
  1. I have a SanDisk Cruser mini 1.0 GB flash drive that worked fine only once. Now i don't know what happend to it.. it has stopped working. when I plug it into any computer a the light on the flash drive turns on and the drive gets detected and a drive letter also gets assigined. when i click on it the system hags for very long period and then shows a mesage something like "semsphore lock timed out", i tried to format it from DOS window of XP, i got the message "Track Zero" bad. is there a way to fix my drive?

    B. Ravi Shankar
  2. logitech

    logitech TS Rookie Posts: 17

    I have the same problem too ...
    Only thing mine is a 512 drive ... Any suggestions on what to do???

    Help needed urgently
  3. banka_ravi

    banka_ravi TS Rookie Topic Starter


    i am still waiting to hear the solution from some one...
  4. toffeapple

    toffeapple TS Rookie Posts: 152

    have you checked that the "lock" is not on??

    it should be a little switch at the side that locks the usb drive..i have a buffalo 1gig stick and theres is a small white switch on the side that locks the drive ...check for one on your model........
  5. banka_ravi

    banka_ravi TS Rookie Topic Starter

    it dosen't have any locks on the stick
  6. tollchief

    tollchief TS Rookie

    I had a similar problem with a 256 cruzer mini, try right clicking on 'my computer' select 'manage' then 'disk management' your cruzer should be listed there. I had to re partition and then reformat as FAT drive. that worked for me.
  7. logitech

    logitech TS Rookie Posts: 17

    OK ... Can you guyz tell me which buttin to click to "Repartition" the drive ... ?
    I see the fromat button ... but no repartition button ...

    help me out here
  8. tollchief

    tollchief TS Rookie

    The error I was getting was that the drive came up and was assigned a letter, but when I clicked to open it windows said to insert a disk in the drive. When I went to disk management the only option was to partition the drive, the partition wizard came up and did its thing.
    I have just stuck my mini back in the USB and gone to disk management, when it comes up the only option I have by right clicking is to format, it sounds as tho your mini has not lost its partition, try formatting in disk management.
  9. logitech

    logitech TS Rookie Posts: 17

    When i try to format ... it say the format was 'unsuccessful' ... what am i to do now ??
  10. tollchief

    tollchief TS Rookie

    I'm sorry I cant suggest any thing else to try, except to contact sandisk customer support, best of luck
  11. lizannel

    lizannel TS Rookie

    Don't bother trying Sandisk's website - it's got one of the most pathetic tech support pages ever. I accidently wiped out the partition on my Cruzer Micro, and windows could not access or format it, and there is literally nothing on Sandisk's web site to help. But I found a nifty little program by HP that will not only reformat a flash drive, it can even make it bootable (if your mobo supports booting from a removable USB drive). It's small (356K) and very easy to use. I can't seem to find it on HP's website, hjowever, but if you Google this file name:

    you will get the site that I downloaded it from (in a thread on another site about this same problem). It worked beautifully for me. Good Luck! :slurp:
  12. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Please use the search feature, we probably have over 100 posts about flash drives no longer working, and I bet over half of them are involving the Sandisk Cruzer Mini.

    There seems to be no 1 solution to fixing this, but there are a lot of posts about people fixing it, use the search feature and scan through the results. You answer lies there I'm sure.
  13. Milo09

    Milo09 TS Rookie

    New scandisk problem!

    I don't know where to ask for help, so I figure some or one might help me solve my problem

    I had a flash drive: Scandisk Mini Cruzer 512MB.

    My problem is I erased the driver, just the driver but not the volume itself. To be more specific there are the two drivers appear when you go the Utilities then Disk Utility. In the diskc utility the first driver will appear--other than the two driver, which is the Hard Drive and the HD Macintosh. Below that two is Flash Drive and the driver, it's colored white that when you put your Flash Drive onto your computer it will appear on the desktop and Finder as well.

    So, here's my problem. I erased the volume, the drive that appears on the desktop and when I put my flash Drive in other computer other than Mac, PC Windows at school. And when I try to open it a window appears that says:

    The disk is not formated. Do you wanna format?

    Yes? or No?

    I try to format but I couldn't because it say's:

    You don't have the sufficient rights to perform this opperation.

    Though the good thing is I can still use the Flash Drive to my Mac, but to PC, I couldn't. The PC couldn't format the Flash Drive.

    Any suggestions other than tell me to ask the Scandisk website itself? Because the webiste sucks. I tried when I try to regrister but... I don't know. I couldn't get in to make an account or something.

  14. RGHawk2000

    RGHawk2000 TS Rookie

    OK guys..first to first

    Hello m8s,

    Eventhough this is an old thread I want to give some input on it.

    The Sandisk problem when you plug in your pen drive in XP:
    a.- The green led will be on
    b.- XP will recognize the pen drive and assign a drive letter to it
    c.- You get a media error where XP ask you to insert a disk

    Before you do anything, dont even try to format, or repartioning your pen drive. First step is to recover the data in there. Yes, you data would still there even though it seems an invalid media error.

    So to recover your data, before you do anything else, there are good programs out there (but dont even try to use the one that sandisk webpage provide in their support is worthless as all the technical support there)

    The program I use to recover the data was Stellar Phoenix FAT and NTFS ver 2.1... I use this program to recover delete data and now it works for even losing partition. However this program wont fix your partition table problems.

    Now, after recover your data, it wont be wise to use any software out there to repartition your pen drive. It would wisely to repair your partition table and then reformat your pen drive. For this part, I would like to know if anyone has any good tools for repairing partions tables and logical drive assigment

    Anyway, these were my 2 cents for the community


  15. banka_ravi

    banka_ravi TS Rookie Topic Starter

    Hi All,

    i got my device replaced by sandisk.
    They have a very easy procedure for getting ur device replace
    open the link
    Click on "Register your Produce" enter ur product details
    then Click on the "Support / FAQ's" tab and post ur query over there.
    They would respond to ur queries

    and if, the device could not be repaired then they might replace the device.

    Best of Luck

    B, Ravi Shankar
  16. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

  17. InfoNet

    InfoNet TS Rookie

    ScanDisk Flash with U3 Security Software

    Does anyone actually KNOW if you can DELETE the "U3" security software
    that is already ON a ScanDisk 2.0 GB Flash Drive when you first buy one?

    I recently purchased a ScanDisk 4.0 GB stick - it doesn't have the 'U3',
    but has OTHER add-ons....It's the one that also comes with TWO cover caps.

    I know if you attempt to format drives on XP, it SETS the amount of space.
    So how can you BYPASS this method on XP?...or CAN you?

    Flash Drives lose about 5-10 MB+ with all that JUNK on them...
    WHY do they even DO this in the first place? - - - - GEEZ!

    The LAST BEST drive I ever purchased was about 2 years ago: IMATION 1 GB stick - that still gives me a great 999 MB...

    ..BECAUSE it had NO - extra software on it!
    (later Imation flash drives changed their production line.. allowing less space!)

    A Flash Drive should have AT LEAST 500k-1 MB 'less' than the full monty,
    given the consideration that there's to be needed 'cushion room'...correct?

  18. thugluve2009

    thugluve2009 TS Rookie

    im here to help

    i had the same problem for like 3 hour i work my way out of it if u have a copy of windows xp you could fix this problem bout u have to be really careful not to delete your recent file or reset windows xp and boot from the disk and make sure u plug in your cruzer driver and follow steps and when it come to the screen where it show what is ur HD size and u will seen the cruzer driver size there too and create a small file size 8mb and reset your pc and go to my computer and format the cruzer disk not your HD if dont get it wait ill put a lil video on youtube or Email me at and ill tell you step by step what to do to solve your problem thank you
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...