Seemingly random BSODs (Windows 7)

By gojira · 14 replies
Sep 25, 2011
Post New Reply
  1. Hello TechSpot!

    This is my first post here, and because English isn't my first language I apologize beforehand if I fail to make this post understandable.

    Roughly two weeks ago I built a new computer. Everything was fine for a couple of days, but then the BSoDs started appearing. The computer can run fine for a couple of days and then just start pumping out BSoDs once again. I've tried to troubleshoot it as best as I can myself, but I don't know what to do anymore.

    Computer specs:

    Motherboard: Asus P8P67 LE REV B3
    CPU: Intel Core i5-2500 3.3GHz (Stock settings with turbo mode, tried disabling turbo mode as well, no luck)
    Memory: Corsair 8GB CL9 1600Mhz Vengeance BLUE (Forced to 1600Mhz in bios, was stuck on 1333)
    HDD: 1TB Samsung Spinpoint SATA3 7200 rpm
    Graphic card: Gigabyte GeForce GTX 560 Ti 1024MB OC (Latest drivers)
    PSU: Corsair CX 500W V2 80+ (All voltages are within +-5% according to bios monitor)
    OS: Windows 7 Home Premium 64bit

    I've downloaded and installed the latest bios drivers from ASUS.

    The BSoDs can come when booting up in the morning (cold boot), while playing some games or just while using the computer in general.

    What I've done so far:

    * Prime95: 11 hours, no errors nor warnings (Blend? test settings)
    * IntelBurnTest: Tested on all torture levels, no problems. Highest recorded temp was 71℃ according to HWMonitor
    * 3DMark11: No problems with graphical bugs nor overheating
    * ES-Tool: No problems with the HDD discovered
    * Memtes86+: 3 passes on each stick, and then 3 passes with both together in dual-channel

    I also replaced Avast Home with AVG after one of the BSoDs listed avast as a probable cause and I updated my NIC drivers after several BSoDs listed ndis.sys as another probable cause.

    I followed the guide on TechSpot and made a new page file with 1.5 the size of my memory, and my HDD got 0% defragmentation.

    What would you suggest I do now? I've included various minidump files (the latest ones got Driver Verifier turned on) as well as a sysinfo file.

    Thanks in advance for any help you're able to offer me.

    Attached Files:

  2. gojira

    gojira TS Rookie Topic Starter

    After reading some posts about Memtest86+, I decided to run it through again and this time let it run for at least 7 passes. An error popped up during the 2nd pass on test 4. Guess I know why you should let it run for a longer period of time now!

    Going to test the sticks separately again to try to find out what stick is causing problems. I had the same problems with BSoDs when running the sticks in other channels too, so I assume the channels are ok.
  3. gojira

    gojira TS Rookie Topic Starter

    Both of the sticks passed Memtest86+ individually, so I'm going to blame Turbo Mode for the error in dual-channel for now (did not receive any errors while running dual-channel with turbo mode turned off at least).

    Could a under-powered PSU cause these problems? I'm thinking 500w might be a bit weak for running a GeForce GTX560 Ti OC together with these parts.
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    If you have your memory overclocked set it back to factory settings. In fact, set it back to 1333 and let us know if you regain stability.

    Go to your BIOS and check the memory voltage settings. Does it match the voltage specs of what your memory is designed for?

    * If you have errors with memtest you've got corrupted memory (unless the motherboard doesn't like your memory configuration). But make sure of the above first.
  5. gojira

    gojira TS Rookie Topic Starter

    Hello and thanks for your reply!

    From the beginning I used the default settings in the BIOS (ran my 1600 Mhz memory as 1333). I've had the same problems with default settings as well as when forcing it to 1600 Mhz.

    The auto settings for my RAM chose 9-9-9-24 voltages, which is what the memories are supposed to run at. Right now I entered the same values manually to see if it helps.

    Because the BSoDs pop up randomly and the computer can work flawlessly for several days makes it hard to know if the problem is fixed or not, all I can do is sit and wait for a new BSoD to come. The last BSoD I received was yesterday morning, everything was stable last night as well as all morning today.

    Though one thing I noticed when running Memtest86+ on a single stick in slot A2 (mobo slots A1 B1 A2 B2) is that it detects it as 6-6-6-20 even though according to the BIOS it's supposed to be 9-9-9-24. Any idea why? Tried googling this problem a bit, and many people seem to run into the same problem with a single stick outside of the A1 slot, though haven't found any solution to this.

    I've tested both sticks individually in both the A1 and A2 slots that I use for dual channel, no errors detected.

    What do you think about the PSU situation? I'm thinking it might be a bit low for this system, but then again, I'm not sure what kind of problems a underpowered system would bring.

    I was not allowed to post a link to the specs of my cpu, so I'll just post them in here.

    Voltage +3.3V +5V +12V -12V +5Vsb
    Max. Current 25A 20A 34A 0.8A 3A
    Max Combined Wattage 130W 408W 9.6W 15W

    500 Watts @ 30°C ambient temperature

    Thanks for helping me out!

    Edit: Saw that the specs became quite hard to read while copy/pasting, but the 130W Max Combined Wattage is for both +3.3V and +5V.
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

  7. gojira

    gojira TS Rookie Topic Starter

    I thought of that too, so last night I was running the computer with just one of the two sticks doing everything I normally do (play music, play some games, sit on skype etc) and had no issues. This morning after a night of Memtest86+ I once again inserted the 2nd stick and haven't had any issues so far, but only time will tell if it has become stable.

    Only thing I've done since the last BSoD is updating my NIC drivers seeing as it was pointing to ndis.sys.

    If this actually solved my problem I don't know, but I will keep running the computer and see if any BSoDs return.

    Not quite sure I inputted everything correctly in the wattage calculator, seeing as my GTX560 Ti is the overclocked edition, but according to that site 470w is recommended for my system.

    Will update as soon as I've tested the computer further!

    Thanks for your help so far.
  8. kristain

    kristain TS Rookie Posts: 47

  9. gojira

    gojira TS Rookie Topic Starter

    Hi again.

    Well the computer ran perfectly stable for a day, but crashed with another MEMORY_MANAGEMENT BSoD last night again. I just don't understand why I keep getting BSoDs like these even though both sticks individually passed 14 passes of Memtest86+ each.

    I'll try running just one memory from now on and see if any BSoD appears.



    Well this whole rig is completely new, other than that I've just installed all drivers and done windows update.

    Indeed there are plenty of errors to be found in the event viewer, although I'm not quite sure how to interpret them all.

    For example, this is the log from the latest BSoD (yesterday evening)

    - System

    - Provider

    [ Name] Microsoft-Windows-Kernel-Power
    [ Guid] {331C3B3A-2005-44C2-AC5E-77220C37D6B4}

    EventID 41

    Version 2

    Level 1

    Task 63

    Opcode 0

    Keywords 0x8000000000000002

    - TimeCreated

    [ SystemTime] 2011-09-26T21:04:57.816030400Z

    EventRecordID 7692


    - Execution

    [ ProcessID] 4
    [ ThreadID] 8

    Channel System

    Computer gojira-PC

    - Security

    [ UserID] S-1-5-18

    - EventData

    BugcheckCode 26
    BugcheckParameter1 0x5003
    BugcheckParameter2 0xfffff781c0000000
    BugcheckParameter3 0x27d
    BugcheckParameter4 0xfffff8a00d7e2009
    SleepInProgress false
    PowerButtonTimestamp 0

    There seems to be plenty of warnings and errors though, 3 Administrative Events errors and 3 Application Events errors since I started my computer this morning (roughly 15 minutes ago).

    I've also uploaded the latest minidump.

    I'm completely stomped right now :-(

    Attached Files:

  10. gojira

    gojira TS Rookie Topic Starter

    Well, running just one memory stick did not solve things either. I ended up with a SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION (c1) BSoD. Seeing as both ram sticks had 14 passes without errors, could it be something else causing these problems?

    I've included the latest minidump once again.

    Appreciate any advice you're able to give!

    Attached Files:

  11. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    The one minidump that gave us a specific cause is 0x000000C1: SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION
    A driver wrote to an invalid section of the special memory pool. You need a new driver!

    The driver in question is nvlddmkm.sys which is a Nvidia video card driver. I suggest doing the following...

    1. Go to our Download section and click on Utilities and then download Driver Sweeper 3.1 to your desktop screen and install.

    2. Download the latest diver(s) for your video card but don't install them.

    3. Uninstall your video card drivers and reboot your PC into Safe Mode. Run Driver Sweeper and remove ONLY the video card drivers. I had someone use it on their chipset drivers! If it doesn't find any video card drivers that is quite okay; just leave all other drivers alone.

    4. Reboot and install new video card drivers.
  12. gojira

    gojira TS Rookie Topic Starter

    Thanks for your reply Route44.

    I did as you advised and I'll update this thread once I know something new :)
  13. gojira

    gojira TS Rookie Topic Starter

    Well, things have gone worse. This morning the computer suddenly shot off, no BSoD or anything, just powered off. Now it won't even boot. Pushing the power button does nothing, so I guess the PSU broke down completely :-(
  14. gojira

    gojira TS Rookie Topic Starter

    Hi again!

    Well I RMA'd my PSU and decided to go with a 650w 80+ Gold one instead, things seem to be much more stable now. For example the 5v is stable at 5.000 and 12v at 12.000.

    I just hope my old PSU didn't have time to damage my other components!

    I'll be running my computer normally for a while and I'll report any news, good or bad.

    Thanks for all your help so far :)
  15. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Okay, great to hear! A faulty power supply like faulty RAM will cause a myriad of issues while throwing out all kinds of error codes and differing reasons for problems.

    * Please keep us updated.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...