Several things not working after hard-drive clean-up

By bwarren97 ยท 5 replies
Apr 22, 2011
Post New Reply
  1. I have a DELL Dimension 8300 running Windows XP Pro. I had my hard-drive cleaned up after I realized that there was stuff on it that shouldn't be there. After that, several functions have stopped working correctly. I have found a solution for one of them, but the others still give me trouble. The problems are:

    -"Drive not accessable. Incorrect function" in the CD drives (solved...somewhat)
    -iTunes is unable to burn discs correctly
    -iPod does not re-sync with iTunes to add/remove songs
    -One user on the computer is unable to run installation programs, or any program labeled "Setup.exe"

    I first solved the CD Drive problem by openning Windows Media Player when a disc is inserted. This discovery was completely accedental, because I watched a movie on the computer using W.M.P., and was able to see what was on the disc using Windows Explorer after openning the program. Now, I had just recently discovered that activating Disc Detector also works. Does anyone know what's going on?
  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    When you say the hard drive was cleaned up what exactly was done to it? If you have had a virus infection type sfc /scannow into the Run box and hit enter, follow the prompts.

    The problems with iTunes will most likely be solved by reinstalling it.

    Go into device manager and uninstall everything under the CD drive then reboot which will reinstall the drivers.

    Sounds like one of your user accounts has been corrupted follow this microsoft guide to repair the problem.
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    If CD related problems persist, the symptoms you describe could be related to problems with driver filters. See if this might apply [post=815753]CD/DVD or Disk Problems? How to Fix Problems Caused by Filters[/post]

    After removing upper/lower filters and rebooting may also be good to reinstall iTunes and any iPod stuff.

    (p.s. your user problem, wouldn't be a filter problem tho)
  4. bwarren97

    bwarren97 TS Enthusiast Topic Starter Posts: 60

    I took it to a computer repair center to clean off the infected stuff. I, personally, don't think they did a very good job.

    I had iTunes reinstalled because of a registry error. Turns out I needed to upgrade anyway; the version I had was iTunes 7. My iPod worked fine at that time, but when I downloaded the new version, it wasn't able to communicate properly. iTunes isn't the only program with problems, though. In Scratch, it won't play instrumental music, and in Robotics Invention System 2.0, I couldn't upload programs or firmware onto my RCX.

    As for the other problems, I will see if I can fix those using your suggestions.
  5. bwarren97

    bwarren97 TS Enthusiast Topic Starter Posts: 60

    I tried uninstalling the disk drivers, then restarting. Nothing different popped up in the boot proccess, but when I logged on, a "Found New Hardware" balloon appeared. I waited a little bit, opened "My Computer", double-clicked on a DVD-ROM Drive icon,... change.

    As for the User Account problem, I am able to use a non-administrator account to run the setup programs, then running it as the problematic account.

    I can still use those features, just not in the same way I used to. However, the Disc detector doesn't really get in the way at all, which makes it seem like the problem was completely fixed. I guess the only way that discs can be accessed on the computer is by running an application that can directly access the drives, which the OS has lost the ability to do alone.
  6. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Have you run the sfc /scannow command?

    If this does not fix it run a Repair install by booting from the XP disc, follow the prompts as if your were doing a clean install and you will come to a screen giving the choice to "Repair". This will reinstall windows without removing any of your software or files. You should then check for any missing drivers in Device Manager and make sure you have Automatic Updates turned on.

    I am not 100% sure that a Repair install will not wipe out the user accounts so you may have to create new accounts. On reflection if the accounts are left intact and the microsoft guide does not fix the issue you have with non admin accounts then this is going to be a permissions issue. Use the administrator account to check the permissions for the non admin accounts.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...