Shut Down on Start Up - Blue Screen Error Message 0x000000c2

By ColMar
Dec 11, 2009
  1. Hi folks,

    I'm having a problem with my Dell desktop I'm hoping someone will have the solution to.

    I'm running a Dell Dimension 9100 with Windows XP Home Edition. When I switch the computer on it begins to load as normal (all be it a bit slow these days) and shows the XP welcome screen. Then, all of a sudden it powers down immediately and shows a blue screen message with the following error code: Stop 0x000000C2. See the image attachment.

    I phoned Dell who helped me run a few diagnostic tests on the hard drive and memory. Both of these were fine so they have said that the problem is software related. As the computer is out of warranty, I was informed that I'd have to pay for the solution so thought I'd have a go at fixing it myself with the help of the internet.

    Windows debugger produced the following (Minidump file attached):

    Microsoft (R) Windows Debugger Version 6.11.0001.404 X86
    Copyright (c) Microsoft Corporation. All rights reserved.
    Loading Dump File [G:\Minidump\Mini120409-03.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available
    Symbol search path is: SRV*c:\debug_symbols*Symbol information
    Executable search path is:
    Windows XP Kernel Version 2600 (Service Pack 3) MP (2 procs) Free x86 compatible
    Product: WinNt, suite: TerminalServer SingleUserTS Personal
    Built by: 2600.xpsp_sp3_gdr.090804-1435
    Machine Name:
    Kernel base = 0x804d7000 PsLoadedModuleList = 0x805634c0
    Debug session time: Fri Dec 4 12:00:55.187 2009 (GMT+0)
    System Uptime: 0 days 0:01:32.812
    Loading Kernel Symbols
    .................................................. .............
    Loading User Symbols
    ************************************************** *****************************
    * *
    * Bugcheck Analysis *
    * *
    ************************************************** *****************************

    Use !analyze -v to get detailed debugging information.

    BugCheck C2, {43, ddda4000, 0, 0}

    Probably caused by : ntkrnlmp.exe ( nt!CmpFree+17 )

    Followup: MachineOwner

    0: kd> !analyze -v
    ************************************************** *****************************
    * *
    * Bugcheck Analysis *
    * *
    ************************************************** *****************************

    The current thread is making a bad pool request. Typically this is at a bad IRQL level or double freeing the same allocation, etc.
    Arg1: 00000043, Attempt to free a virtual address which was never in any pool
    Arg2: ddda4000, Address being freed.
    Arg3: 00000000, 0
    Arg4: 00000000, 0

    Debugging Details:

    805db493 5d pop ebp

    BUGCHECK_STR: 0xc2_43



    PROCESS_NAME: winlogon.exe

    LAST_CONTROL_TRANSFER: from 8054f137 to 8053767a

    f6ea99e8 8054f137 000000c2 00000043 ddda4000 nt!KeBugCheckEx+0x1b
    f6ea9a24 8055182d ddda4000 e1f5b650 e1f5d000 nt!MiFreePoolPages+0x94
    f6ea9a64 805db493 ddda4000 00000000 f6ea9ad0 nt!ExFreePoolWithTag+0x1ba
    f6ea9a74 80660872 ddda4000 00002000 00000000 nt!CmpFree+0x17
    f6ea9ad0 8061a8e3 e1f54b60 00000000 00000000 nt!HvpRecoverData+0x3ec
    f6ea9b1c 805cfc5d e1f54b60 00000000 00000001 nt!HvMapHive+0x133
    f6ea9b34 805cf6e7 e1f54c01 00000005 00000000 nt!HvInitializeHive+0x3da
    f6ea9ba0 805cff3c f6ea9bdc 00000005 00000000 nt!CmpInitializeHive+0x26d
    f6ea9bf8 805ce62d f6ea9d04 00000000 f6ea9c64 nt!CmpInitHiveFromFile+0xa3
    f6ea9c20 805ce707 f6ea9ccc f6ea9c6c f6ea9c5c nt!CmpCmdHiveOpen+0x21
    f6ea9cac 805ce7a1 f6ea9ce4 f6ea9ccc 00000000 nt!CmLoadKey+0x90
    f6ea9d40 805ce7ff 0006dcc4 0006dcac 00000000 nt!NtLoadKey2+0x1fc
    f6ea9d54 804dd99f 0006dcc4 0006dcac 0006dcf0 nt!NtLoadKey+0x12
    f6ea9d54 7c90e514 0006dcc4 0006dcac 0006dcf0 nt!KiFastCallEntry+0xfc
    WARNING: Frame IP not in any known module. Following frames may be wrong.
    0006dcf0 00000000 00000000 00000000 00000000 0x7c90e514


    805db493 5d pop ebp


    SYMBOL_NAME: nt!CmpFree+17

    FOLLOWUP_NAME: MachineOwner


    IMAGE_NAME: ntkrnlmp.exe


    FAILURE_BUCKET_ID: 0xc2_43_nt!CmpFree+17

    BUCKET_ID: 0xc2_43_nt!CmpFree+17

    Followup: MachineOwner

    The report seems to suggest that the ntkrnlmp.exe program is causing the error. I can start windows in safe mode with networking but it won't let me perform a system restore.

    I think I've gone as far as I can without technical assistance, which is where I'm hoping those on this forum can come in !!

    Let me know if you require any other information or screen grabs from the pc in order to assist.

    Any help is much appreciated.


  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    0xC2 are caused by either faulty drivers or buggy software.

    ntkrnlmp.exe is a core Windows OS driver. Usually these are too general to be of much help.

    Do you have any other erecent minidumps that we can look at?

    Have you scanned for infections?
  3. ColMar

    ColMar TS Rookie Topic Starter

    Sorry for the delay in posting but this went on hold in the run up to Christmas and unfortunately Santa didn't bring me a solution !!

    Route44 - I've scanned for infections with Norton Antivirus 2009 which didn't find anything. I've attached some Minidumps as below for you to have a look at.


    My user profile was the only one set up on Windows but I tried setting up a new one and testing whether I could get into Windows that way. This worked as Windows loads with the new profile, but still cuts out when "loading user settings" on start up using my old profile.

    I've attached latest minidumps and screen grabs of the event viewer, system info and the windows error message. Hopefully some of you guys will be able to read more into them than I can at the minute.

    I've uninstalled both Norton Internet Security and Spybot Search and Destroy which i suspected of being the cause but my old profile still causes the blue screen error.

    I need to check whether I have the OS disk which may have come with the computer (I think Dell had stopped supplying them by the time I bought my pc). If I have it, I'll try and run the system file checker to see if anything is corrupt and needs repaired from the CD.

    Do the minidumps or screen grabs provide any inspiration to anyone as I'm running out of ideas?
  4. ColMar

    ColMar TS Rookie Topic Starter

    Attached Minidumps
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...