"Side by side configuration is not correct"?

By ikesmasher ยท 26 replies
Jun 17, 2010
  1. Right now with 3DS max and daz3D i get the following error: The Application has failed to start because its side-by-side configuration is incorrect. please see the application event log for more detail.

    right know its only with 3DS max and daz3D, but im sure there are other programs that will do it too. its probably because i was going through my computer deleting worthless stuff that i never used and i accidentaly deleted all the visual studio C++ stuff with it. i reinstalled all of it and this is what i have installed right now on VISTA 64 BIT home premium:

  2. jmjsquared

    jmjsquared TS Booster Posts: 145

    Perhaps this will help...

    You may try running the built-in System File Checker tool (SFC.exe) . START---> RUN then type: sfc /scannow and click OKAY .

    If that doesn't resolve your issue, you can download and try another Microsoft Tool here: http://go.microsoft.com/fwlink/?LinkID=167363
    (QUOTE): What is the System Update Readiness Tool?
    System resources, such as file data, registry data, and even in-memory data, can develop inconsistencies during the lifetime of the operating system. These inconsistencies might be caused by various hardware failures or might be caused by software issues. In some cases, these inconsistencies can affect the Windows servicing store, and they can cause software updates not to work. The System Update Readiness Tool tries to resolve these inconsistencies.

    What does the System Update Readiness Tool do?
    The System Update Readiness Tool verifies the integrity of the following resources:
    Files that are located under the following directories:
    Registry data that is located under the following registry subkeys:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Component Based Servicing
    Note This list may be updated at any time.

    When the System Update Readiness Tool detects incorrect manifests, files, or registry data, it might replace the incorrect data with a corrected version. (QUOTE)

    Good luck.!:wave:
  3. ikesmasher

    ikesmasher TS Evangelist Topic Starter Posts: 3,000   +1,319

    this is what sfc /scannow said:

    i cantpost the CBS log because it is HUGE. however if you need a certain part i can give that to you.
  4. jmjsquared

    jmjsquared TS Booster Posts: 145

    Last "easy" attempt...

    If SFC reported only a few irreparable corrupt files, you can look in other folders for other occurrences of the corrupt/missing files and copy them. If that is not feasible, please read on.

    The CBS.LOG can grow to 50 MB and then is copied to the CBS.PERSIST.LOG and a new log is started. So, for the next "possible", easy fix, you can open the CBS.LOG with Notepad, SELECT ALL and click DELETE. Click SAVE and Close. This will make finding corrupt files easier if the next step fails.

    Then, try booting from your Vista DVD and running SFC from the command prompt off the DVD making sure to tick "Run As Administrator". SFC should then access the DVD files to replace any corrupt files on your C drive.

    By-the-way, did you try the Update Readiness Tool? Actually, I doubt that it will help where SFC failed but it's worth a try. Besides, it may fix other discrepancies that have not been noticed yet. If you run it, it will produce two logs in the Windows\CBS folder: Cheksur.log and Cheksur.persist.log

    If the above does not work, I know of only one other possibility which is very time consuming and rather difficult and will require use of the Windows Automated Installation Kit (WAIK), a third-party application like "vLite" http://www.vlite.net/download.html , your Vista DVD and a DVD burner.

    Let's hope the "easy" way works. I'll check back in the next 12 hours.

    Good luck, Ikesmasher!

    ---JMJ :wave:
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Add'l comments and questions

    1. Yep. CBS.log gets HUGE, for sure. MS puts way too much stuff in the log to try and go through it by hand. You should use the findstr command. See http://support.microsoft.com/kb/929833

    2. What Vista SP level are you running????? (SP2 is the latest)

    3. Have you run all Windows Updates? Do you have Net Framework 3.5 SP1 installed?

    4. Trying to fix those side-by-side issues can be a pain. Do you still have the install CDs for your two apps? While we can address reinstalling the C++ redistributables, IMHO would suggest first seeing what SFC is complaining about and seeing f can be fixed. Also trying to simply reinstall the apps. If that still doesn't work
    > uninstalling the C++ stuff currently installed
    > uninstalling the apps
    > then reinstalling the apps
    > Then run Windows updates.
    > If problem persists, then post back.Next steps would be try reinstall 2005 and 2008 SP1 releases of the C++ stuff:
    Microsoft Visual C++ 2008 SP1 Redistributable Package (x64)
    Microsoft Visual C++ 2005 SP1 Redistributable Package (x64)
    then others if still needed​

    /* edit */
    And, not sure if needed, but just to know... do you have netframework 2.0 installed as well?

    / * edit2 */
    btw.. i'm guessing you haven't done disk image backups before the problem? may be a good idea to start now. Good freeware for the immediate job of capturing a disk image clone of your current system before trying more changes, use EASUS Todo Backup

    /* edit 3 */
    Ooops. Just re-read my post and realized forgot to write one of the things i thought to list: we should also check your application Event log to see if any more detail is available about what the problem is
  6. ikesmasher

    ikesmasher TS Evangelist Topic Starter Posts: 3,000   +1,319

    1.) i dont have a vista DVD i dont think D:
    2.) im on SP2
    3.) i have attempted reinstalling the C++ stuff several times, but windows installer exits when preparing files or whatever. it does say the stuff is installed in control panel though, im just not sure if it is correctly.
    4.)where is the application event log?
    5.) i think i have the latest .NET framework
    6.) cant reinstall 3DS max because i was very lucky to receive the extra copy of the DIGITALLY distributed software from my friends dads office, and my dad deleted the setup files, hes computer illiterate..
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1. Let's see what you currently have installed
    Run MyUninstaller. Click edit->Select All, Ctrl->C to copy, then paste into Notepad (Programs->Accessoried->Notepad). Attach it to next post

    2. Let's see your application event log
    > Recreate the side-by-side error message problem
    > Open notepad, copy/paste the command below, then save the file on your desktop name it Events.bat double click to run it. Attach the ApplEvents.txt file it will create on your desktop
    wevtutil qe application /c:50 /rd:true /f:text /q:"*[System[(Level=1 or Level=2 or Level=3)]]" > "%userprofile%\desktop\ApplEvents.txt"
    Post these.. then when you get a chance look through the link in prior post to use findstr to generate a list of the corrupt files from SFC

    /* edit */
    If you don't have the Vista DVD, do you know if there's a recovery partition on your computer? What is the computer make/model?
  8. ikesmasher

    ikesmasher TS Evangelist Topic Starter Posts: 3,000   +1,319

    i do have a recovery partition, but im too afraid to use it. its a shared family computer, with a bunch of important work documents on it. if any of them somehow get deleted or corrupted, i am in HUGEEEEEEEEEEEEEEEEEEE trouble.
  9. ikesmasher

    ikesmasher TS Evangelist Topic Starter Posts: 3,000   +1,319

    here is the uninstaller log thing. oh wait, its 363 KB, it can only be 200...eh..
  10. ikesmasher

    ikesmasher TS Evangelist Topic Starter Posts: 3,000   +1,319

    ok here is the application event log for 3DS max:

    Attached Files:

  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Oh. Didn't realize the tool generated such a bloated report! Instead: let's use SIW (i just tried on my machine and was only 40KB, and on second look, i also like the SIW output format better. :D )

    Download SIW
    > Click Software->Installed Programs
    > Click on any one of the program entries in top pane. Ctl-A to select all, Ctl-C to copy them, then paste into notepad
    Well, we can't do much about it if you haven't been doing backups so far but you need to start now (before applying any more changes to be safe). You also want to be creating drive "image" backups so you can preserve an entire disk image (it will also gives you normal file/folder recovery in addition ability to restore back to a full disk image to restore functionality to a snapshot in time)

    EASUS Todo backup is good freeware but only provides for full backup (which is good enough for now). Acronis True Image Home (which i use) is well worth $50USD. It also provides for incremental and differential backups which will help when you start running them regularly (now that you know the reasons why one should ;) )

    just fyi... i've seen some cases where these SxS errors get fixed. Others where a reinstall was needed... So can only hope for the best but certainly create a clone drive image backup of your disk now before you try anything else

    fyi2: as to backup drives: IMHO recommend a large external backup drive (e.g. an external USB drive). I'd suggest an external hard disk which has its own AC power adapter. (IMHO For critical backups, safest not to rely on drives which, themselves, rely on USB ports for their power vs. can provide its own power via its own AC plug)
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    A quick update...

    I found some interesting stuff in your Event Log. Based on what i see , I have a guess at what you're missing for DAZStudio3 . (is a best guess, won't know till we can try it)

    But before we try anything would be good if you did the backup first. And when you can, would also want to see the SIW installed program report before we try installing anything else

    /* edit */
    Also it looks like 3ds and DAZStudio are 2 different problems needing 2 different fixes. I have yet to chase down 3ds
  13. ikesmasher

    ikesmasher TS Evangelist Topic Starter Posts: 3,000   +1,319

    what should i do with a backup once a create it? to make sure ill be able to put everything back exactly the way it was in case after something goes wrong?
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) The good news is: Now that I've seen the Event Logs i think there's low chance of what we'll do will screw anything up as it, in fact, looks like you're simply missing 2 different C++ resdistributables (but i still need to see SIW to confirm that suspicion)

    2) But since you indicate the critical need to preserve the system i would still want to do the backup first
    > Just to err on the side of being "overly-cautious" given your situation and
    > It's something you should be doing anyway so we may as well be both cautious and start a good habit ;)

    3) EASUS Todo is fairly simple to use
    > Install it and using its menu create Bootable Rescue CD (only needed to do restores from backup when your system won't boot then you can from CD)
    > Next, create a full backup to physically separate media (i.e. you don't save backups on the same disk you're backing up)
    > When the backup is complete you can look through it, if you want, just for the comfort to see and know all the personal files and folders are there and you have copies of them.

    Then we'd do our changes. If you ever needed to restore from backup you do so with only a few mouse clicks from EASUS Todo menus. Start the restore, come back in an hour or less and computer should be back to where it was.

    /* edit */
    P.S. Acronis True Image Home is 50USD but a full free trial for the first 14 days so that's also an option. And, over the long haul, Acronis is better then EASUS as it supports incremental backups and other features useful once you start regular backups. Which ever we use for now is OK by me and up to you
  15. ikesmasher

    ikesmasher TS Evangelist Topic Starter Posts: 3,000   +1,319

    starting backup now...i didnt see bootable rescue CD so im just creating the backup on the same partition and ill copy it to a formatted external hard drive later
  16. jmjsquared

    jmjsquared TS Booster Posts: 145

    Question re findstr

    @LookinAround, I've been following along with ikesmasher and have a bunch of questions, the first of which is: How do you get findstr to generate a useable output. I keep getting cmd windows as unfriendly as sfc.exe's.

    @ ikesmasher, Please pardon my interruption. :eek:
  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184


    1. You probably already noted but i'll note as well: When you click Backup i'd suggest you click Disk 1 (because if you have multiple partitions it defaults to only backup the current active partition and you want to backup the whole disk)

    2. When backup is complete you can click Check Image File to have it verify the integrity of the backup

    3. Click Tool->Create Bootable Disk to burn and create bootable media

    /* edit */
    btw "Disk 1" in the EASUS display should reflect all the partitions on your hard drive
  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Did you copy/paste the command as shown in the MS support link (i provided earlier) into the command window? As findstr should then only output lines that have the text "Cannot repair member file" so you can see the filename
    [B]findstr /C:"[SR] Cannot repair member file" %windir%\logs\cbs\cbs.log >sfcdetails.txt[/B]
    Speaking for myself, no worries. "Healthy" and constructive comments, questions, and alternate views are welcome. This is a discussion forum as much as a help/support forum
  19. jmjsquared

    jmjsquared TS Booster Posts: 145

    JMJsquared :wave:
  20. ikesmasher

    ikesmasher TS Evangelist Topic Starter Posts: 3,000   +1,319

    I am done backing up
  21. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I only still need the SIW Installed Program report. [post=896529]Pls refer here[/post] for instruction
  22. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Actually.. while i'd still like to see the SIW report to confirm what's there vs. missing I think we can start without it

    I'm going to first describe what i did to identify and find the missing C++ redistributable library
    for anyone who might be reading/finding this thread in the future with similar problem (and, of course, hoping what i describe proves correct!)

    Some background: Many Windows apps are built using Visual C++ libraries. The tricky part is that there are many different versions of "assemblies" of the C++ libraries in both 32-bit and 64-bit "flavors". So the trick is tracking down the right flavor of the right assembly and version.

    One of the error messages in your Application Event Log
     Log Name: Application
      Source: SideBySide
      Date: 2010-06-17T20:31:17.000
      Event ID: 33
       Activation context generation failed for "C:\Program Files (x86)\DAZ 3D\DAZStudio3\DAZStudio.exe". 
       Dependent Assembly Microsoft.VC80.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.4053" could not be found. Please use sxstrace.exe for detailed diagnosis.  
    This is telling us that your app DAZ 3D requires:
    > the x86 flavor
    > of Assembly Microsoft.VC80.CRT
    > version 8.0.50727.4053

    If we google x86 Microsoft.VC80.CRT 8.0.50727.4053 and look at the hits we find Security update for Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package: July 28, 2009

    So next steps
    1. Try installing Security update for Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package: July 28, 2009

    This is an SP1 release so i'm guessing it's inclusive and doesn't require the original release.

    2. But, also note, your application log error would indicate DAZ 3D is dependent on this library so i'm also guessing the DAZ 3D installer includes this needed library. If above doesn't work, you can also try

    Find DAZ 3D in CltPnl->Progs and Features, and click its Change/Remove button
    > If it gives you a "repair" option, simply do the repair
    > Otherwise, run the installer and let it do an uninstall/reinstall

    See how this goes, then we can try tackling the other app
  23. ikesmasher

    ikesmasher TS Evangelist Topic Starter Posts: 3,000   +1,319

    ill install that update. in the mean while,

    Attached Files:

  24. ikesmasher

    ikesmasher TS Evangelist Topic Starter Posts: 3,000   +1,319

    Daz3D is working now, thanks alot! 3DS max is still not working though
  25. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    The 3DS max error msg in your Application Event Log shows a different dependency so it requires a different install then your other app

    Based on your Application Log error message for this case
      Log Name: Application
      Source: SideBySide
      Date: 2010-06-19T11:32:52.000
      Event ID: 33
       Activation context generation failed for "C:\Program Files\Autodesk\3ds Max 2010\3dsmax.exe". 
       Dependent Assembly Microsoft.VC90.OpenMP,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8" could not be found. Please use sxstrace.exe for detailed diagnosis
    For this case, we'll google for amd64 Microsoft.VC90.OpenMP 9.0.21022.8
    which seems to point to Security update for Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package: July 28, 2009

    Give it a shot and let me know
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...