Sims2 and DirectX 9.0c: Missing graphics card/driver

By Lightbulb
Dec 26, 2009
  1. I have had the Sims 2 installed on this laptop before with no problem. Before I went to university I uninstalled it and my uncle updated me to Windows Service Pack 3.

    This is the message I get when I try and open the Sims 2:

    (type http)

    I have since spoken to my uncle and have gone into -> Run -> Dxdiag - it says I do have DirectX 9.0c. I spoke to said uncle the other day (we have 2 family laptops and one has DirectX 10) and he said to uninstall DirectX then reinstall and restart. This didn't change anything.

    So, my sisters friend asked me questions about this laptop and he said that when my uncle fixed it the last time he forgot to reinstall the graphics card. When I go into Run -> Dxdiag -> Display - there is no device name and "n/a" is written next to
    manufacturer, chip type, DAC type and Approx. total memory.

    What do I do? :S

    My laptop is Sony.
    The sticker below it says:
    CPU: Intel Pentium M 740 1.73 Ghz
    Memory: 512 MB
    HDD: 80 GB
    WLAN: 802.11 b/g
    Optical: Double layer DVD RW
    Graphics: Nvidia Geforce Go 6200 with Turbocache supporting 128 MB
    OS: Microsoft Windows XP Pro

    The model No: Sony Vaoi VGN-FS295VP

    I have tried downloading a driver online from Nvidia but I get a message saying the hardware is incompatible then it terminates instead of installing.

    Help? :)
  2. mailpup

    mailpup TS Special Forces Posts: 7,189   +470

    Try going to Sony's website for your laptop's graphics driver.
  3. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Run Windows Update and look for a graphics driver update under HARDWARE

    You can only get the Geforce driver from Sony, not Nvidia. Try looking under the Sony model number in the UK, under Sony Laptop video drivers
  4. Lightbulb

    Lightbulb TS Rookie Topic Starter

    I've tried that, not working. I've entered in my Product Code & ID, selected the right driver (NVIDIA GeForce Go 6200) but the instructions on it aren't working right (after I install it it should appear in add/remove programs but it doesn't). So now I am assuming that it is because I have Windows Service Pack 3 and will take it to get fixed tomorrow =)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...