Slow applying personal settings on Win XPe thin clients

By bugsby2 · 14 replies
Apr 21, 2011
Post New Reply
  1. We have a lot of dell FX160's with XPE service pack 2 deployed on Windows 2003 domain. Everything is fine except for the login time which is 30-35 sec, about 25 seconds is taken by appyling personal settings. All users are using a mandatory profile and there is no network mapping on the endpoint or anything so we can't figure out what should be taking so long... They are set to DHCP, we have tried fixed IP addresses with no improvement.

    Any suggestions? anything would be very much appreciated.
  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Not my field of expertise but I'll see if I can assist.

    Does this problem occur on every user account on all the PC's?

    For experimental purposes try creating a new user account and see how fast that will load.
  3. bugsby2

    bugsby2 TS Rookie Topic Starter

    thanks for the reply,

    yes, I'm almost sure this is the case with all users on the current xpe thin client image that we use. I can try what you suggest but I don't think this is user related. I've always suspected some service or gpo that might be causing it but I have not got to the bottom of it.
  4. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    This microsoft guide may prove if it is a system service by allowing a clean boot with all services disabled.

    If this speeds things up try to isolate the service/s that are slowing things down by re-enabling only one half of the services, if that slows it down then you know the service/s is in that group so then renable half of that group and so on, This should quickly help to identify the service/s that are causing the problem. If they are non essential you can permanently disable them.

    There is a full XP tweak guide here which includes a section on XP services.
  5. bugsby2

    bugsby2 TS Rookie Topic Starter

    Is it possible to run msconfig on windows xp embedded? It is not working for me like it does on a normal xp machine...
  6. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    It should still run but you need to be signed on as an administrator.
  7. bugsby2

    bugsby2 TS Rookie Topic Starter

    It does not seem to work. Just comes up with the message that Windows cannot find 'msconfig', make sure you typed the name correctly, and then try again...
  8. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    OK, it should be there as XPE is only an extension of XP Pro. You could try opening a command prompt and see if that works. Click on Start and then Run, type cmd and hit Enter. Then type msconfig.exe and hit Enter, see if that does it.

    Unfortunately there is very little information available on XPE, all my wealth of experience is with plain old XP and Windows 7.
  9. bugsby2

    bugsby2 TS Rookie Topic Starter

    Can't get it either way. I agree about xpe! Wish we could move away from it but at the moment that is not an option.

    Maybe this is part of service pack 3. XPe never got the service pack 3 release.
  10. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Have you got automatic updates switched off, or is that not included in XPE. This link should get you SP3 but it should have come from microsoft as it was released in 2008.

    Having done a bit more searching (and actually found some information) it seems this OS was designed more for use on small electronic devices although the full version could be used as an OS on a PC. Only a few PC's were produced with this OS preinstalled.

    I would say it's time for a change. Even if you only move on to XP it would be an improvement but in about four years there will be no more support for XP so a bigger change will then be needed. Windows 8 is already in the pipeline.
  11. bugsby2

    bugsby2 TS Rookie Topic Starter

    Dell never released an image on their FX160 thin clients with SP3 installed and I have been told that they are not planning to do so. I guess we are at the mercy of the manufacturer in this case. From what I've read SP3 for XP embedded was only released to OEM's.

    The problem here is that these endpoints are specifically for a VDI environment ie there is no computing done on the endpoint. Basically the FX160 is a small device like you say. The build has a 2GB flash drive so installing the full XP is not an option and even Windows 7 thin OS takes more than 2GB I think.

    We are not ready to shell out a lot of money for new hardware....

    This is deviating somewhat from the original discussion:) but very interesting and I'm appreciating the feedback.
  12. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    With such a small amount of information available for your OS I have been unable to get the information I need to be able to advise any further. I've hit a dead end, without access to msconfig I have no idea what else to suggest.

    I do hope you will manage to solve the problem and may be some other members might have some constructive advise to give.
  13. bugsby2

    bugsby2 TS Rookie Topic Starter

    We have been frustrated with this for quite a while and also frustrated with dell for not releasing an image for their FX160's with SP3 installed.

    I've experimented quite a bit with turning off different services but nothing has worked so far.

    Mark56, thanks for all the input, hopefully someone with some direct experience with xpe will bump into this thread...
  14. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Your welcome, I only wish I could have been of more help, hope you manage to get it sorted.
  15. bugsby2

    bugsby2 TS Rookie Topic Starter

    Over 450 views and no comment, I guess XPe is a bit of a wildcard:)

    I've installed bootvis and looking at the results it shows logon+service taking 40 sec but I don't see any way to drill down and see what is actually happening... Any advice?

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...