Snipping Tool Wont Save in Vista

By yukka ยท 4 replies
Nov 10, 2008
  1. I have lost the ability to save using the snipping tool on some machines on my network. You can draw a box around items on the screen but you cannot then get a dialogue box when you click to "save". It also doesnt present a dialogue when you select "save as" either but I can forward the screenshot as an email or copy to clipboard and paste into mspaint.

    I have run process monitor and is does not show any problems. I have also tried sfc /scannow which doesnt fix the issue.

    I have read that it can be caused by moving the Pictures folder that snippingtool automatically looks for but it currently works on my own machine using UNC paths to my roaming profile but not on a second machine as either local admin account without roaming or my own account with roaming.

    I have tried moving the folders around so maybe that isnt it. I reimaged my machine to get it working with my roaming profile and that fixed it but how long it stays fixed remains to be seen. There aren't major changes between what was on there before and after and I have a few support calls requesting that it is fixed. It isnt acceptable to fix this issue by reimaging every machine on the network. I need to find a fix so I can adjust it with a login script or using sccm.

    Any help would be excellent. Using Vista Business with SP1 here.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Alternative (free) program for snapping (capturing) images from selected parts of the screen is:
    MWSnap, screen capture utility
    Works on Vista & Xp :grinthumb

    How to enable the Snipping Tool in Windows Vista
    • Click on Vista Start button, and go to Control Panel.
    • Click on Programs link.
    • Click on Turn Windows features on or off link. If User Account Control pops up for confirmation, click on Continue button.
    • Scroll down the list of features in Windows Features dialog window
    • Tick the check box for Tablet-PC Optional Components to enable and show the Snipping Tool in Vista.
    • Click ok

    Re-installing the Snipping Tool
    • Open Control Panel, click the Classic View in the Tasks pane. Double click 'Programs and Features'.
    • Select 'Turn Windows features on or off' in the Tasks Pane.
    • Remove the check mark from the 'Tablet PC Optional Components' and press OK.
    • Exit and reboot the computer. This will remove the Snipping Tool component.
    • After the computer restarts, go back into Control Panel and repeat the same procedure
    • Add the check mark to the 'Tablet PC Optional Components'
    • Reboot the computer again.

    Possible Software Conflicts & Fixes
    According to MS none ;)
    According to many users, the following:

    On HP: Disabling QuickPlay through MSconfig.
    On DELL: Uninstall QuickSet
    Miscellaneous startups - In this case try running the Snipping Tool in Safe Mode, to confirm it's not the tool
    Turn off Tablet PC Optional Components from Windows features and then turned it back on.
    Run Office 2007 Diagnostics

    Note: I was unable to find a one for all fix to this issue, the issue is presently unresolved.
    Please add to this thread if anyone finds another, or better solution
  3. pixelwizard

    pixelwizard TS Rookie

    mine is mis-firing also... no saving etc.

    Yup, me too.

    I have seen the other threads in this and other forums. So far nothing has fixed the problem, which arose after months of no problems with it. Now it won't save a capture, won't save-as, does nothing with a capture except email it.

    Running Vista Home Premium 32 bit.

    MS is silent on this and provides no downloadable replacements, and I found no MS fixes either.

    After managing to alter the security permissions on the files [these only] to do so, I also went so far as to replace the two occurrences of snappingtool.exe with copies from another machine. Nope... this stab in the dark had no effect.

    So far, no other on-board software has exhibited any peculiar behavior.

    I am not making a comparison with the other suggested third party freeware, above, to supplant SnippingTool, but here's an alternate: Gadwin PrintScreen 4.4 (free version). It's good, well liked over at cnet. See

    But it's not as good as SnippingTool was [when it worked right]!... no ability to make a freeform shape or to add 'pen' sketching to the image.
  4. Lynn770

    Lynn770 TS Rookie

    snipping tool won't save in Vista - this finally fixed it!

    My snipping tool stopped working over the holidays. Well, it stopped saving. I could take snips but they wouldn't save, I just couldn't get a save dialogue box to come up. I had gone through turning of the PC tablet options and rebooting; running the SFC/SCANNOW command, running the Windows office Diagnostics...nothing was working until today.

    Yukka - I wanted to thank you for posting the note about this having to do with moving the "Pictures" folder. This is what finally fixed the problem for me. When I moved my files over from my previous computer's hard drive, I deleted the "Pictures" folder on the new computer because I already had a "My Pictures" folder. All I had to do was add a "Pictures" folder back to the directory and the snipping tool started opening the save dialog box again. I've been struggling with this all week and was about to look into downloading a new snip tool.

  5. pixelwizard

    pixelwizard TS Rookie

    I seem to have found the fix for mine

    Given the above postings about the Pictures folder and/or a My Pictures folder being possible sources of the problem, I then happened to notice that the Pictures button in the right panel of the Vista start menu had also become useless at some point (clicking it did nothing; its properties panel was blank, with no tabs for adding a path or any other relevant info). The other buttons above and below that one were fine.

    I went looking for forum entries about that defunct button and found that adapting this procedure has now fixed both problems:

    Type 'regedit' in the
    Start Search box. In the registry editor, navigate to:

    "HKEY_CURRENT-USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders"

    In the right-hand pane, edit the path data for the value named 'My Pictures'
    so that it corresponds to the folder you want. Then log off & back on &
    your Start menu should know where your Pictures folder is.

    In fact I had no value named My Pictures. So I made one, by right-clicking within the blank part of that panel. Slide off of New and pick String Value. A name is now supposed to be keyed in; type 'My Pictures' (without the quotes). Then right-click this newly named thing - like a file - and you get the opportunity to put something in the second field, which is labeled Value data. In there you should place the folder path to your folder full of pictures for this current user. Mine looks like this: C:\Users\xxxx\AppData (10) where xxxx stands for my actual Vista user account name. Yours may look similar but don't count on that (10) being a match.

    How do I get these complicated looking folder paths (it's not the only way of course)? Open the folder in question. At the top of the window there's a field with the folder's name in it. Doubleclick that name and it magically transforms into an old-fashioned Windows-type pathway and this can be highlighted/copied/pasted... right into that Value data field waiting in your regedit creation.

    OK your way out of all this, restart the PC and test the Pictures button and the Snipping Tool.

    I still have no folder named My Pictures, by the way. The folder with the pictures in it, that looks like it's the proper folder as supplied by Vista for photos, was named Pictures before I did this repair and still is. So is the start menu button.

    Given that I can't recall whether I ever had a My Pictures folder after I migrated to Vista and given that the Snipping Tool worked fine for the first few months, this repair gives me the suspicion that a registry cleaning program was the source of the change. Such things may reassign registry values and somesuch. I use a few of them, and will be watching now for interference with this created-by-me registry entry. At least I know how to restore the missing function if necessary again.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...