Solved: Drive letters cannot be assigned to flash / USB drives under Windows XP

By Bluemouse · 69 replies
Sep 24, 2006
Post New Reply
  1. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Havent tried, but i can.

    What I dont understand is why it shows up in INTERNET explorer and not windows explorer. Are they not the same shells?

    I also get this problem when I go into disk manager where it comes up fine the 1st time, but if i disconnect the flash drive and plug it back in, it doesnt seem to want to go into disk management. I seem to have a similar problem with diskpart as well. It went in when I had already assigned a drive letter once, but when I disconnected and reconnected, it doesnt do anything anymore. Diskpart just closes after about 30 seconds or just stays at the "On computer: XXXX" line, while Disk management sometimes freezes at the "Connecting to logical device manager service" status.
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    There's something supressing that drive letter from showing in Windows Explorer. It's there... and accessible... It just doesn't show up.

    It makes sense that if it didn't work WE, it wouldn't work in IE either... But as we see, that's not the case. So your logic is sound, but it could be some specific, obscure bug which affects the way WE enumerates or displays drives just under the "My Computer" window.

    We'll just have to keep an open mind with this one, because it seems to defy most intellegent conceptions. :)
  3. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195


    Ending the dmadmin.exe task flixes the freezing problem....


    Microsoft DiskPart version 5.1.3565
    Copyright (C) 1999-2003 Microsoft Corporation.
    On computer: GRAL
    DISKPART> list volume
      Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
      ----------  ---  -----------  -----  ----------  -------  ---------  --------
      Volume 0     I                       DVD-ROM         0 B
      Volume 1     C   System Driv  NTFS   Partition     60 GB  Healthy    System
      Volume 2     E   Data Drive   NTFS   Partition   7217 MB  Healthy
      Volume 3          MY USB  FAT    Removeable    62 MB
    DISKPART> list disk
      Disk ###  Status      Size     Free     Dyn  Gpt
      --------  ----------  -------  -------  ---  ---
      Disk 0    Online        75 GB      0 B
    DISKPART> select volume 3
    Volume 3 is the selected volume.
    DISKPART> list disk
      Disk ###  Status      Size     Free     Dyn  Gpt
      --------  ----------  -------  -------  ---  ---
      Disk 0    Online        75 GB      0 B
    DISKPART> assign letter = M
    DiskPart successfully assigned the drive letter or mount point.
    DISKPART> list volume
      Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
      ----------  ---  -----------  -----  ----------  -------  ---------  --------
      Volume 0     I                       DVD-ROM         0 B
      Volume 1     C   System Driv  NTFS   Partition     60 GB  Healthy    System
      Volume 2     E   Data Drive    NTFS   Partition   7217 MB  Healthy
    * Volume 3     M   MY USB       FAT    Removeable    62 MB

    Still doesnt show up in my computer though....

    And the other problem is that once I use up a letter and disconnect the device, i can no longer map anything to it until I reboot, almost as if the computer still thinks it is there. If I remap the drive without disconnecting then I can use the old letter fine...

    What drivers control this stuff? Also, I found something called USBdetector.exe on my computer and uninstalled it, but it didnt do anything useful. I dont know where it came from really, or where to download it again.
  4. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Yes, i was running home and then upgraded, but i think it was faulty before that, just cant remember for sure.

    Formatting is not an option, because I dont have enough space and dont really want to spend like 80 bux going to some pc repair shop to do a backup. I also have a lot of custom configs on here which took me a while to do, as well as some software installed where I lost the cd.

    My USB ports are not faulty, because my external hdd works fine, and the USB key is recognized when I dual boot ubuntu.

    Edit: I just tried driveman as a 3rd party drive manager, and it only detects it once i map the drive
  5. Sphere

    Sphere TS Rookie

    ok tried all of those and no luck, i mean if i could get Microsoft update working i reckon it would fix it but everytime i try i get this error code:

    [Error number: 0x8024402F]
  6. N3051M

    N3051M TS Evangelist Posts: 2,115

    re: windows update problem.. This site may help.. here's the summary:

    try clearing out your temp files:
    Internet Options>
    -delete Cookies
    -delete files
    -[settings]>[view objects]>delete if any there (optional)
    Close IE and reopen or reboot your PC and try..

    Check your router/internet connection and settings, check your firewall etc.

    Curious.. does your USB sticks pick up in WE like normal on other pcs?
  7. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Windows uses a generic 'usbstor' driver which handles virtually any USB storage device. It's included with your Windows install.

    This is different than your USB host controller drivers. If there were a problem with usbstor, reinstalling SP2 (for example) should fix whatever problems may exist with your USB storage driver.
  8. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    where can I get just usbstor by itself?

    If it is an OS issue, then what could be the causes?

    The only thing I can think of is drivers, so which drivers could cause the issue?
  9. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Just one more thing. I have a SD card reader on my laptop and I have the same problems with them too in that slot. Therefore, it HAS to be some driver that deals with flash memory, since my USB flash key, USB mp3 flash player and CARD flash disk all do the same thing.
  10. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Your SD-card reader is probably connected via your internal USB bus, so that doesn't necessarily mean it isn't USB. But I think your USB storage drivers are much more likely a cause than USB itself. I don't 100% rule anything out, but I don't believe it is either. Purely based on conjecture, I think it some quirky Windows problem with assigning drive letters under a certain set of circumstances. Of course, I am not a software engineer, so my guess is as good as yours.

    If you're looking to install your USB mass storage driver, your system's original usbstor.sys (driver), (service) and usbstor.inf (setup information) will be located on your XP install disc. You'll find the files in the i386 folder somewhere (may be in subfolders.. not sure) and the last letter of the extension is usually chopped at the end like so: usbstor.sys will be usbstor.sy_ on your CD.

    Here are the directories where these files belong and should be copied to:
    • usbstor.sys - C:\Windows\System32\Drivers\
    • - C:\Windows\INF\
    • usbstor.ini - C:\Windows\INF\

    The only complication I forsee is Windows File Protection. If you copy those files over, they'll just get overwritten (without any warning) by the originals cached by WFP. We need to disable WFP before copying those files.

    Since SP2, MS has removed the option to disable WFP, although we can still enlist the aid of an application (or registry setting) to disable WFP at this point. Search around and you'll find something as I don't have any recommendations.

    You can also use SFC (System File Checker) from the command prompt. Just type in SFC /SCANNOW and make sure you have your Windows XP disc in the original install drive. It will scan your computer for corrupted or changed versions of system files, which I'm assuming includes usbstor.sys and .pf and probably ini and replace them with nice, fresh versions from the CD.

    There have been updates to the XP USB storage driver over the years as well, prior and probably after SP2. So reinstalling your SP2 would probably have the same affect as copying or SFCing the files.

    Just some more ideas... Good luck!
  11. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    I already tried the sfc, and it screwed up my nvidia drivers :S It also took a while, since it kept prompting my for my cd when I already had it in, and I had to mash "retry" about 100 times to get it to complete. Still have the same problem though :S

    Thanks for the ideas though :)
  12. Sphere

    Sphere TS Rookie

    Can anyone give me the installation for the windows usb driver?
  13. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Would the sd card slot be connected via internal USB? How would I check that?
  14. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    What version of Windows are you talking about? XP has it's own USB drivers, but if don't trust them, try searching
  15. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195


    It had something to do with the registry, and nothing to do with the drivers at all.


    Be sure to try remapping your drive letters before attempting this fix. It is only to solve the issue once the drive letters refuse to remap properly

    For Windows XP Only - Not sure of the exact registry keys for 2000, but should be similar

    1) Go into start -> run -> regedit -> hit ok

    2) Navigate to:

    3)file -> export (the mounteddevices1 folder) and save to a chosen location

    4) delete all the dosdevices drives (ie. \dosdevices\C: )

    5) I cant remember if i did it to the "mountd devices" folder too, so dont do it at first but if it doesnt work then do it after

    6) go to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}]

    7) Export this too and save to a chosen location that you will remember

    8) delete the upperfilter key

    9) reboot and try plugging in your device.

    This actually didnt work for me when i tried it, but then i tried plugging in my device an hour later and it worked flawlessly (all 3 flash drives)

    Hope this helps! Your registry may be slightly different, but look in there, there are probably a bunch of keys that are screwing it up.

    Cheers :)
  16. Sphere

    Sphere TS Rookie

    OMG DUDE I LOVE YOU!!!!!!!!!!

    Its back working, I appreciate everyone’s help Thank you for taking the time and helping :)
  17. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Ditto :) .
  18. Swaine77

    Swaine77 TS Rookie

    Aiya! Careful with that registry!

    I've got the same problem with my thumb drives not showing up in Windows Explorer so I was really excited when I saw your post. I saved the registry folders that you said to back up but after I destroyed my registry, XP wouldn't boot and I didn't know how to restore them. :) :p So I booted in safe mode and restored a Restore Point. That got the registry restored and XP booting again. I probably should have been more cautious but I deleted all the \??\Volume entries and a lot of the ones below those like (ie \dosdevices\C:). I really hope I can figure out how to tailor your fix to my machine and get the auto-drive assignment working again.

    Moral of the story: Don't delete registry entries unless you know EXACTLY what you're doing.
  19. hounddawg

    hounddawg TS Rookie

    It worked for me!

    Thanks for this solution. I'm not sure what went awry with my system, but I suspect it had something to do with a new version of McAfee that I installed a couple weeks back. It was called McAfee Plus. I'm using XP Media Edition on my HP Pavilion. It was a replacement to the previous online version of McAfee. After installing it my operating system started going stupid. I ended up having to do a system repair. It seemed to work OK for a couple days then started going stupid again.

    I found out that McAfee has crappy support options - some dumb online chat thing that makes you type forever and a support line that is a pay per minute 900 number. I'm not paying to debug any company's software! I uninstalled, ran their cleanup utility and demanded a refund.

    I got a call a couple days later to do a survey. Too bad they spend more time doing survey's than they do supporting the customer. They can do all the survey's they want now. I'm not paying to install crap.

    As for HP, I spent about 3 hours working on this problem with them (three different support people) and they ended by telling me that I'd have to do a clean install. NO WAY! Another couple hours of research and I stumbled across this one and it worked. Thanks folks.
  20. enciel

    enciel TS Rookie

    thanks so much!!! i have been having the same problem for months and your instruction with the registry fixed everything!!! i thought reformatting was the only way to repair it to how it used to be but now its working perfectly!! thanks so much!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  21. leosoybean

    leosoybean TS Rookie

    Same here! The clear instructions were greatly appreciated.
  22. DRayX

    DRayX TS Rookie

    No MountedDevice1

    I don't have a MountedDevice1 folder in my registry just a MountedDevice folder. I tried removing the DOS files from this but it didn't help. Any suggestions would be greatly appreciated.
  23. Redwin

    Redwin TS Rookie

    I solved this problem another way round. Deleting the upperfilter I see more like a workaround. I think the upperfilter is there for a reason. Btw I don't think you have to delete the MountedDevice thing. The Bluemouse (workaround) works fine for me just deleting the upperfilter. Take a copy of the key (or better of the whole registry) before you do anything. Don't mess with the registry if you don't know what you are doing. After you have deleted the upperfilter do a reboot. After the reboot Windows should tell you it has installed some hardware and want's to reboot. Do that and you should be good. Works for me. Now, here's what I did instead of deleting the upperfilter. I found out the file SPTD.SYS in C:\windows\system32\drivers (XP) was the reason for bad behaviour. The SPTD.SYS and SPTDxxx.SYS belongs to Daemon Tools. The xxx are some numbers. So, by uninstalling Daemon Tools and rebooting, same thing happend. After reboot windows installed some hardware and after a new reboot everything was ok. If you have Daemon Tools installed, to figure out if thats the reason, move the two files mentioned above to an empty folder. Do a reboot. After the reboot windows should install some hardware. If you can see your Flash Drive after a new reboot you know the reason. I don't know who's to blame. The Daemon Tools or the Flash Drive. But there have been some problems with SPTD.SYS over time. Another thing. After doing it, no matter what solution you use, take a look at your drive letters. They maybe changed. Remap them back to where they were from the start. Sorry for my bad english.:eek:

  24. Brainer

    Brainer TS Rookie

    Thanks Bluemouse

    Happened to me after a "less than smoothe" SP2 installation.
    Your fix worked instantly.

    I keep getting an "insert disk" error on booting but I can live with that.
  25. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    brainer, that probably has to do more with your boot options than with the hd. maybe you have it set to boot off usb or cd before hard drive. Check your bios settings.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...