Spread the love! TechSpot Tech Gift Shortlist 2017

Solved: Drive letters cannot be assigned to flash / USB drives under Windows XP

By Bluemouse ยท 69 replies
Sep 24, 2006
Post New Reply
  1. jobeard

    jobeard TS Ambassador Posts: 10,845   +897

    here's a screen shot showing the discontiguous mapping letters that work
    for me -- they even get retained across boots.

    the USB devices will get mapped (for me) as E:\ F:\ when attached

    Attached Files:

  2. Bluemouse

    Bluemouse TS Rookie Topic Starter Posts: 195

    Not following ;) Whats your issue again? :)
  3. JohnMart

    JohnMart TS Rookie

    Entries in UpperFilters key were the cause on my system

    Bluemouse's fix resolved the issue for me and I am extremely grateful to you as I had previously spent countless hours looking for a fix for this issue and your fix was the only one that worked.

    I do have some comments that may be helpful to others with this issue as follows:

    My machine is running Windows XP SP2 (and it was upgraded to SP2 but I don't think that is relevent to this issue). My issue was exactly as Bluemouse stated in the beginning, however, in addition, I had discovered that when I did manually assign a drive letter to the partition on the usb flashdrive, even though it was not seen in My Computer or Windows Explorer, the data on the Flashdrive could be accessed by drive letter from a command prompt. Of course, after the machine was rebooted, the drive letter went away again.

    Below are some differences that I encountered on Bluemouse's fix (at least on my system):

    On step 3, there was no MountedDevice1 folder, only a folder called MountedDevices. I performed step 4 on the MountedDevices folder on my machine.

    On step 8, the key was called UpperFilters

    ----- I think deleting the UpperFilters key in step 8 was what did it on my system as I originally deleted the UpperFilters registry key as per Bluemouse's instruction and the issue was resolved. I then ran the reg file I had saved previously to put the UpperFilters registry key back because I was not sure what it did. I then experimented further and was able to narrow down the specific cause and fix the issue while still keeping the UpperFilters key in my registry ----- Here are my notes:

    There were three values in the UpperFilters key in the registry on my machine as follows (and this was the order they were originally in):


    I found that snapman (which is a service used with Acronis True Image) was causing the issue and to be more exact, it was not that it was one of the values in the UpperFilters registry key, but rather that it was first in the list. By having snapman last in the list, I could still use that service but it did not cause any drive letter assignment issues.

    This is the order they are in now and all is working well:


    Important Note: If you plan to leave the UpperFilters key in your registry (rather than deleting it) ,then at a minumum it needs to have the value PartMgr in it, as that value is for the Windows XP "Partition Manager Driver" (partmgr.sys) which Windows XP uses to assign drive letters to partitions.

    BTW... I did try putting Phylock (is used by another imaging program called Image for Windows) first, then PartMgr, then snapman, and there were no issues, so the issue only occurred if snapman was prior to PartMgr.
    You_Guys_Rock likes this.
  4. Sgluber

    Sgluber TS Rookie

    MANY THANKS Redwin!

    First of all, HELLO TO EVERYBODY of this GREAT community! :)

    This is my first post here.

    GREAT, Redwin! ;)

    My problem is exactly the same posted by Bluemouse and added by JohnMart. My first try was to do what Bluemouse described, but don't work for me and I needed to restore de backuped registry because the normal boot failed after the changes.

    But after to read your post, Redwin... I simply follow your words - I have Daemon Tools installed -, moving SPTD*.sys out from \windows\SYSTEM32\drivers and reboot: PERFECT! :bounce:

    Just this to solve for me - the exact point! - MANY THANKS REDWIN (rep to you)! :grinthumb

    PS.: Probably I'll consult this GREAT forum again in the future, but I registered just now only to post this message and to thank by the support.

    SO, CONGRATULATIONS TO EVERYBODY who created, support and announce this *VERY* GOOD site! :D
  5. picha69

    picha69 TS Rookie

    Great solution, THANK YOU!

    I just registered to say THANKS for the solution. It worked perfectly and I am a happy man again.
  6. ikostic

    ikostic TS Rookie

    Didn't work for me and my problem is a just bit differnent to the original problem

    In my case the USB memory stick/flash drive works if it is connected before user logon to computer, but not if it is connected after logon.
    I haven't got file C:\WINDOWS\system32\drivers\SPTD.SYS and solution from BlueMouse didn't work.

    Other symptoms are all the same.

    1) The drive letter is assinged in the Disk Management
    2) I can work with the files on it in CMD window.
    3) I can open and save files in any application including IE.
    4) USB Hard Drives of any kind work fine.

    You migh think that there is no problem just plug it in before logon.

    The problem is the system / or better say systems (96 of them in 4 computer labs) are used in a University. There are about 4000 users and itis hard to explain it to each of them.

    I am looking after 11 computer labs. 7 of them are MSI Hetis (Intel 915 chipset) and they don't have problem. But 3 older with Intell 865 and new one with DQ965GF chipset are having problem above which I am trying to solve for the last 6 months (from time to time).

    Note: I am using same XP Pro SP2 Syspreped image on all computers. The image orignally was developed on MSI machines but I have tried later to reinstal Windows on the 965 chipset image (on the top of existing Windows) and the problem stayed. The image is over 35 GBs mostly Engineering and programing applications whicha are updated at least every semester start, so I don't want to maintaind 2 or 3 images.

    Tere is no problem with any of them when I install clean Wndows.

    Any help appreciated.
  7. JoeHoops91

    JoeHoops91 TS Rookie

    I followed Bluemouse instructions and it worked for me and my camera and all my usb devices are working now. But now in My Computer I have 2 new Local Drives (E) and (F). My hard drive is C and CD-R is D, and now I have these 2 local drives. The first one is a FAT system and it contains a Dell folder and all files MDM files like "Dellsys.mdm and usbmass.mdm.. The 2nd one has a couple of folders. The folders are BAT" , "SRC1" , "SRC2" , "SRC3" , "SRC4" , "SRC5". Can someone tell me what these Local disk are and are they harmful to my computer? Do I need to put those 2 things I backed up from the Registry back there?
  8. prisnusber

    prisnusber TS Rookie

    Sansa E280 still not working for me

    I tried all these solutions posted in this thread but my new mp3 player e280 still does not show as a drive letter. It does appear in the device manager and it works but in order to use automatic sync software it has to show as a drive letter. Any other ideas? THANKS!
  9. buksorn

    buksorn TS Rookie

    Many thanks from Thailand.

    Now figure out what caused it. Thanks bye
  10. wyderp

    wyderp TS Rookie

    I've had the same issue on a dell tower running XP 2002 SP2. deleting the upperfilters (plural, btw)from 4D36E967-E325-11CE-BFC1-08002BE10318 worked great for me too. It is likely that Auto update did a downgrade to some files or stomped on a config - how pathetic is that? Microsoft should be embarrassed that everyday users have to do this crap just to get their junk OS to do everyday stuff. Do Linux/UNIX/OSX have issues routinely reading a mounted drive? answer: almost never.
  11. digilla

    digilla TS Rookie

    Much Easier Solution

    I found a MUCH easier solution to this issue. I simply deleted the device from the Device Manager and rebooted. When I rebooted the drive letter was assigned to D: instead of E:. Here is exactly how I did it:

    1) Right-click My Computer and choose Manage
    2) Select Device Manger
    3) Expand Disk Drives (make sure your SD card is inserted before you go to Device Manager)
    4) Left-click on SD Memory Card and choose Uninstall
    5) Reboot
  12. L1qu1d

    L1qu1d TS Rookie

    Hi guys, new guy here.

    Just thought I'd register to let you know another way of fixing this is similar to Redwin's idea, however it doesn't require a restart.

    If you have Daemon tools installed, simply right click on the tray icon and set the amount of virtual drives to 'disabled'

    worked for me, who knows.
  13. guitarrez

    guitarrez TS Rookie

    Problem solved!! USB Mass storage now visible in XP explorer!!

    Thank you Bluemouse!! After scouring the internet for 3 weeks this finally worked!! I backed up the registry filed like you said, and after a blue screen and a couple of reboots, I plugged in my mass storage device and WALA!! It was automatically assigned letter F; by the XP explorer!! Letter E: was assigned to a virtual drive on my Lenovo IBM, drive C:, used for backup and recovery. I suspect that there was a conflict before, with the IBM virtual drive and my USB mass storage, both trying to use the E: drive. I had tried using Disk Manager to assign another letter to the USB mass storage, but it still had not worked. Oddly enough I was able to access the USB mass storage device from the the Device Manager and other programs like Outlook for attachments, but NOT through XP Explorer. NOW it works!! Just a question: I noticed that the DOS-Drive letters were recreated in the mounted device folder.... How about the upper-filter thingy? Is that automatically re-installed as well?

    Now another issue: How do I get my Plug and Play to work?? I normally wouldn't care, but I'm trying to install a Canon printer that relies on the plug n play for installation. Before I reinstalled Windows XP, I used to get a "New Hardware Detected". Not any more. Anybody??
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Just some additional info/suggestions for anyone else finding their way to this thread...

    There are several different methods to fix problems caused by "Driver Letter Conflicts" (which is typically the root cause of the problem described in this thread)

    IMHO: The simplest (and most thorough) solution is using the DriveCleanup Tool
    • The "Drive Letter Conflict" occurs because your USB device is competing for the drive letter with some old / prior installation data still on your computer.
    • And your USB device has lost the battle for the drive letter! (so the USB device appears in Device Manager but not My Computer or Explorer with a drive letter)
    • Running the DriveCleanup Tool will uninstall / remove old installation data for all currently unplugged USB storage devices
    • So the next time you replug the USB storage device, Windows does a new, clean install and reassigns it the next available drive letter

    Here's some helpful links for reference
    > See this post for [post=727106]How to use the DriveCleanupTool[/post]
    > If you're still having USB issues see [post=720762]Troubleshoot: Windows Won't Recognize Your USB Hard Drive[/post] (<= rewritten 11/21/09. So if you've read this post before is worth taking another look!)
    > To help avoid problems in the future see [post=753513]How to Avoid Problems with USB Storage Devices[/post]
    You_Guys_Rock likes this.
  15. pearls

    pearls TS Rookie

    @blue mouse

    i have thru the regedit....
    where should i export the things u said us to export..
    more over i dint mobile device1 in my regedit. could u make it little more clear on that
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Try this. See [post=727106]How to Cleanup and Remove old USB Mass Storage Drivers[/post]
    You_Guys_Rock likes this.
  17. Raptor88

    Raptor88 TS Rookie

    John Mart and BlueMouse,

    I want to thank you both for helping me fix my USB access problems that I had done many hours of searching with no joy till now. I'm so thankful that I registered on this forum to thank you both. I'll describe my fix as it might help others, as this thread helped me.

    *** MY SYMPTOMS WERE: ***
    1. SanDisk 12-in-one USB card reader no show in Explorer. Showed in Disk Management but no drive letter. Trying to add a drive letter got an error msg saying that the drive or volume was not available. Reboot to make available. (paraphrasing since I did not write the exact wording down) --- Bottom line, no way to access the card reader.

    2. Thermaltake external USB hard drive no show in Explorer. Showed in Disk Managment with a drive letter. Able to open drive from Disk Management only. Able to do backup or restore using TeraByte Image For Windows. Not accesible using Acronis TrueImage 8 (I guess since not registered in Explorer).

    *** THE FIX: ***
    Using John Mart's UpperFilter tips, I found that my upperfilter was set as snapman, Phylock, PartMgr. I changed the order to PartMgr, Phylock, snapman per John's post. To change the order, just click on the UpperFilter entry. A text box will appear with the three entries on three lines. Just edit as you would with a text editor.

    Unbelieveably both my USB SanDisk card reader and USB Thermaltake external hard drive appear in Explorer (My Computer) and both work normally now. THANKS JOHN MART!!!

    Before I changed the order of PartMgr, Phylock and snapman, I had tried the following which may or may not have affected the final fix:

    I have IDE and SATA hard drives as C, D, E, F, G and two optical drives as M and N. Using Blue Mouse's procedure I deleted the DOS devices for drive letters H, I, J, K, L, O, and P. In other words, drive letters that I was not using. I also deleted the Upper Filter statement.

    After a restart, the card reader and external drive still did not show up in My Computer. I ran XP's Tweak UI and under My Computer > Drives, the drive letters for H, I, J, K and L were unchecked. I checked them so now all drive letters were checked. I'm 99.9% sure that all drive letters were checked prior to doing BlueMouse's procedure of deleting the DOS drives.

    After a restart the card reader and external drive appeared in My Computer. Inserting a SD card in the reader brought up the AutoRun box. I was estatic! But then I discovered that the drive letters for my hard drives were scrambled. Only the C drive retained the correct drive letter. Also in Disk Management, there were NO drive letters for any of the drives and no way to change or assign the correct letters to the drives.

    Since I had exported the Mounted Devices and Current Control Set folders from the registry prior to doing anything, I imported both and after a restart my drive letters were back to normal but my USB card reader and external drive had the same problem as before.

    This is when I tried John Mart's method of changing the order of the entries in the UpperFilter. After a restart, both USB devices appeared in My Computer and worked normally.

    FWIW, my USB inkjet, USB laser printer and USB scanner always worked. But they are permanently plugged in the back USB ports. My card reader and external drive are plugged into the front USB ports.

    After so many days and days and hours and hours of searching the web, I'm really happy that I found this thread and got my USB devices working like a champ.

    Thanks BlueMouse for getting John Mart on the right track. Thanks John Mart for posting your experience which fixed my problem.

  18. Blues

    Blues TS Rookie


    Bluemouse, I registered on this forum, basically to thank you very much for the solution to a very annoying problem.

    Thankyou Very much indeed.
  19. You_Guys_Rock

    You_Guys_Rock TS Rookie

    I CANNOT thank everyone enough who stuck it out and worked diligently until some solutions and / or fixes were found! Great job!

    LookinAround's suggestion to use the DriveCleanup Tool is pure genius and it really helped my situation.

    JohnMart's discoveries regarding Upper Filters was extremely helpful, too.

    Anyone who suggested reassigning drive letters for your HDDs and CD/DVD drives so that they were more grouped together and therefore allowing adequate quantities of sequential drive letters to be available for USB drives (flash, internal and external card readers, etc.) also deserve honorable mention.

    Here are my notes in case they might benefit someone else down the line... (NOTE: I should have done the following steps with a reboot between each one to verify which one had the most impact...sorry about that).

    I should mention the problem I was having first. I bought an internal card reader for my Windows 7 Pro build (64 bit) and then started experiencing Windows Explorer errors and hang ups as a result of drive letter issues (and perhaps Acronis True Image).

    1. The first thing I did was shut down and disconnect the internal card reader from the USB header and disconnect ALL USB devices.

    2. After a reboot I went into Disk Management and reassigned my HDD and CD/DVD drives so they were all grouped together at the top (Ex. C, D, E, F, G, H).

    3. Then I ran the DriveCleanup Tool (thanks to LookinAround) which removed all traces and registry entries regarding any USB device I had ever used on this PC since I installed Windows 7 (clean install BTW).

    4. Regedit was next, in hunt of any and all Upper and Lower Filters VALUES containing "snapman" (a product of Acronis True Image, if you have that installed) and was VERY CAREFUL to only delete the " snapman " portion of any Upper and Lower Filter VALUES I found. What I mean there is DO NOT delete anything else, not spaces or carriage returns you might find within the VALUE. Most likely the only other thing you'll find in there is " PartMgr " which must be there, followed by a carriage return (leave the carriage return there). You might find other information within these VALUES, but the only thing I removed was " snapman " (without the quote marks of course).

    5. I then shut down the PC, let it sit a minute, then turned it back on with all of my USB devices (internal and external) still DISCONNECTED to make sure everything was working properly at that point. When I saw that it was, I shut down again and reconnected the internal card reader and booted up. Just before it gave me the desktop it informed me of device drivers being installed and it assigned the first four available drive letters to my new internal card reader.

    Now I'm up and running with no problems! Like I said earlier, I'm not CERTAIN which step took care of my issue, but you really can't go wrong by completing all of the steps I mentioned.

    In my case I consider it SOLVED, but I know that might sound like a stretch of the word to some. After all of the frustration I went through to get to this point, though, I feel like it's a victory. I'm very grateful to everyone on this post for all of your help...much more valuable than any tech support person on the phone could provide.

    Good luck, hope this helps someone out there.
    LookinAround likes this.
  20. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184


    Thanks for posting all your efforts. Job well done. Glad to hear you were able to fix your problem (y)

    Happy Computing!

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...