Tech Stocking Stuffers: 18 awesome gifts under $50

STOP: 0x000000D1 ntfs.sys, I'm stuck

By jstluise ยท 12 replies
Sep 6, 2009
  1. I tried going through the guide to stop error messages, but I wasn't making any progress. Hopefully someone can give me some guidance.

    *HP desktop computer w/ Windows XP Home Edition
    Problem: A couple days ago, while the computer was being used it would shutoff and restart automatically, without notice. It starting doing it more frequently so I automatically thought virus. But, I couldn't do the 8 steps because the computer would restart in the middle of the tests. Soon, the computer wouldn't even get past the startup screen before restarting. Once in a while it would start up all the way and then restart later. NOW, it won't get past the startup screen...just starts up, restarts, starts up, restarts etc. Not even Safe mode will work.

    At that point, all I wanted was to save some documents off the drive and then reformat it. So I plugged the drive into another computer (as a secondard drive), but doing that caused the other computer to act the same way and I could not gain access to the screwed up drive.

    Next, I tried to repair the windows installation but using the recovery disc. But as soon as I hit "r" to repair, I would get the BSOD:

    Technical information:
    *** STOP: 0x000000D1 (0x8CBDE014,0x00000002,0x00000000,0xF7074416)

    I restarted and tried "To set up Windows XP now, press ENTER", but again, after pressing ENTER this time I got a similar BSOD:

    Technical information:
    *** STOP: 0x000000D1 (0x8CBDE014,0x00000002,0x00000000,0xF7074416)
    *** ntfs.sys - Adress F7074416 base at F7073000, DateStamp 41107eea

    I don't know what else to do. Is there any way I can save some data on the drive? Mostly all my other data is on an external drive but there are some things that would be nice to get back.

    I am already planning to pick up a new drive, but is there anything I can do with this one? Any help would be great! Thanks!
  2. Jawshh

    Jawshh TS Enthusiast Posts: 392

    You may have faulty drivers on your system. Its more likely being caused by your hard drive. Possible Fixes:

    1.Boot from your XP cd. Enter Recovery Console, Log on the XP installation and type chkdsk /r

    2.Reset the bios or load its default settings

    I am not really sure, but I think your hard drive or RAM is faulty because you are not even able to perform a clean install of XP.
  3. jstluise

    jstluise TS Rookie Topic Starter Posts: 27

    I read about doing option 1, but I can't even get logged onto the XP installation because the get the BSOD as soon as I try.

    Haven't tried doing anything with the bios yet.

    I'm guessing it is my HDD because it made the other computer act the same least that shows that it isn't any other hardware in the computer causing the problem.

    Is there anything else I can do to try and access the drive? Some backwards way that I haven't tried yet? I'm stumped.
  4. errorjack

    errorjack TS Rookie

    Try posting your Minidump?
  5. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Since he can't access windows he won't be able to access his minidump. I suggest posting your issue on the Memory and Storage Forum.
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    [post=793472]Look through this post/thread[/post]
  7. Jawshh

    Jawshh TS Enthusiast Posts: 392

    You can create a recovery floppy disk( if you have a floppy drive). Put a floppy disk in the floppy drive of another computer running same OS. Right click on the drive and select format, then check "create MS-DOS recovery disk" . Then boot from floppy and type chkdsk /r
  8. jstluise

    jstluise TS Rookie Topic Starter Posts: 27

    Thanks everyone for the replies.

    I tried to disable the autorestart, but that didn't work...just kept the blue screen up and didn't restart.

    LookinAround, thanks for the link...I am downloading Knoppix right now to try. Sounds like it is worth a shot.

    In the meantime, I do have a floppy drive so I will try what Jawshh suggested.

    Thanks again everyone...I'll post updates with my progress.
  9. jstluise

    jstluise TS Rookie Topic Starter Posts: 27

    I tried this but couldn't get it to work. Got to the command line but the command would not work.

    Did a quick search and read that NTFS systems cannot be accessed from DOS. Is this right? If not, a little more detail on the procedure would be nice.

  10. jstluise

    jstluise TS Rookie Topic Starter Posts: 27

    Update so far...

    I tried using the recovery console again (by d/l the .iso and booting off a cd). I ran into the same problem as I did before.

    I burned Knoppix. I was able to boot into Knoppix just fine, but could not mount the drive. It came up with an error when I tried to access the drive.

    When that didn't work, I wanted to verify that I got the copy of Knoppix okay. I used HashTabs to check the hash sum values. When I click on the .iso of Knoppix>properties>file hashes tab, the MD5 hash value that comes up matches the .md5 file that I downloaded to check against. However, when I click the "Compare a file..." button and select the .md5 file, the hash comparison comes up with a red X and a hash number I haven't seen before.

    So I don't know if I got the Knoppix .iso okay or not...I'm confused of the hash comparison. ???

    Any other options for recovery? Please let me know if I should post this problem in a different forum.

  11. orondf

    orondf TS Booster Posts: 93

    your hard drive is bad... replacing it will fix the problem, but you will have to reinstall windows and you will lose all your files...
  12. easethepain

    easethepain TS Rookie Posts: 16

    To clarify the drive is dead boot from a dos boot disk to a dos prompt when it has created the ram drive letter type Fdisk it cannot read an ntfs partition but will interogate the HDD if it works the hdd is fine and you just have a corrupted ntfs partition which you might be able to fix with either fixboot or fixmbr

  13. jstluise

    jstluise TS Rookie Topic Starter Posts: 27


    All files are recovered. Even though I couldn't mount the drive in Knoppix, I used "testdisk" in Knoppix to explore the files on the drive and copy them onto a flash drive. It took a while because I only have a 1gb flash drive, but I got them all eventually. I tried accessing my external usb hard drive through Knoppix so I could copy my files onto it, but Knoppix couldn't mount that drive either. Seems Knoppix has trouble mounting the NTFS file system, where it was fine mounting the FAT32 system (my flash drive). I'm sure there is a way to make it work, but I'm not familiar with all the code for Knoppix.

    I don't know what to do next with this drive. I already bought another drive so I can set the system back up and running again. Maybe I'll mess with the bad drive later...could just be a corrupted NTSF partition that can be fixed using Knoppix.

    Thanks guys for the help.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...