1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Strange USB Flash Drive problem

By jddomine ยท 12 replies
Jun 21, 2008
  1. Like many of you, I own several USB Flash drives. My latest additions were two 8GB SanDisk Micro Crusers with U3 bought at two different times over the last 3 months. They have been working flawlessly up until 3 days ago. When I inserted a drive into a USB port, the amber light came on for 1-2 seconds and then went dark; it did not show up in Windows Explorer or Hardware Manager. The same thing happened with the second Cruser drive. I then tried some of my older USB Flash drives including two PNY 1GB drives and a 2 GB SandDisk Micro Cruser Skin drive; they all worked as did my PNY Media Card Reader for Secure Digital cards. ALL of them worked when connected to the computer (Dell Dimension 4550, Intel P4, 2.53 GHz, 1GB RAM running WinXP HomeSP3). I tried the two 8GB Cruzers on the rear USB ports: they still didn't work. I tried them on my laptop (Lenovo duocore Intel Centrino, 1 GB RAM running WinXP Home) and they BOTH worked fine!! They also worked on a new Gateway AMD QuadCore 2.2GHz with 3GB RAM running Vista.

    I cannot use any jump drive utilities because the drives do not connect to the computer. It's as though when it is powered up, it senses that there is something wrong and immediately shuts down. I also understand that I cannot add a new driver to the computer without having the jump drive up and running; is this true?? Why would I need a driver any way?? I am considereing getting another 8 GB (or less) SanDisk Micro Cruzer with U3 and connecting that; that might install a new driver that all of them can use, or it might put the new jump drive into the same condition of not working on this computer.

    Should I consider "disabling" or "unistalling" (which??) all the USB Ports one at a time (all at one time??) to see if that resets / reinstalls a non-corrupted dirver?? BTW, I have rebooted several times including with one of the non-working jump drives inserted in a slot, but there was no change in the outcome.

    I don't think it is a failure in the jump drives themselves in that (1) they are both really new, (2) it happened to both of them the same night (they were, however, plugged in separately) and (3) they both work in my other computers!!

    Have you heard of this before?? Got any suggestions??

    Regards, jdd 20080620 [[]]
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Your Dell computer may be infected with a virus or other malware
  3. jddomine

    jddomine TS Rookie Topic Starter

    Thanks for your feedback. I guess anything is possible, but I would be surprised to see a virus deactivate / prevent a connection with a specific, identical set of two jump drives, which does not completely incapacitate them (they still work on the other two computers), and which does not affect three other jump drives when plugged into the same slots on the Dell computer!! That is a really targetted virus!!

    BTW, I use Norton AV (updated automatiically) and both SpyBot and Ad-Aware and CCleaner to keep tabs on my registry changes.

    Thanks. JDD 20080623
  4. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 228

    It is possible that the non-working drives have an A-type USB 2.0 Male connector that is just slightly smaller than the size specification, though within manufacturing tolerances. It could also be that the USB A-type female sockets on your PC have been manufactured on the 'large' side of its size specification, again within manufacturing tolerances. This could be causing the drives to only intermittently receive power and possibly not enough to run it when it is getting power. If, by chance you have access to an A to A Male/Female USB 2.0 Extension cable, you could test this theory out.
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    sandisc drives use U3 technology. Get rid of it and retry.
  6. jddomine

    jddomine TS Rookie Topic Starter

    Thanks to both of you for your inputs.

    Tedster: I will try to delete the U3 stuff from my jump drives using my laptop. I can also uninstall it from my computers. Thanks.

    NetCablesPlus: Do you think the geometric mismatches could have gone unnoticed for more than a month and could be found on 6 ports on my desktop and at least 2 ports on a 4 port hub all on the same night with both Cruzers that work when connected to USB ports on two other computers??

    JDDomine 20080624
  7. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 228

    I did not realize that you were also having trouble through a Hub (at least I did not see it in your original post.) It was a longshot to start (offered for an unusual problem), and that additional information makes it even less likely.
  8. jddomine

    jddomine TS Rookie Topic Starter

    Thanks. This is quite a mystery.

    Regards, JDD 20080625
  9. SOAD

    SOAD TS Rookie Posts: 55

    i have the same stick and vista began to not detect it was plugged in. on the occasions it did find it, i tried to reformat the stick, hoping it would fix it. During the reformat, it would stop half way and say it failed.

    I then tried reformatting the stick on an old windows 2000 pc that is in my house. It completed the reformat and has been working flawlessly on both vista, xp and the 2000.

    Could be worth a go reformatting on a different pc?
  10. jddomine

    jddomine TS Rookie Topic Starter

    Thanks for your suggestion. I first uninstalled U3 from both Cruzers -- no change. I then reformatted one of the Cruzers using my laptop -- it is still not recognized by my desktop. It reformatted cleanly with no hesitations / stops.

    Next suggestion anyone??

    JDDomine 20080628
  11. CA_Tech

    CA_Tech TS Rookie

    Scan for viruses. Also select a drive letter for the drive in device manager - disk management.
  12. tengeta

    tengeta TS Enthusiast Posts: 612

    Try other USB devices in the same port just to make sure its not a short of any kind. Seems really unlikely, but its happened to me. I had to put things in that particular port before I turned on the machine or it just went haywire.
  13. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    You will also need to remove the U3 partiton - and reformat the whole drive with 1 giant partition.

    U3 is absolute crap and causes a lot of issues on many systems. In fact, the government forbids U3 drives on DoD computers.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...