Stupidest XP problem ever!

By LeonE
Jan 5, 2007
  1. I know how ridiculous this sounds, but it's the honest truth:

    This evening I got home from work to find that my new PSU had come in the post. My old etech 400W PSU was a bit noisy so I'd opted for a higher wattage but lower noise model from Arctic Cooling.

    I took the old one out of my case and had got the new one installed within about 10 minutes. On powering up all seemed fine, until the inital system checks were done when I was told that Windows XP had failed to start successfully.
    "Maybe I inadvertently dislogded a cable" I thought, so I switched it all off and had a good look inside the case, but all looked fine. I tried again but got the same problem. I then tried booting in safe mode, thinking I could use one of my system restore points. It booted in safe mode ok, but for some reason there were no restore points saved. At this point I was hungry so I shut it down again and got sopmething to eat. On returning, I forgot to boot in safe mode but it booted in normal mode ok, and took me to the usual log-on screen so I thought everything was ok.

    However as soon as I'd entered my password I got a pop-up notification telling me that I have 7 days left to activate XP. If I choose the "activate now" option, I get another message saying "Windows XP has already been activated" (which of course it has) and it then loads my personal settings as normal. Everything works fine and I can't find any other differences apart from that. What worries me is that once it passed midnight here, I restarted and was told that I now had 6 days to activate. It seems likely that in 6 days time if I haven't resolved the problem I'll be unable to use Windows at all.

    My first question is, how the hell could this happen from changing a PSU?! No other hardware has been changed and I've checked all connections about 10 times- nothing has been accidentally swapped or loosened.

    2nd question- does anybody know how I can resolve it? If I click "Yes" to activate it tells me that it's already activated, and clicking "No" just bypasses the screen altogether and loads my desktop as normal, leaving the ominous countdown timer ticking away the days...
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    That is very odd indeed and I have no idea what happened. However, I suggest you contact Microsoft and explain what`s happened. They should be able to offer you some advice on what you should do.

    Regards Howard :confused:
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

  4. LeonE

    LeonE TS Rookie Topic Starter Posts: 17

    I managed to solve this problem last night after a long time searching through various websites, and thought I'd post the solution because from what I gather it's a common problem yet I only found one resource that explained how to fix it.

    I don't want to take the credit from this guy so I'll post a link to his findings here ( but I'll summarise what he said to hopefully increase the chances of somebody finding it through Google, as it took me ages.

    The obstacle that I had to overcome was that Windows asked me to activate it, but when I tried to do this I was told that it had already been activated. The countdown timer kept ticking and I knew that if I didn't fix it soon I'd be stuck in an endless loop of "please activate me" followed by "I'm already activated" followed by "please actuvate me" and so on!

    I'd tried altering the OOBETIMER registry entry, moving the wpa.dbl and wba.bak files from the System32 directory, all to no avail. In order to get Windows to think that it hadn't been activated I had to edit the actshell.html file found in Windows\System32\oobe.

    Open it with Wordpad, and go to around line 3598 (I did this by using ctrl+f and searching for the word "already" as this appears right near to where you need to be).

    Scroll down a little until you see:

    if (g_Already_Activated == 0) then display the already activated
    if (g_Already_Activated == 999)

    Then simply change the 0 shown above to a 1, exit the file (saving changes) and the next time you're asked to activate windows it should let you follow the activation process rather than inisist that it's already been activated.

    NB If your timer has already run out then I think you're pretty much screwed- from what I've read as soon as it tells you that Windows has already been activated it the kicks you out to the log-on screen, where you're then told that you need to activate Windows, and so the endless cycle begins. In this case I think a clean install is the only way to go.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...