SUSE Linux 9 (SLES 9) GRUB loading stage2... stuck

By ComputerGuy55 ยท 6 replies
Nov 18, 2011
Post New Reply
  1. Hey, so were dealing with Linux in my class and the teacher got us to install Apache server. It worked fine for everyone except one student when he turned on his machine the next day it stalled on

    GRUB Loading Stage2...

    Like above. I've tried to search a solution on google to fix this issue. Just wondering if anyone here has found a fix for this problem.. I am continuing to look for a fix online, will update if I find one..

    Thanks in advance

    UPDATE: A few things I would like to add that I forgot to put. We removed apache from the machine and it still doesn't boot. We can also load into the OS if we put in the installation CD, and do an "Update" just basically hitting Next on all the steps and it loads into Linux fine..
  2. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    yes, this has nothing to do with Apache (which is a service which runs AFTER boot time).

    Grub is the newest boot manager for Linux - - suggest you address the Linux install.
  3. ComputerGuy55

    ComputerGuy55 TS Maniac Topic Starter Posts: 380   +8

    Yeah I'm not super great with Linux commands.. I assume it's because GRUB can't find the HD or partition to load off of and it stalls, but I don't exactly know how to change this or where to. I assume its in the "grub config file" as I've read on other forums/posts.
  4. Grub stage 1/1.5 cannot find stage 2.

    To cut a long story short, stage 1 is the part of grub which resides in the MBR, stage 2 is usually in the /boot directory on one of your main partitions. If grub cannot find stage 2 then it's usually because it's not installed/configured properly or grub cannot find it because it's on a volume or file system which requires a specific kernel module to be loaded for it to function. Disk failure is another possibility - this is actually likely as you have said that it was working ok previously.

    (SLES 9 is also ancient in Linux terms, it was released in 2004 and it uses a very early 2.6.x kernel.)
  5. ComputerGuy55

    ComputerGuy55 TS Maniac Topic Starter Posts: 380   +8

    Can't upgrade. If it were my choice I'd use Ubuntu (not really a linux fan myself anyways, but if it were my choice) but for our course the teacher distributes SLES9.

    Anyways. It worked perfectly fine for about 2 months until we install apache, and then the next day after a reboot it would not load properly. So were not too sure what the issue is.
  6. This has nothing to do with Apache, it's most likely a hardware issue. If your educational establishment runs SLES then they must know how to maintain it - refer it to them.
  7. ComputerGuy55

    ComputerGuy55 TS Maniac Topic Starter Posts: 380   +8

    I know its not to do with Apache, I was just saying that's the last thing he did on it. And the teacher isn't a fantastic Linux teacher, she knows basics and teaches right out of the book. She doesn't know the answer. If she did I would not have had to post on the forum.

    I'm looking for a way to fix the issue. I know its related to the boot, I've read that on other forums as I already posted above.. I'm looking for someone to either direct me to a website with instructions, or tell me here if and how to fix the issue.

    I assume I have to edit the grub config file (as I posted above as well) but I do not know linux well enough to do it, and apparently neither does our teacher.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...