TCPIP.SYS related BSOD Crash

By HorseloverFat ยท 7 replies
Aug 12, 2007
  1. Hello. I'm new to the forums, although I've frequently browsed the threads here when I have technical issues or just want to read up on how something works.

    Lately I've been experiencing semi-regular BSOD crashes on one of my computers. It's an extremely mediocre setup (Sempron 2400+, 512mb, etc) that I use solely for running some P2P clients, so I don't have to waste resources on my other computer or leave it on constantly. Anyway, back to the issue.

    Maybe 4-5 times a day I've been getting a blue screen of death. It used to just reboot, until I changed the "automatically restart" option in the hopes of getting some more info to try to solve the issue. The blue screen mentions TCPIP.SYS and some memory addresses, but aside from that doesn't give much of a clue as to what's going on. I *think* the problem is related to BitComet, as it only seems to happen when that app is running, though I haven't extensively tested that theory (I'm going to tonight, I plan on leaving it on without BitComet running and see if it crashes).

    At first, after Googling the "Your System has Recovered from a Serious Error" message that I initially was getting after an auto-reboot, I thought it might be bad RAM, so I ran MEMTEST and sure enough there were errors, so I replaced that right away. MEMTEST no longer finds errors in the RAM, but the problem persists, unchanged.

    Then I got to thinking about what had changed recently that might be a factor, and thought that the problem might have begun when I switched from my motherboard's onboard Marvell LAN to the onboard NVidia LAN, so I switched back and disabled the NVidia LAN in the BIOS, but no luck there either - it just crashed again right before I came here and started writing this post.

    I've created debug logs of my minidumps for two of the crashes - the most recent one after switching back to the Marvel LAN, and an earlier one with NVidia LAN. I'll attach both, if anyone thinks they can glean any useful information from them. One difference I noticed is that the latter debug log, the one for the crash that occurred with the Marvel LAN, has a few error messages about being unable to identify modules, while the earlier crash does not.

    I know for sure that it's not malware or a virus, as I've had Kaspersky Internet Security Suite running real-time protection and I've done a full scan on the highest protection settings. I also should mention that I did a fresh format very recently, installed all Windows updates, etc. Oh and, the problem DID exist before the format, I was hoping it would get rid of it.

    I haven't completely ruled out the NVidia LAN as the culprit, since even though it's disabled in the BIOS the drivers would still be installed, would they not? Right now that's my only lead, since the problem did seem to start when I switched to that onboard LAN. Aside from that there's nothing I can think of except a hardware failure of some sort, and I've already ruled out the RAM by replacing it with a brand new stick.

    Sorry this post is so long, but I always prefer to err on the side of too much detail than not enough.

    So, can anyone suggest anything, or gather any clues from the debug logs? I'd be eternally grateful for any help.

    PS. Crash1.txt is the earlier crash, with the NVidia LAN, and Crash2.txt is the later crash with the Marvell LAN.

    Attached Files:

  2. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Although the minidumps are crashed at tcpip and I believe the problem is related to hardware. The module list of the second debug report was corrupted and it is the symptom of hardware problem. Probably the ram, psu or overheat. Attach more debug reports here if you have. It can help us to confirm whether it is hardware or software problem.

    WARNING: Frame IP not in any known module. Following frames may be wrong.
    440688be 00000000 00000000 00000000 00000000 0xbc189c21
    start end module name
    804d7000 806eb500 nt ntoskrnl.exe Wed Feb 28 04:10:41 2007 (45E54711)
    806ec000 8070c380 hal halaacpi.dll Wed Aug 04 01:59:05 2004 (41107B29)
    b9083000 b90ae000 __ ?? unavailable (00000000)
    ba101000 ba142000 ______________________________________ba101000 ????????????????????????????????????? unavailable (00000000)
    ba16d000 ba190000 Unknown_Module_ba16d000 Unknown_Module_ba16d000 unavailable (00000000)
    ba220000 ba229000 _________________________________________ ????????????????????????????????????????? unavailable (00000000)
    baa96000 baae8000 srv srv.sys unavailable (00000000)
    bab60000 bab8d000 mrxdav mrxdav.sys unavailable (00000000)
    bac7b000 bac90000 wdmaud wdmaud.sys unavailable (00000000)
    baf0c000 baf10000 ndisuio ndisuio.sys unavailable (00000000)
    bf800000 bf9c2180 win32k win32k.sys Thu Mar 08 08:47:34 2007 (45F013F6)
    bf9c3000 bf9d4580 Unknown_Module_bf9c3000 Unknown_Module_bf9c3000 Wed Aug 04 02:00:51 2004 (41107B93)
    bf9d5000 bff42500 nv4_disp nv4_disp.dll Fri Jun 29 04:13:08 2007 (4684BF14)
    bffa0000 bffe5c00 ATMFD ATMFD.DLL Wed Aug 04 03:56:56 2004 (411096C8)
    f4cbd000 f4cd5000 dump_atapi dump_atapi.sys unavailable (00000000)
    f4d9d000 f4dbe000 ipnat ipnat.sys unavailable (00000000)
    f4dbe000 f4df6000 klif klif.sys unavailable (00000000)
    f4df6000 f4e65000 mrxsmb mrxsmb.sys unavailable (00000000)
    f4e65000 f4e90000 rdbss rdbss.sys unavailable (00000000)
    f4e90000 f4eb2000 afd afd.sys unavailable (00000000)
    f4eb2000 f4eda000 netbt netbt.sys unavailable (00000000)
    f4f02000 f4f15000 nltdi nltdi.sys unavailable (00000000)
    f4f15000 f4f6d000 tcpip tcpip.sys unavailable (00000000)
    f4f6d000 f4f80000 ipsec ipsec.sys unavailable (00000000)
    f4fc4000 f4fc7000 Dxapi Dxapi.sys unavailable (00000000)
    f721f000 f7230000 nvarm nvarm.sys unavailable (00000000)
    f7230000 f7315000 nvmcp nvmcp.sys unavailable (00000000)
    f7315000 f737b000 5W 5W unavailable (00000000)
    f73d0000 f7404000 Unknown_Module_f73d0000 Unknown_Module_f73d0000 unavailable (00000000)
    f742c000 f745d000 _____ ???? unavailable (00000000)
    f74ed000 f74fc000 sysaudio sysaudio.sys unavailable (00000000)
    f74fd000 f750e000 ___e______d________________________d___ ???e? ????d????????????????????????d? ? unavailable (00000000)
    f750e000 f7525000 __f750e000 ? unavailable (00000000)
    f7525000 f7549000 portcls portcls.sys unavailable (00000000)
    f7549000 f755d000 Unknown_Module_f7549000 Unknown_Module_f7549000 unavailable (00000000)
    f755d000 f75c3000 Unknown_Module_f755d000 Unknown_Module_f755d000 unavailable (00000000)
    f75c3000 f75d7000 ___ ?? unavailable (00000000)
    f75d7000 f7c55000 Unknown_Module_f75d7000 Unknown_Module_f75d7000 unavailable (00000000)
    f7c55000 f7c78000 Unknown_Module_f7c55000 Unknown_Module_f7c55000 unavailable (00000000)
    f7c78000 f7cc4000 Unknown_Module_f7c78000 Unknown_Module_f7c78000 unavailable (00000000)
    f7e2f000 f7f0d000 Unknown_Module_f7e2f000 Unknown_Module_f7e2f000 unavailable (00000000)
    f7f0d000 f7f4e000 yk51x86 yk51x86.sys unavailable (00000000)
    f7f4e000 f7f71000 USBPORT USBPORT.SYS unavailable (00000000)
    f7f85000 f7f89000 Unknown_Module_f7f85000 Unknown_Module_f7f85000 unavailable (00000000)
    f8130000 f8133000 rasacd rasacd.sys unavailable (00000000)
  3. HorseloverFat

    HorseloverFat TS Rookie Topic Starter

    Thank you for your reply.

    I've attached zip files of all my minidumps since the format. The most recent one, 04 in the file, is the one for which I posted a debug log that contained the errors you mentioned. Only that most recent minidump happened while running the Marvell onboard LAN, all the rest happened with the NVidia LAN.

    Last night I tested a different theory than what I said initially - I ran BitComet all night, but by itself - the last few times that the crash has occurred I was running BitComet and eMule together. Anyway, NO crash last night with BitComet running alone. I'm going to leave it running that way for the rest of the day, and then try running it with just eMule tonight to see if that will crash it. If eMule alone doesn't crash it then that means it only happens when both apps are running.

    The fact that the crash seems to be dependant on exactly what software I have running leads me to suspect that it isn't hardware... Am I wrong to think that? I truly hope it isn't hardware... As I said before, the RAM was JUST replaced, so I really doubt it's the cause. PSU, I could buy a new one if that turns out to be the problem, but I do have ASUS' PC Probe utility running and monitoring different aspects of the power supply, and it hasn't popped up any warnings. As for motherboard, I have a couple of spare Socket A motherboards that I could swap in to test that, but both would be a step backwards as far as features, etc. But my gut is telling me it's not hardware here; maybe it's just wishful thinking, but I find it really odd that the crash would be dependant on which of two very similar programs happens to be running at the time.
  4. HorseloverFat

    HorseloverFat TS Rookie Topic Starter

    Okay, I just came back to the computer to find that it HAS crashed again, with just BitComet running. It just took a LOT longer before it crashed, it seems. In my system tray, all that I had running was BitComet, NetLimiter, and PeerGuardian. So that rules out Kaspersky Internet Security Suite and eMule, but doesn't conclusively place the blame on BitComet yet. Tonight I still plan to run it without BitComet and see if it crashes still.

    This is really frustrating, but I do sort of feel like I'm making progress, at least in ruling things out.

    Here's the debug log and minidump for this latest crash.
  5. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Your Windows maybe crashed with multiple culprits. It is software problem of Kaspersky Anti-Virus and ram problem. The reason why I suspected it is ram problem because some dumps have corrupted module list. Most of the crashes are at tcpip!TcpipBufferVirtualAddress+8. TCPIP.sys is very stable module and it is unlikely it is the software error of tcpip.

    I find klif.sys is installed at your windows and your version has known software problem. You can search google with "44d328c7 bsod" and you will find a lot of hit. You had better de-install Kaspersky Anti-Virus or upgrade it to latest level.

    Your version of Kaspersky AV
    klif.sys Fri Aug 04 19:00:23 2006 (44D328C7)

    BTW, some version of emule has conflict with ZoneAlarm. But your PC does not have ZA.
  6. HorseloverFat

    HorseloverFat TS Rookie Topic Starter

    Thanks again for your reply cpc2004.

    Kaspersky Anti-Virus isn't running on my computer anymore, and the crash still happens. I didn't uninstall it though, I'll try that.

    I posted this same topic on the forums and someone there says that he thinks it looks like the culprit is either the NVidia LAN driver or some interaction between it and BitComet, and recommended that I re-enable it, uninstall it, and then disable it at the BIOS level again, so I'm going to try that. He also posted a link to a thread on another forum about a similar problem to mine.

    What do you think? His thoughts on the matter jibe with my suspicions about the NVidia LAN and the fact that, as far as I can remember, the problem began around the same time that I switched to it from the Marvell LAN.
  7. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    The stack trace of the minidump does not have the footprint of the module that you mention. I believe that some device driver screws up memory and it causes TCPIP crashing. It maybe NVidia LAN driver but I cannot prove it.

    f7442b94 f4f4227f 01000000 00000010 81b0009d tcpip!TcpipBufferVirtualAddress+0x8
    f7442bb4 f4f43b32 000278cf 81b0b134 826edb18 tcpip!XsumSendChain+0x44
    f7442c34 f4f4394a 8286d988 826edb18 f8edc8c0 tcpip!UDPSend+0x3ca
    f7442c58 f4f439b0 00442c7c f8edcfa0 81b0b174 tcpip!TdiSendDatagram+0xd5
    f7442c90 f4f42308 f8edc8c0 f8edc954 f8edc8c0 tcpip!UDPSendDatagram+0x4f
    f7442cac 804e37f7 82569f18 f8edc8c0 f8edc8c0 tcpip!TCPDispatchInternalDeviceControl+0xff
    f7442d14 804e37f7 8251fc68 00000000 f8edc99c nt!IopfCallDriver+0x31
    f7442dac 8057d0f1 00000007 00000000 00000000 nt!IopfCallDriver+0x31
    f7442ddc 804f827a f4f2d5f8 00000007 00000000 nt!PspSystemThreadStartup+0x34
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16
  8. shortguy014

    shortguy014 TS Rookie

    Uninstall NetLimiter, this seems to the problem with most of these types of BSODS.
    Check Here, shows how the problem was resolved.

    I cant post links yet, so subtitute hxxp with http and doubleudoubleudoubleu with www
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...