The memory could not be "read"

By Auldsod ยท 6 replies
Feb 20, 2009
  1. I keep getting "The Instruction at 0x7c9524f9 referenced memory at 0x00000010. The memory could not be 'read.' (or 0x7c90100b...memory at 0x00000034) Click OK to terminate the program." Happens at any time, very often when desktop PC has been idle for about 20 minutes or so. This error wipes out some folder settings (details to thumbnails) and always my QuickLaunch menu. Must reboot my PC and the shutdown window has invariably become transparent. XP Home SP3 fully updated. 2 GB RAM. 140 GB free disk space. Intel Core 2 Duo 2.46 GHz. Nothing recorded in Event Viewer. Googled internet and found this error to be very prevalent, but no fix found. Please assist. Thanks: mail
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Have you replaced the memory, or tested the memory? Or run the computer with only one memory module at a time?
  3. Auldsod

    Auldsod TS Rookie Topic Starter Posts: 18

    Hi raybay. Thank you for the reply. When I bought this PC about 18 months ago it had 512 MB RAM, which I replaced with two cards of Crucial DDR2 RAM, 1024 MB each, in the ASUSTeK Computer INC. P5VD2-MX 1.XX Motherboard, and have never had any problems, until the Microsoft updates recently which included IE 7.

    I have always suspected IE 7 of being the problem although I have never used it unless I had to. Just after posting my string, I upgraded to IE 8 RC1 and the "Memory could not be 'read'" error has not recurred since then.

    I also watched my TaskManager for 40 minutes,and recorded the following, which mean little to me, but you will know what the readings represent: During the idle, CPU usage was static between 0% and 7% - half way through the exercise I opened explorer.exe (which is one of the programs that faults, though it is not in use at the time of faulting. The other is Webshots ScreenSaver which is disabled anyway.) I also opened Outlook Express and opened some emails.

    I returned to idle for the remainder of the time. The page file started at 547 going up to 702 by the end of the vigil.

    Other TaskMan readings were:
    Totals: Handles: 10536; Threads 543; Processes: 54.
    Physical Memory: Total: 2095532; Available 1509160; System Cache: 821492. Comit Charge(K): Total: 70552; Limit: 4034140; Peak: 130l796.
    Kernel Memory: Total: 181656; Paged 169308;
    Nonpaged: 13372. Processes 53
    Comit Charge: 702/3939.

    At the end of the 40 minutes, the PageFile reading was: 702.

    Well, it is now almost 2 hours since I installed IE 8 RC1 and still no "Memory could not be 'read'" error. from the two faulting programs. Will have to wait and see what happens down the line.

    I am sure the two Crucial DDR2 sticks are OK, but have no way to test them.

    I use Avant Browser and it's very fast, and my PC is very responsive otherwise. I find Firefox slow and sluggish, so don't use it. Kindest regards, and thanks to TechSpot.
  4. Auldsod

    Auldsod TS Rookie Topic Starter Posts: 18

    Sorry raybay, no sooner had I closed my browser after posting the above, when the exact same two errors occurred. PC froze until I clicked on OK to close them.

    On trying to open TaskMan, message was: not enough memory. Had close-down - small window was transparent. All my menu icons were replaced by dull "file" icons. On reboot all returned to nortmal.

    Beats me...
  5. Auldsod

    Auldsod TS Rookie Topic Starter Posts: 18

    The memory could not be "read."

    Hi raybay. I seem to have fixed the problem - by accident. I right-clicked on:

    My Computer>System Properties>Advanced>Performance>Settings> Advanced>
    Change> and ticked: "No Paging File" and then rebooted, hoping to clear out the paging file and reset. On reboot, the PC had reset the Change>No Paging File to System Managed File, and the values shown are now: Minimum Allowed 2 MB; Recommended 3069 MB; Currently allocated 2046 MB. On going to C:\PageFile.sys the size is shown as: 2,095,532 KB (2048 MB).

    A Si-Software Sandra scan now reflects the following: System Memory Summary: Total Physical Memory 2 GB. Free Physical Memory: 1.31 GB (65%); Maximum Page File: 3.07 GB (80%); (non-comprehendo!)
    Page File: c:\pagefile.sys 00; PE36 - 36 - bit Page File Size Extension - Yes; Maximum System Pages 798720.

    Kernel Statistics: Total Processes: 55; Total Threads 555; Total Open Handles 11250.

    Kernel Memory Information: Total Memory 248,40 MB; Paged Memory 234,47 MB; Non-Paged Memory 13,93 MB.

    Extended Memory Information: Allocated Memory Load 34%.

    I give this detail as it may help others, although I don't understand what I've done.

    Thank you raybay and Techspot: Sucessfully Resolved. Best regards.
  6. raybay

    raybay TS Evangelist Posts: 7,241   +10

    We have found it necessary to uninstall Internet Explorer 7.0, and sometimes, to do that, we had to remove Service Pack 3.
    Then clean booted, then ran a defragmentation, then use RegClean to remove any residue.
    Then install Service Pack 3.
    Then again reboot and defrag,
    Then run Microsoft Updates, then defrag,
    Then reboot, and THEN install Internet Explorer 7.0 or 8.0
    After this cumbersome process, everything worked fine.
  7. Auldsod

    Auldsod TS Rookie Topic Starter Posts: 18

    I replied to raybay after logging in 4 times, as I kept being directed to do. What happened to my reply? I was logged when I replied? Anyway, I am very glad to be rid of that dreadful error: "The memory could not be 'read.'" Your modus operandi is most interesting and practical raybay. Thanks to you and TechSpot. Best wishes.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...