Toshiba Satellite 1135-S1552 WiFi Networking Problem

Status
Not open for further replies.

tedcera

TS Rookie
I have recently installed an Intel 2200 Wireless Card into my Toshiba Satellite 1135-S1552.

The computer recognizes the hardware, and all the software and drivers are working fine.

The problem is when I try to Enable my Radio Switch. I need to be able to press Fn + F2, but on my Satellite the Fn + F2 switch accesses the Battery Mode.

Does anyone know how I can re-map my keyboard, or enable my Radio Switch???

Please help.

Ted
 

Nodsu

TS Rookie
Perhaps you don't have to press Fn+F2?

On my IBM the radio is controlled by Fn-F4.

And you don't have to use the Fn+x combination anyway. The WiFi connection software can be used to turn on/off the radio. If you don't have any special software then disabling the wireless connection will effectively turn off the radio.
 

tedcera

TS Rookie
"Perhaps you don't have to press Fn+F2?"

That is correct. My Fn+F2 is for my Battery Mode. The Fn+F8 is the pre-assigned key for Enabling my Radio Switch, but it does NOTHING when I press it.

Also, the software that came with my Intel 2200 WiFi card is Intel's PROSet Wireless software. It does have an optiong to Enable/Disable the Radio Switch, but when I click on Enable, it says, "You Radio Switch is still Disabled. Press Fn+F2 to Enable it."

Could there be another way to Enable the Radio Switch?
 

Nodsu

TS Rookie
Did your laptop come with no WiFi initially? You might want to install the wireless programs from Toshiba to get all sorts of fancy support for it. ConfigFree is the WiFi program that comes with Toshiba laptops. Download the latest version from Toshiba website.
 

tedcera

TS Rookie
The problem is with the Radio Switch.

I do not know how to enable it.

The LED light does not come on.

And no, my laptop did not come with a WiFi card inside. I installed it myself. The F8 key does not work. And yes, I have tried Toshiba's programs, and they give me the same message to make sure the Switch is ON, which I don't know how to turn on.

I am thinking about giving up and just using a PCI card, but I would rather have it be internal.
 

Nodsu

TS Rookie
Perhaps they mean the WiFi antenna switch that your laptop has? It is in the rear part of the left side of the machine right after the audio connectors.
 

tedcera

TS Rookie
The laptop's Antenna Switch is located on the leftside towards the back of the laptop.

IT DOES NOT WORK. The LED light does NOT light up if it is in the ON position.

Likewise, the Fn+F8 does not do anything either.

I have called Toshiba and they will not tell me whether, or not, my laptop is even capable of using an internal WiFi card, yet the laptop has a slot for one.

Toshiba is being very unhelpful.

I have tried installing/unistalling numerous amounts of drivers/software to get it to work and ever time the card is recognized and I am stopped at the Radio Switch.

HOW DO I GET MY RADIO SWITCH TO WORK??
 

StormBringer

TS Maniac
Go into the BIOS, look for a setting called something like "wireless control" this should be set to whatever the key combo is(in this case FN+F8) also make sure any other settings for wireless are enabled.
Also, there may be a utility that needs to be installed in Windows for you to use the key combo(on Dell systems you have to have something called Dell Quickset, not sure on a Toshiba)

Also, if you have no card present, you can't turn its radio off and on. If you do have a card, and have a control utility for it, it should have an option for enabling/disabling the radio
 

Marturion

TS Rookie
I had the exact same problem with my intel pro 2200bg mini pci card and Toshiba Satellite 1135. I foun a solution that worked for me: (note, you may need to scroll down a bit, the workaround has to do with covering pins 11 and 13 on your m-pci card)

(oops, can i not put a link here?) Since i guess i can't place a link, i'll just write out the solution:

After completing this, the hardware (and Fn key) seem to have no effect on the state of the wireless. (the LED doesn't light up either, so don't get discouraged if you don't see a green glow) at least the card finally does, it seems to have something to do with how Toshiba uses pins 11 and 13, i wonder if there is a jumper inside the laptop that could be switched insead of covering those? Right now i'm just glad it works. Pass this on to as many people as possible, perhaps we can save a few man-hours.

Solution: Cover pins 11 and 13 on your m-pci wireless card (even pins are on the bottom side, the odd are on the top. For orientation, the "top" of the card is where you plug the two antenna in.

While facing the "top" of the card count to pin 11 and 13. (from the "cut" in the card over, don't forget to count the lone pin as well "1,2") cover both pins 11 and 13 with tape (or as suggested in the post, finger nail polish) Place card back, start laptop, and you should be able to configure it from there.

| |||||||||||||~<- (pin 11,13 bold)

hope this helps!

PS Merry Christmas
 

RodTech

TS Rookie
Fantastic Solution!

This solution also worked perfectly for me on a Toshiba P10-304.

Unbelievable how whoever figured that out figured it out. I suppose there must also be a pin to cover which would allow the LED to come on but god knows which one.

I would also assume toshiba have an easier way of doing this (a template or something) - i'll ask them when their 'engineers' get back to me.

And all this just for an excuse to pay toshiba 'engineers' to fit the mini-pci card, as per the manual, for which they probably charge about 100 quid.

Anyway thanks for a great solution.
 

SBMongoos

TS Rookie
hmmm.... I seem to have the same problem but can't get this to work for me. I believe I have the right pins covered. But when I cover them then the laptop doesn't even detect the card.

I have a Toshiba 2435-S255 and am using a Broadcom Mini PCI BCM94306MP. 802.11b/g.

****

Got it. Wasn't thinking clearly. One one side you count 1,3,5 etc. I was simply counting 1,2,3,4. Anyway, I got the card to work by using a couple tiny slice of scotch tape.
 

PaulD

TS Rookie
Me Too... Toshiba and WiFi Card

Thanks to all for previous comments. I too have a I have a Toshiba 2435-S255 and had a Belkin PCMCIA WiFi card that refused to work reliably. Finally gave up on that and purchased a OEM Broadcom Mini PCI BCM94306MP. 802.11b/g. Received without any installation manual or SW. On install the system found the card, then windows automatically went on the Net and set up drivers (I was on a wired LAN) However the card would not "turn on". I've simply followed the comments above (counted across pins 1, 3, 5, 7, 9, and covered over 11 & 13 with some tape). Bingo it came to life !! I can now sit anywhere in the house and still surf.... Thanks again to everyone. Would NEVER have figured it out otherwise. If anyone does further experimentation and discovers how to enable the external on/of switch or function key would love to hear !! Paul
 

ksiegel

TS Rookie
Not Just Toshiba...

It isn't just a Toshiba problem. I have an Acer Travelmate C301XCi (Tablet PC) that I just upgraded with an Intel 2200 bg card - kept getting the "radio is off" stuff, and was ready to through it!

I contacted vendor, (An eBay seller), who sent me to this forum.

Did the same thing - Scotch (R) tape over pins 11 and 13, reinstalled and it works just fine. No LAN indicator on the case, but the indicators on screen are good enough.

Just apssing along the info,,,

-Kurt
 

h4gster

TS Rookie
>While facing the "top" of the card count to pin 11 and 13. (from the "cut" in >the card over, don't forget to count the lone pin as well "1,2") cover both pins >11 and 13 with tape (or as suggested in the post, finger nail polish) Place card >back, start laptop, and you should be able to configure it from there.

>| |||||||||||||~<- (pin 11,13 bold)

Can you send a link to a picture? I have either a dead board or I am being a numptie.

J
 

ksiegel

TS Rookie
mini pci card detail - jpg file

Okay, I don't know if I'm doing this right, but....

I scanned my old PCI card, and annotated with the placement of pins 11 and 13.

Hope it works, and I hope it helps.

-Kurt
 

Attachments

Tedster

Techspot old timer.....
I have a toshiba satellite laptop and my antenna switch is on the right side under the volume knob.
 

h4gster

TS Rookie
ksiegel said:
Okay, I don't know if I'm doing this right, but....

I scanned my old PCI card, and annotated with the placement of pins 11 and 13.

Hope it works, and I hope it helps.

-Kurt
Thanks Kurt. It looks like my card is fubar.
 

ICUB4UCME

TS Rookie
on the topic of pins 11 and 13, i have tried this and it works great but is it possible that the 2 pins could be reversed from the factory? so if you could rewire it so 11 is hooked to 13 and vice versa, would that maybe solve the issues with hardware antenna control?
 

mjbanks

TS Rookie
Hi everyone,

I found this site and thread on google on the same problem. I have a Toshiba Satellite 1135-S125 and recently bought the Intel 2200. I tried covering pins 11 and 13 with finger nail polish, but it still tells me wireless off in the intel pro software. Maybe I have the antennas backwards? There's a brown-ish color wire and a white one, not sure which is main and which is aux. I've tried both ways and it still tells me the hardware switch is off.

Any ideas or suggestions?

Thanks everyone!

Matt
 

SRB

TS Rookie
Brilliant...works like a charm..

I was just about to chuck a broadcom a/b/g (dell 1450) interface card when I came across the posts. I was installing it in a newer Satellite P25 system and
the same problem listed happened. Covered the pins and bingo, card works
perfect. The only thing I don't understand is that I have a Satellite 5205
that I installed the same card in 6mos ago with out any problems. Works
perfect with no mods and my controls and switches work fine. Oh well...
Thanks again.
 

ICUB4UCME

TS Rookie
mjbanks said:
Hi everyone,

I found this site and thread on google on the same problem. I have a Toshiba Satellite 1135-S125 and recently bought the Intel 2200. I tried covering pins 11 and 13 with finger nail polish, but it still tells me wireless off in the intel pro software. Maybe I have the antennas backwards? There's a brown-ish color wire and a white one, not sure which is main and which is aux. I've tried both ways and it still tells me the hardware switch is off.

Any ideas or suggestions?

Thanks everyone!

Matt
remember that the pins are even on one side of the card and odd on the other. pins 11 and 13 are next to each other on the odd side of the card, this is covered earlier in the thread.
 

HOKSHA

TS Rookie
I Have The Same Problem But .....

Hello every body its the first time for me to join to this forum i have the same problem but my toshiba A30 and i Buy It with WIFI built in so i guess my problem is too hard or my laptop need to return to the toshiba warranty i don't know but if any body have any answer please tell me and thanks all
 

odrod

TS Rookie
I am using a Toshiba Satellite 5205 and I'm trying to install an MSI MP54G4 minPCI wireless card. Windows picks it up, the radio light is on, but it will not find any networks, including the one sitting right here. It actually picks it up on very low for a short period and then loses it. I covered 11 & 13 and have the same results.

Any ideas? My dlink pcmia card picks up quite a few networks.
 
Status
Not open for further replies.