Toshiba Satellite 1135-S1552 WiFi Networking Problem

Not open for further replies.


tedcera said:
Toshiba Satellite 1135-S1552.
on my Satellite the Fn + F2 switch accesses the Battery Mode.
hum; my mx35-s161 says that fn+f2 IS BATTERY options and
fn+f8 is wireless :)
Omg It Worked !!!

I have Toshiba Satellite A30-514 and I bought a Intel 2200BG Chipset mini-PCI WLAN card from ebay. Everything was installed fine except I was getting the same no signal so I googled and read this thread on the forum and its amazing what a bit of sellotape can do. How you do it is you put some sellotape on pins 11 and 13. As sellotape normally doesn't come that small what you do is put the wide sellotape covering many pins then just use a cutter (not scissors) to cut around the 2 pins. Then just peel the sellotape covering the other pins and voila. BTW, the pins 11 and 13 are on the top of the card (where you put the antenna wires on) and you count them like this.

The key the the cut between the pins, so the 11th and the 13th pin would be the 6th and 7th (or 5th and 6th if you count after the key).

1 Key 3 5 7 9 11 13
2 Key 4 6 8 10 12 14

A more accurate description can be found on this web page about which pin to cover but note that this webpage only tells you to cover pin 13 but you need to cover pins 11 and 13 with the Intel 2200BG Chipset.

Also Note on the 2 Antenna Wires and the LED light on the side for WLAN:
I also wondered which wire goes in which socket but then I noticed that the white wire is a bit shorter than the brown/black wire. So what I did was connected the white wire to the little socket labelled "main" and the black/brown wire to the socket names "aux" (which was further away so I used longer wire). It works with those so I'm guessing I chose the right ones.
As for the LED on the left side of the laptop, I have updated to the latest bios and still it doesn't seem to light up although wireless is working absolutely fine and I get full signal.
Hi there!
I tried the 11-13 selotaping procedure with the Intel 2200 BG wireless card in my Toshiba A30-303, and it worked!

However, now I have 2 problems:

1. Battery - The full charge is now drained in less than 30 minutes (previously I had more than 1 hour)

2. Speed - I can only get 11 mbps, instead of the expected 54 mbps

Anyone with the same problems? Can I solve this?
Thank you all!
A possible solution for the switch and led

Looks like I can't post a link as of yet so here goes: (By the way lots of disclaimers were posted with this as people may do it wrong and fry something.)

Problem with WiFi LED
After getting an unauthorized card to work, you may notice that the WiFi LED found on the ThinkPad is not working. This doesn't happen with all unauthorized cards. The general cause for this is the fact that the MiniPCI standard leaves the implementation of the LED signals available on the MiniPCI connector to the card vendors. Therefore some newer WiFi cards use one of the signals originally meant for LEDs to implement the "radio kill" switch input. As a result, the LED doesn't get proper signals and fails.

The WiFi LED found in ThinkPads is connected to following pins on the MiniPCI connector.

Pin Signal Description
11 LED1_GRNP WiFi active LED +
13 LED1_GRNN WiFi active LED - (older cards) / RF Silent input (newer cards)

Note: The descriptions are specific to this article.

If your LED is not working, the problem could be the pin 13. Newer cards may no longer provide the necessary negative signal there to drive the LED. Before you apply any fixes, be sure to check the voltage between pin 11 and ground (can be found for example on the MiniPCI latch arms) - it should give you about 3.3V while the WiFi is active and 0V otherwise. The voltage between pin 13 and ground should measure about 2.5V. The notebook has to be running while you perform the tests so be extremely careful. All the mentioned pins are on the upper side so it's quite easy to get to them with a multimeter. If all the voltages match, your LED is fixable.

MiniPCI Specification (PDF, 724KB)
MiniPCI Pinout

The solution is to connect the ground (GND) to the pin 13. However, since the new RF Silent input signal is active low, grounding the card side will tell it to turn itself off. Therefore, we have to separate pin 13 of the card from the system board and connect ground to the system board side only.

There are many ways to accomplish this. One which doesn't require any soldering is to mask pin 13 on the card with a cellophane tape and use about 3cm of thin wire to connect pin 13 of the connector to the ground. Place one end of the wire on the masked pad and insert the card into the slot. Check if the wire is centered on the pad and try pulling it (but not too hard) to see if it holds. If it comes out easily, pull the card out and repeat. If you successfully attach it, you have to connect the other end to the ground. The best place is the left MiniPCI latch arm. Bend it outside and insert the wire into the small gap between the two pieces of metal the arm is made from. Finally, make sure that the wire doesn't touch anything else and doesn't stand out too much, it must not touch the touchpad electronics when you put the palmrest back on. If in doubt, cover the wire with some insulator.
Thank you thank you thank you

I Have a toshiba s2430 that did not come with a wifi card installed. I tried fitting a broadcom bcm4306 and could not get it to work. Have been searching the internet for nearly a week trying to find a solution with no luck and then I found a link to this site. followed the instructions and it works perfectly.

dont know how people find out this information but I am very glad they do.

Thank you.

Toshiba Sp10-304 Pin 11+13 Worked!

Covered The 2 Pins with Sellotape.....Quite Fiddly..Those Pins Are Very Small And My Eyesight Is Not What It Used To Be!!!
Didnt work the 1st time so i took the card out and put another layer of tape on....Bingo.
Thankyou to everyone that has posted...I like most people dont care that the lights or switch doesnt work...i now dont have to drag a cat5 from my wireless router!!!
Using A broadcom bcm94309mp Out of a dead Dell Inspiron 510m....
On another topic the ram from the dead dell revived my Toshiba P10....It kept blue screening....a new bank of Ram sorted the problem.
Keep posting your successes makes the solution easier to find when googled!
And another big thank you for this great tip. I managed to tape pin 11 and 13 and it works now on my sons Satellite A30.

Edward :-D
Not open for further replies.