Touchpad functions messed up

By timepink ยท 6 replies
Mar 24, 2011
Post New Reply
  1. Hi! First of all, as I couldn't find a cause, I didn't know where to post this thread. If I posted somewhere wrong, please, move it to the correct place. Thank you :)

    Today, I was using my laptop normally when, out of the blue, my touchpad started to behave strange. It would not move around the screen by itself, but its functions were all messed up. I tried reinitialization, restoring the system, removing and installing the synaptics driver, removing the driver again and installing no driver. Nothing worked. In safe mode was the same. The "touch click", however, worked a little. The touchpad now can't be used.
    It's Win7 Home Premium 64bit. I was using at that moment, Skype, Opera, Gom Player, iTunes, firewall Comodo, antivirus Avira, Yahoo widgets and other system softwares I can't remember.
    What can I do?
  2. tipstir

    tipstir TS Ambassador Posts: 2,477   +126

    Yes that tpad need to be replaced. Drivers can only do so much. I have since 2005 and it acts so bad, but can't get parts for it. I just use one of those mini blue LED wireless mouse from MS or Logitech with the mini USB dongle. To fix your issue depends if you in or out of warranty. Cost and labor will add more than buy $40 buck or less wireless mini mouse. My 2010 Windows 7 64-bit one seems to act up already. I just got MS 3500 blue LED mini mouse to use with it. To send it back for repair wont' be cheap I would have to foot the bill to sent it back in on 15.6" Still tpad works but if I type to fast and the pressure from my palms is where the trouble is.
  3. bushwhacker

    bushwhacker TechSpot Chancellor Posts: 783

    This actually happened to my Dell Inspiron E1505 ( Vista32 ).... the only way I can go around them is to use the Logitech G5 mouse. Trust me, you're better off using the mouse instead of using the tpad... they're a load of massive headache if you are doing a lot of photoshopping and programmer coding.

    However, this issue seemly to be stopped when I upgraded it all way up to windows 7 64bit. Must be me, or tpad might just wanted to screw with me.
  4. timepink

    timepink TS Rookie Topic Starter

    Since its Friday afternoon, I will have to wait til Monday to call Dell warranty services (its a Dell Inspiron 15r/N5010). I pray for their international services to work, since I'm not in my country. And thank God its in warranty. I found a USB mouse here where I am and I'm using it. But the strange thing is sometimes the mouse will behave the same as the touchpad, and some keyboard keys won't work for 30 seconds, at least. This happens specially after I click on a touchpad button. Its very strange.
    The only thing I know is that my mom will go nuts, because this laptop is only 3 months old and had already a motherboard replacement because of a factory malfunction.

    And I prefer the touchpad, as I don't do anything that requires a mouse and don't use the laptop on a table (I don't have a table to use it on).

    Thank you
  5. bushwhacker

    bushwhacker TechSpot Chancellor Posts: 783

    Did you try and turn off the tpad setting and forcing them to use the external mouse only?

    Sorry to hear if this is still wrecking ya.
  6. tipstir

    tipstir TS Ambassador Posts: 2,477   +126

    They all fail even DELL ones too. I use to repair Tpads but even if you repair them they can't take harsh usage otherwise they'll fail again. Best to use external mouse. If you get it replace just remember one thing it can happen again! Take care
  7. timepink

    timepink TS Rookie Topic Starter

    Yes, I did. Nothing changes. Thank you.

    What do you mean by using it harshly? Anyway, this laptop is only 3 months old, so this should not be happening now.
    I have another Dell for exactly 3 years and the touchpad itself never abandoned me. The only problem was that the little rubber below the left button wore, making it unusable.
    And the USB mouse is getting affected by the touchpad problem. Sometimes it will not work. In those moments, I have to wait a little for it to work or disconnect or connect it again.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...