1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Unable to download Firefox

By old101 ยท 29 replies
Dec 29, 2008
  1. While on Firefox, and trying to read some article I started getting the massage "Cannot find this URL". I was not trying to find anything. Anyway that kept crashing the Firefox, so I un-installed it. When I try to go to Mozilla Download site and try to download Firefox 3 I end up getting a Google message that the link is broken. This happens on both Internet Explorer and on Chrome, which I am using to post this massage.

    What is happening?. Is Mozilla site compromised?. Your help please.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  3. old101

    old101 TS Rookie Topic Starter Posts: 52

    Thank you. Done as you suggested, got the same result. Unable to download v3.0.5 Your link got me to v3.0.4 which downloaded and installed. Still the same problem, an Alert massage "URL is not valid and cannot be loaded". This appears on the Firefox home page. I then upgraded to v3.0.5 through Secunia. Downloaded and installed, but still the same Alert massage and a frozen browser.
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  5. old101

    old101 TS Rookie Topic Starter Posts: 52

    Sorry I don't know how I got to v3.0.4 perhaps re-direction?. Anyway Secunia picked it up and I upgraded to 3.0.5 throuh it with the same result. Scanned with NOD32, Spyware Doctor and Black Light, all negative.

    When I use your Direct(32Bit) link I get a blank white screen and a message at the bottom: "This type of file can harm your computer. Are you sure you want to download Firefox 3.0.5?"

    Now I remember that I got the same screen in one of my early attempts to make Firefox work.

    For what it is worth the highjackthis.log should be attached.

    Attached Files:

  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Wow a lot running, including:
    Spyware Doctor

    Personally I'd turn off all these startups (or un-install the actual programs)
    Have a look at Startup Control Panel: http://www.mlin.net/StartupCPL.shtml
    To help with that

    It must be running slow
  7. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    kimslad is more conservative than I am! I would be surprised if you could get "anything" else on that system with all the programs and processes you have starting up!

    1. You are running two antivirus programs:
    ThreatFire: Antivirus
    Esset Smart Security Suite: a personal firewall, antispam, antivirus and antispyware

    Please re-open HiJackThis and scan. Check the boxes next to all the entries listed below.
    Now close all windows other than HiJackThis, then click Fix Checked. Close HiJackThis and reboot into Safe Mode:

    Start> Run> msconfig> enter> Selective Startup> UNCHECK EVERYTHING except:
    Esset antivirus (Nod32)
    Apply> OK

    Control Panel> Add/Remove Programs> uninstall Threat Fire.

    Start> Run> services msc> right click on TFService> Properties> Change Startup type to Disabled> Stop the Service.

    Reboot into Normal mode.. NOTE: you will get a nag message that you can ignore and close after checking 'don't how this message again.' Stay in Selective Startup.

    Now try to install Firefox.

    I would also suggest you follow the steps here: https://www.techspot.com/vb/topic58138.html,
    running Malwarebytes, Superantispyware, then rescan with HijackThis. You have SO many processes running that chances are great that you have malware. Attach all three logs when trough.
  8. akjproductions

    akjproductions TS Rookie

    Unable to download mozilla

    I've been having trouble using Internet Explorer, so I tried to download Mozilla Firefox. Unfortunately when I click on the download Mozilla, the only thing that occurs is a blank page appears.

    When I click on the "Your download should automatically begin in a few seconds, but if not, click here," nothing still is happening. Can you please help me?
  9. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

  10. old101

    old101 TS Rookie Topic Starter Posts: 52

    Hi kimsland and Bobbye,
    Thanks for your comments. Haven't ignored you just had some year end stuff to do. Also remembered that the only change I made to my system before trouble started was to upgrade to Eset's latest build which was giving some people problems. To eliminate that possibility I went back to the previous build which was around for a few months. Did not solve the problem though. Nor did starting in Selective startup.

    Have gone through Bobbye's list and about to download a new copy of Firefox and will install it.

    Re-installed Firefox and am in fact using it now. The old nag screen still pops up regularly, "The URL is not valid and connot be loaded". The difference is however that it does not freeze Firefox like it used to. I just click OK and go on. Just a nuisance now.

    Ran Super Anti-Spyware and Malberbytes' Anti-Malware. Both removed a couple of trojans. However when I came back to Normal Start the nag screen is back, and this time it freezes Firefox.
  11. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    The 'nag' screen is easily handled.
    Sometimes, you have to close it and check the 'don't show' a couple of times. This is NOT unusual.

    I repeat:
    You may also have something blocking the download of Firefox. Unless we see what's going on on the system, we can't help. The HijackThis log alone is not sufficient.
  12. old101

    old101 TS Rookie Topic Starter Posts: 52

    Thank you for your comments. Since my last post I removed just about everything from the startup menu, and additional six to eight services (non Microsoft). I can download and install Firefox now without any problems, and it runs for a minute or so and then the Alert screen comes up and freezes it, so I have to shut it down through the Task Manager.

    As you can see the Alert screen just has two alternatives: Yes and X.
  13. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    I have not seen any Alert message like the before. I think there may be something blocking the install. But you have so much running! Suggest you shut down ALL these that kimsland mentioned:
    Spyware Doctor

    Did you handle this?
    Then do this:
    There is also the change that a RAM chip has gone bad. If we can't find anything that could be causing the block, you will have to run memtest to check.
  14. old101

    old101 TS Rookie Topic Starter Posts: 52

    Done it all now. Alert message still comes up every few seconds, but does not freeze the browser. Still browsing like that not very practical.

    The logs you asked for are attached. Sorry I missed that part of your request originally. Thank you for your perseverance.
  15. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    Basically, the logs are clean, having removed small amount of malware. If the problem with Firefox persists, it has got to be as mechanical or hardware related problem. The only other suggest I have is to check the Event Viewer for the Error that corresponds to the time of the message or crash:

    Checking the Event Viewer in Vista:

    Also check all the security settings in both IE and Firefox. Make sure there isn't a block for the URL.
  16. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Also MalwareBytes definitions now updated as well
    I'm not suggesting that there may be some malwares still to remove
    But as a good measure, best to start it; update it; and run another scan. Just in case ;)
  17. old101

    old101 TS Rookie Topic Starter Posts: 52

    Thank you both for your patience and help.

    kimsland - I did in fact re-run both the MalwareBytes and the SuperAniSpyware a couple of days later in Safe mode. Both came clear, so I did not re-post the logs.

    Bobbye - you mentioned the possibility of running a memory test in one of your previous posts.. I tried to run memtest by entering "memtest" in a command screen but got nowhere.
    How do I run the memory test?.
  18. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Please run ==> Memtest <== on your Ram
  19. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    Thanks kimsland. I like yours better than the one I was going to leave!
  20. old101

    old101 TS Rookie Topic Starter Posts: 52

    Thank yo both for your help. That is a nice tool to have around. I ran it, two passes no errors.
    I also checked the Device Manager. No problems reported for either the network card or the modem (Which belongs to my ISP).
  21. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Ah huh :suspiciou
    And the other 5 tests?...
    ie according to the guide you must run it for 7 passes (sometimes it faults right at the last pass (always the way isn't it ;) )
  22. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    I went back and read all your post on this thread and noted that the reason you tried to download Firefox in the first place was because you were having a problem with Internet Explorer.

    How about we look into that. I wouldn't be surprised if the problem had something to do with the failed FF. Tell us what the problems with IE was.

    Edit: Please ignore this question- my mistake due to another person posting on this thread.
  23. old101

    old101 TS Rookie Topic Starter Posts: 52

    kimsland - ran two cycles of seven tests each. Took two hours per cycle. Cycle two seemed the to consist of the same seven tests as cycle one, although I did not watch the process continuously for four hours.

    Bobbye - the original problem I had with Firefox was the message " Unable to connect to URL".
    Since this occurred shortly after updating to v3.0.5 I tried to re-download the previous version, then a fresh download of v3.0.5. Had problems doing that through Firefox, Chrome and IE.

    After that I had some suggestions from kimsland for system cleanup and was able to dowload v3.0.5, originally through a Secunia update. I still had the Alert "Unable to connect to URL", which actually freezez Firefox. This problem persisted through all the subsequent steps I took. The last time I tried it, just before running the memtest I got the same Alert in Safe mode (with connection).
  24. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    Sorry old101- I used a statement that was from someone else who posted here about the problem with IE.

    But for your Firefox> please give me the URL that is displaying at the time you get:
    We're missing something here.I pit the string 'Alert "Unable to connect to the URL"'+Firefox in Google and came up with multiple sites involving the Oracle Server not reading the page right. Have a look:
    Oracle Application Server 10g (9.0.4) Release Notes
    File Format: PDF/Adobe Acrobat
    "Alert: A configuration script needs to be run as root before installation can ...... The error message "unable to connect to URL http://host:port/ibse. ...

    If you can't pick this like up, go here and choose the first entry:
  25. old101

    old101 TS Rookie Topic Starter Posts: 52

    Picture of the actual Alert is one of my previous posts. It reads "URL not valid and it cannot be loaded".

    This alert occured over a half dozen or so sites that I visit every day. The Alert does not freeze the Firefox immediately. The first thing I did when the problem occured was to try another site, and for example I got as far as the Forum screen on Techspot before a second message appears and usually kills the browser, although at times i got up to a third Alert.

    My home screen is refdesk.com. That always comes up, the Alert message appears only if I try to use one of the links (web site is all links), or select another websie. Thats when the Alert starts popping up. It does not matter whether the website URL is selected from the bookmarks, or typed in.

    I played with this problem for a few days before I posted it. The Alert does not come up on IE, Chrome or Opera.

    Thank you much for your help. I did download the release notes, but on quick examination cannot find any relationship to my problem.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...