Urgent help needed - Comp won't reach POST, just shuts down

By Will_m ยท 7 replies
Jun 30, 2009
  1. I have a just installed a new PSU, the Seasonic MD12 and upon installing it in my system which worked before now, I can't even get to the post screen, it simply starts to boot, the cpu and psu fans spin, then it stops, then nothing no beeps noises or anything just goes dead, the mobo light is still on and a few leds are showing but other than that, nothing.

    I've tried the PSU in another machine and it works fine and I've also tried removing all connections from the mobo except the 8-pin and 24-pin power connectors, keeping in the video card, soundcard and cpu with just one stick of ram but still the same result. I'm pretty worried about this as it all worked fine the other night but now I've replaced the PSU it's died although the PSU works fine in another comp.

    I'm really hoping it's not a problem with the mobo so if anyone can come to my rescue that would be fantastic as I had planned to work on a new project this week :(
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Seasonic is a great power supply we use frequently in new installs... We have never seen a failure...
    Consider other events... could your hard drive have gone bad? Do you have all the cable connected properly.... Remove and reseat to test.
    Consider damaged cables, damaged sockets, damaged memory, damaged hard drives, and something not plugged in at all, such as the CPU fan. Double check everything you have done... when rested and no longer stressed.
    Then get back to us with the good news that everything works, and what you figgered out that made eveything happy.
  3. Will_m

    Will_m TS Enthusiast Topic Starter Posts: 77

    hi raybay thanks for the reply, i've tested the mobo without HDD's, optical drives etc. I've just got in 1 stick of ram, the cpu and video card. Also I've removed the mobo from case as someone suggested it might be shorting with the case. This all produces the same result though.

    I've tried it with another power supply which only has 4-pin mobo connector and after attaching just the 24-pin connector it seems to work no problem even without the 8 pin connector.

    I've also tried the Seasonic PSU in another machine and it works fine too, so it must be an issue that the Seasonic has with my mobo (Gigabyte EX58-UD5).

    Are there any other steps I could try?
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Cannot help, except to say the Seasonic works fine in a Gigabyte boards we have ever installed.,
    We do not have any suggestions, except to theck with the Gigabyte site and the Seasonic site to see if there are odd things reported.
  5. cc06590

    cc06590 TS Rookie

    get your money back
  6. Will_m

    Will_m TS Enthusiast Topic Starter Posts: 77

    have requested a replacement to be tested and sent out to me, ill keep you all updated when it arrives.
  7. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

  8. Will_m

    Will_m TS Enthusiast Topic Starter Posts: 77

    Thanks Tedster I did go through the troubleshooting guide but unfortunately none of the solutions worked and when I got to testing the components, the RAM, PSU, and Mobo all worked in other set-ups which left me rather stumped. The only thing I couldn't test fully was the PSU as I didn't have another Mobo with an 8 pin connector but with my old asrock 4 pin board it worked with no problems.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...