USB drives not recognized

Not open for further replies.


Posts: 3,413   +145
Today my friend handed me two identical USB flash drives and asked me to fix them. He was not very specific about what happed, why they don't work, what he did, or anything, I'll keep pestering him, but even if he would tell me, he isn't the kind of person to know what he did on a computer.

Both drives seem to have an identical problem and refuse to show up on my computer. In device manager, they don't show up in the USB ports, but do show up under Other devices as yellow question marks. Right clicking and looking at properties, the device status says "No drivers are installed for this device. " on both drives. I've tried this on two different computers with the same result.

I've tried formatting them with OCZ format utility, HP USB format utility, lexar's format utility, UMP tool, test disk, and hdd low level format tool, none of which even see the drives.

I've tried going into the bios and looking at any USB devices, it didn't show up, but i didn't look too closely.

A program I found called Chip Genius v 2.64 did see it. I'm pretty sure it lists all the usb devices in my computer, my mouse, keyboard...anyway it sees the drive as a "USB Device", the information listed under it for both drives is this:

Device Name: +USB Device

PnP Device ID: VID = 07F2 PID = 0001
Serial Number: 5&&10C94DEA&&0&&4
Revision: (Information not returned)

Device Type: Standard USB device - USB2.0 Full-Speed (USB1.1)

Chip Vendor: (No match record)
Chip Part-Number: (No match record)

Product Vendor: USB
Product Model: Device

Tools on Web: (N/A)

Now, i'm at a loss at what to do, so I come to techspot for help.
Thanks in advance, and keep in mind that they look like low quality nameless USB drives, so they may just be dead, although since both seem to have died at roughly the same time, I suspect my friend would have something to do with it. I honestly have no idea what he does with his drives, all he does is put games on them but he comes to me with dead drives pretty often. So far i've been able to fix them, until now.


Posts: 6,906   +10
Not fixable under normal conditions. Sounds like the typical SanDisk USB failure problem.
There are companies that will rescue USB data for a very high price, but they have to remove the chip to do that.

USB devices serve the purpose of moving data, or saving a copy, but they should never be the only source of the data, as the USB drive failure rate is 30 percent in the first year, and then failures go up dramatically.

I would not waste time further on this. Tell your friend the data is lost unless he or she wants to spend in excess of $100 to rescue it.


Posts: 6,429   +186
Very Interesting....

I have some info (i don't claim an answer). And please proceed at your own risk..

1) I took a quick look at the Chip Genius tool.
If Chip Genius is seeing the hardware ID i suspect Windows is also seeing it
> Verify the VID and PID values again using Chip Genius
> Now click Start->Run, enter msinfo32. Look at under Components->USB as well as Problem Devices. I suspect you'll find the identical VID and PID values listed for a device?

2) Go ask your friend if those are "protected" USB devices.. And if they ever heard of a company called General CADD
> If you plug those VID/PID values into a USB hardware ID formatted string you get USB\VID_07f2&PID_0001
> After a bit of Googling, my best guess is that's a General CADD USB dongle security device which would need special drivers.

Again, this is all just my best guess.. so proceed at own risk if you try downloading and running anything from General CADD

/* edit */
oh.. just skimmed your post again and, yes, Windows is seeing the same as Chip Genius
do show up under Other devices as yellow question marks.
If you were to rt click the device, then the Details tab you'll find it sees the same hardware ID as Chip Genius


Posts: 3,413   +145
is the drive in question

If you were to rt click the device, then the Details tab you'll find it sees the same hardware ID as Chip Genius
Yes they are all seeing the same thing as Chip Genius.

I followed their instructions and installed the drivers, it seems to work exactly as said, however i'm pretty sure it is a sort of security key for General CADD, not a usable flash drive.

Now, launch General CADD Pro. The Demo Mode message should no longer appear.


Posts: 6,429   +186
i'm pretty sure it is a sort of security key for General CADD, not a usable flash drive.
Yes.:grinthumb That makes much more sense.

and just fyi (if you're curious) see [post=755153]Plug and Play Overview: How Windows Finds Drivers for USB Devices[/post]. And i'll add the following comments/generalizations:
> A Plug and Play device presents Windows its list of Hardware IDs. Optionally, it may also present Windows with Compatible IDS
> When possible, Windows prefers using a driver that matches a Hardware ID
> However, when no driver match can be found using Hardware IDs Windows looks next looks for a driver to match using Compatible ID

USB storage devices that use that a standard Windows generic driver, will present Compatible IDs, at least one of which will match a generic driver.

If you insert a flash drive, rt cick it Properties in Device Manager, click Details. In pulldown window for Compatible IDs you'll see something like

Now view the pull down for Matching ID. You'll see which ID Windows matched to finally select the driver!


Posts: 3,413   +145
Yes it all makes sense now, except where they came from and why he didn't know what they were. I would thing a CAD program would be pretty expensive.

Thanks for your help and information :).
Not open for further replies.