USB Flash Drive Problems

By cs_desertrat ยท 38 replies
May 25, 2005
  1. Speak2BEEB

    Speak2BEEB TS Rookie

    Alright, so sure enough I don't feel ALONE anymore! Indeed, I also was an ebayvictim and I bought the exact same thing:

    advertised as brand new, not refurbished.

    It worked for a little bit. Copied some jpegs over, some opened, some didn't. Then I did a scandisk on it with fix&detect bad sectors. After that, BYE-BYE memory stick! The computer "senses" that it's in, but it can't open it. The LED also just keeps blinking, whereas before, when it was "working," it was a solid light.

    What I found out is that the person swapped the guts and for sure, the guts were used and scratched up.

    I will not disclose the person JUST YET, as he might be refunding me.

    What a scam, and as another pointed out, INDEED, "you get what you pay for!"

    I have yet to try the windows98 format.

    SO BE CAREFUL ON WHAT YOU BUY!!!!!!!!!!!!!!!!!!!!
  2. Sharam

    Sharam TS Rookie Posts: 509

    Did any of you try a working flash drive just to check, just want to know, I know there are bad drives out there.

    What I use is 2.5" drives which don't need external power (gets 5V from USB), and this still fits in my pocket.
    My sandisk never failed me either.

    But in Win2k and winXP pro, I did have to go to add/ remove hardware, uninstall HID mass storage or anything I found with HID and storage and re boot. I had to do this a couple times. It works no problem %99 of the time.

    And I had to do same with many systems (friends and clients) as these days lot of people are using such devices, so I'm not surprised many systems do the same thing, I bet if you went to the add/ remove hardware in any given system, you see many instances of HID mass storage and such with so many devices that users connect and disconnect over and over.

    It is true, from eBay and no name brands you can never be sure.

    It is hard to track these "manufacturers" few weeks they are making flash drives then no good CD-Rs then what ever they happen to be able to get in large quantities and their bright minds as to what to do with what they now have in order to make their investment grow.
  3. Speak2BEEB

    Speak2BEEB TS Rookie

    Hey guys!

    Listen, THIS IS INDEED A SCAM! You guys need to be VERY CAREFUL when buying these things off ebay.

    Check what I did. I opened the Memory stick up, searched for the CHIP that was on it, and sure enough, it was a used 128MB chip, NOT a 2GB chip as advertised.

    The part number on it was TC58128AFT. This is a 128mb chip created by Toshiba!

    I am SO THANKFUL that the guy reimbursed me, but it was only because he noticed I was catching on to his schemes! He's hoping I just drop it and forget about it. NO WAY MAN!

    Here's the guy: alhambenjammin
    Here's the item he sold me:

    Be careful guys!
  4. Xpert

    Xpert TS Rookie

    solving the problem

    I experienced same with 512 MB stick, the solution can be simple..when formatting do not use quick format option!!!Quick format may cause all the trouble, since I formated mine without quick format I didn't experiented data loss. An other advice I received is formatting it to NTFS, if you search the net you will find out how you can do this correctly from Xp. I can not tell much about NTFS formatted pen drives because I formated mine just moments ago.
    I hope these problems are not hardware ones and can be solved, othervise I will seriously doub in pen drives as in floppy disks.
    Good look to all of us!
  5. Xpert

    Xpert TS Rookie

    NTFS didn't do it for me, I stick with FAT 32 it is realible for me. These are all the tipps I can give.
  6. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    what did you expect? You're buying from hong kong!
    always check feedback, ESPECIALLY when buying from overseas.
  7. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    Sorry to hear you had troubles.... ebay can be very dicey.
  8. boredpcola

    boredpcola TS Rookie

    Hi guys,
    I recently had an issue with my pny attache 1gb usb flash drive. I was receiving a message "please insert disk" when tring to access my flash drive. Seems that quite a few others have had or are having the same issue so I am offering advice on the fix which worked for me.
    First you need to download the following program.
    once installed open the program and plug in your usb device, it should show up on the list, if not try closing the program and reopening to refresh it.
    It is very important that you select only the drive you wish to erase, so select your drive and procede. Once the operation is complete safely remove your flash drive and reinsert. Then open "my computer" or right click START to explore to your drive. Highlight your drive and right click it for a dropdown of options, select format and choose your file system and volume name. DO NOT use quick format. Once this process finishes you should be able to access your drive once again and begin rejoicing.
    I hope this helps you guys out, took me about 3 hours to find a fix that actually worked. Shoot me an E-mail if this worked for you or you need help with any of the details.
  9. sillysalem

    sillysalem TS Rookie

    Hi I recently bought a sony 64 gig flash drive from Shaun Holmes on e bay. It took ages to arrive leaving me to think it was coming from another country (not stated on ebay) It worked fine then all the files on it became corrupted and now it even refuses to be formatted. Is there any other way of formatting it ?I payed a small fortune for it ! Thanks !
  10. fightflashfraud

    fightflashfraud TS Rookie

    Hi sillsalem, seems like you bought a fake, most drives on eBay with capacities over 8GB are fakes. Fraudsters take small drives (ususally under 4GB) and program the control chip to report a higher capacity to the operating system. Once the files saved reach the real capacity files that seem to be saved just dissapear into the void or are corrupt. There is a program you can use to check the capacity of your flash drives - it's called h2testw and you can download it free from the Internet. There are a number of blogs on wordpress about this scam which have a lot of information about this scam.
  11. sally90

    sally90 TS Rookie


    I have an 8GB flash memory. It has worked for the last three months. I plugged into my computer today and it wont open. When I click to open it a note comes up saying "Your device needs to be formated." but that doesnt work. I have everything on it. A book, I am writing, work stuff, presentation and NO back up. WHAT WRONG???
  12. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

  13. bikermo

    bikermo TS Rookie

    i don't know how to fix the problem, but i do know how to recover the lost files-

    google "photorec" and/or "cgsecurity" and/or "testdisk" and download.

    or do your w w w thing and put this after it:
    (this forum won't let me post a link)

    it's a zip file. extract the files to a new folder, open the folder for the system you're using and run photorec from there. i had a 6 gb WD pocket drive i was using for 2 years and ALWAYS would safely remove the hardware. used it on a pc at work and through several new computers (upgrades) at home almost every day over those 2 years. it has an excel workbook with my entire financial life on it. i keep track of what is due and when, and which check bills will be paid from, as well as tracking balances on my credit cards, mortgage, 401k, etc., and one day i popped it in and it would show up (as my j: drive) under my computer, but i could not access it. i got no error message at work; it would just seize up the pc. everything else, even stuff not connected to the drive, would run super slow. found photorec and recovered ALL my files. my only tip is go into each folder and recover files one by one. when i tried to recover an entire folder my workbook was invalid per excel. when i copied it alone, it was fine.

    so i plugged the flash in at home and device manager showed it to be healthy and functioning. reformatted it and still shown to be healthy and functioning, but when i tried to access it again i got the "parameter is invalid" error. right-clicking on the drive gives me an hourglass and never brings up the menu.

    got a few things here that hopefully will be helpful, but ordered 2 new drives from amazon in case. thought i would share how to recover your data because it was truly a lifesaver for me. and best of all, it's free! i was so thankful, though, i made a donation.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...