Spread the love! TechSpot Tech Gift Shortlist 2017

USB not working

By AndyTheKing ยท 7 replies
Feb 14, 2017
Post New Reply
  1. Hey! I have a Asus x99 strix motherboard and the other day the usb's stopped working... I have looked all around for information but I have not found a solution yet. USB 3.1 is working but thats pretty much it. Neither the front panel usb's work. I have reseted my bios to default settings but that did not work. I really need help!!!
     
  2. Cycloid Torus

    Cycloid Torus Stone age computing. Posts: 2,831   +551

    Possibilities: specific port driver may be corrupted or loaded twice - same for hub - same for controller, also could be electrical failure caused by voltage regulator chip or some kind of short.

    Remove all devices from USB except mouse and keyboard. Connect mouse and keyboard directly to motherboard USB 2.0 ports. No hubs.

    Go to Device Manager, under View tab set to see 'hidden' and then inspect all USB devices - remove drivers and uninstall 'hidden' and 'error' devices - if duplicates remove both - reboot 'cold', a full power cycle turning PSU off then on - after restart, allow system to find and install what it can - then check Device Manager for problems - then add any additional USB devices one at a time allowing the drivers to be fully installed without error before adding another.

    Keep notes. Let us know how it goes.
     
  3. AndyTheKing

    AndyTheKing TS Rookie Topic Starter

    I will try that! My friend checked on my compiter and He said that its probably my windows 10. I have a free copy Of Windows from my friend. He checked my errors on my computer and mostly of them was Windows errors... I might need to buy a new Windows this time. Do you think it might be the Windows? Also my led's sttopped working... if you want check out this forum https://rog.asus.com/forum/showthre...lled-USB-Ports-not-working-after-bootsequence
     
  4. Cycloid Torus

    Cycloid Torus Stone age computing. Posts: 2,831   +551

    If you want to go into deeper than the USB, then it is time for you to give some detail about system and your history with it. I may have been in error to assume that the USB problem happened on a previously working system. Reading your other posting on the ASUS forum, I was surprised to learn this is a new system. If so, consider re-building on the benchtop, just in case the issue is a badly located standoff/loose screw, etc ...it is important to have a system which will POST and boot properly before trying to assess issues like USB. Once you have that working properly and fully installed, you can try a fresh download of Win10.
     
  5. AndyTheKing

    AndyTheKing TS Rookie Topic Starter

    Thanks for reply. I have a fairly new system wich I built 3 months ago. It boots and post normal codes on the motherboard. The system has a GTX 1070 from asus. Asus x99 strix motherboard with 32gb of ddr4 2400mhz ram from hyper x savage with latency of 12. I have a I7 6800k. I Use a corsair h115i liquid cooler. I use Ssd from Samsung 250gb where I store WIN10.

    I think IT is a failiure in my operating system because my mouse and keyboard light up in boot but it dont light up or work when I come to where I type my password and stuff.

    I had the GTX 1070 in a previus build but I have only used the card in 7-8 months. I have never had a problem like this. I can enter my computer and IT works but I have only 1 working usb(3.1). I think IT is the Windows fault. I am going to buy a Windows today and see if the problem solves.
     
  6. Cycloid Torus

    Cycloid Torus Stone age computing. Posts: 2,831   +551

    You can download Win10 from Microsoft...charge is only for the license which I suppose you already have. Once your machine is registered with Microsoft, you can just run Win10. If you think you have a bad version, download a new ISO copy.
     
  7. Cycloid Torus

    Cycloid Torus Stone age computing. Posts: 2,831   +551

    POST - no serious hardware issues - good!
    mouse/keyboard - light up in boot - then 'dont light up' - likely issue is software (bad driver somewhere)

    CLEAN THE SLATE: DO a POWER CYCLE (turn off system, unplug from wall, remove battery if any, disconnect UPS if any, everything Disconnected and OFF - then hold down the power on button for 30 seconds - then reconnect power and start up again) - then as BIOS comes up, turn 'fast boot' OFF (sometimes too fast for USB drivers to load)

    Check Device Manager for the triangle error signs - any? pls describe if any

    If still not working, try 'LOAD OPTIMAL DEFAULTS' in BIOS.

    If still not working right, go to asus for chipset and other drivers, download again and reinstall.

    Let us know how it goes.
     
    jobeard likes this.
  8. Dimebag

    Dimebag TS Rookie

    Did you get anywhere with fixing your issue?
    I've had the same issue with my X99 ROG STRIX board + 6800k chip... however I had NO USB working at all.
    I've finally managed to figure out a way around the problem that actually involved buying additional hardware but for a long time I thought I'd made a very big mistake purchasing this board.

    Believe me I've tried every suggestion going in regards to rebuilding, changing BIOS settings, drivers and so on... it simply did not work. The problem is fundamental how xHCI is handing off from UEFI/BIOS to the operating system. I've seen this occur frequently when running a dual graphics card setup + m.2 card with a 6800k processor.

    When the PCI express lanes saturate the USB controller can fail to init properly... huge issues.
    Let me know if you need any info on how I managed to fix mine.

    P
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...