USB ports not functioning

By Riesz
Jun 13, 2009
  1. I have a HP m8330f with XP 64 Professional and when I rebooted my computer today, out of nowhere the USB ports stopped functioning.

    I use a wireless mouse and first noticed the receiver wasn't powered and I couldn't move the mouse cursor. First I replaced the batteries in the mouse, although the receiver was not powered. I tried the mouse receiver in the second port on the back of my computer and same result. Tried it in both of the front ports and still no luck. I tested other USB devices on the front ports -- an old wireless mouse receiver, USB hub, etc. Nothing works.

    I checked in BIOS to be sure USB is enabled. It is.

    In device manager for the USB controllers (Standard enhanced PCI to USB host controller, Standard OpenHCD usb host controller, USB mass storage device, USB root hub, USB root hub) I unchecked "allow the computer to turn off this device to save power" in power management. No luck.

    I uninstalled all the USB controllers and rebooted so Windows would reinstall them. Plugged in my wireless mouse receiver and rebooted again. The receiver powers and stays on until Windows boots.

    I'm out of ideas and not sure what is going on. It seems to be an issue with Windows and not the hardware, but why would it happen out of the blue like this? My last resort will be to install Windows, but I hope it doesn't come to that. I'm hoping someone will have more suggestions to try! Thanks for the help. :)

    Edit: Oops, sorry, I overlooked the "General Hardware" forum so this might belong there.
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hmmm.. not sure just what your problem is but in device manager note:
    >> The "controllers" are internal motherboard devices
    >> Root hubs are also internal. There should be (and is) one root hub per controller
    USB Mass Storage indicates your devices are detecting an EXTERNAL USB device class= Mass Storage (which can be a flash drive, CD/DVD drive, or external HD)

    I suggest you start with Windows updates and then reinstall BOTH your usb controllers and motherboard chipset drivers
    See [post=744411]USB Device Problems? Check for Windows Updates[/post]
    See [post=751005]How to Reinstall Your USB Controllers and Motherboard Chipset Drivers[/post]
    See [post=752196]How to Check Hardware / Connection Issues with your USB Device[/post]

    /* EDIT */
    and note is preferred you attempt USB controller reinstall with ALL usb devices unplugged
  3. Riesz

    Riesz TS Rookie Topic Starter

    Thanks for the reply! I will be reading over the links you posted. :)

    The mass storage device is, I believe, the multi card reader that came with my computer. It's built into the case. I don't have any external HDDs or anything plugged in, only my mouse receiver for now. I might try uninstalling the devices and rebooting again with the mouse receiver unplugged, though. I'll look over the links first!
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    you bet.

    try those first. But also note you usb mouse normally appears under Mice in Device Manager (and not under USB controllers). But good to start with windows updates and reinstall your controllers and stuff. can look further at the problem/hardware if problem continues after trying that
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...