Build a PC USB to Serial problem

Status
Not open for further replies.

jools1976

Posts: 21   +0
I'm trying to instal an HL340 USB to serial cable on a Xp Media Center OS. I've used these cables a hundred times before, and usually once plugged in it will come up in the device manager under COM and LPT ports. I'd then install the HL340 driver that comes with the cable and it would work. Thing is, with this computer I'm trying to use it on now, it's coming up in the device manager as USB2.0-Ser!, and there's no driver I can find that will work. I've taken the cable and plugged it into another computer running Xp Home and it comes up like it should (COM and LPT ports) and works great. So... I know it's not a bad cable. Any ideas?
 

jools1976

Posts: 21   +0
  • Thread Starter Thread Starter
  • #3
It's actually a Toshiba Satellite laptop. It has 2 ports on the side and 2 on the back. I've tried all 4 seperately but always the same result...
 

kimsland

Posts: 13,810   +3
Please update all your Toshiba drivers from your Toshiba support page
You may also want to download the Manual and confirm USB2 exists on any/all ports

I usually do a Windows update (Custom) as well to confirm all drivers are up to date
Plus it is wise to confirm all Service Packs and security Updates are complete

It also could be a Virus/Trojan causing this issue, so you may wish to do a full scan

Lastly check in CMOS (usually DEL or some other keypress on system startup to get into CMOS setup) Check all USBs are enabled, there may be other options on your USB settings as well
 

jools1976

Posts: 21   +0
  • Thread Starter Thread Starter
  • #5
I completely updated windows, and I also ran full virus/malware/spyware scans cleaning anything that was there out. I checked the Toshiba website but there were dozens of drivers and I wasn't sure which ones I might need. Lastly, I checked the CMOS and anything USB related was enabled.
 

jools1976

Posts: 21   +0
  • Thread Starter Thread Starter
  • #7
Which drivers do you mean though? I have an A100 so I have to go to the toshiba.ca page to get the drivers...
 

jools1976

Posts: 21   +0
  • Thread Starter Thread Starter
  • #8
Update. I ended up solving my issue. I found an alternate driver for the HL340 that had an uninstall option within the application. I uninstalled the driver while the cable was still plugged in, then removed the cable and reinstalled the driver. Once this was done I plugged the cable back in and it came up HL340 in the device manager instead of USB2.0-Ser!. The found new hardware wizard still came up, the drivers finished loading automatically and it was good to go. It's just weird because using the exact same cable I never had to do that before. Oh well... Issue resolved. Thanks for the help once again Kimsland!
 

kimsland

Posts: 13,810   +3
I found an alternate driver for the HL340
Please provide link to this driver
Because I went all the way through your drivers page (earlier today) trying to work out "which one"

htt p://somewebpagelink
 

jools1976

Posts: 21   +0
  • Thread Starter Thread Starter
  • #10
Thanks for checking that out for me. The driver is actually on a disc that was given to me (Not the one that came with it). Am I able to attach to the thread?
 

kimsland

Posts: 13,810   +3
No, only up to 200kb (ie not much)
You could attach the inf file in the extracted setup folder, that's about all
Otherwise you need to upload it to Rapidshare (or some file hosting site) then link to here
 
I can't get HL340 USB/serial to work on Vista. Does it need a special driver, or are there any other ways to get it going? I'm using Toshiba Sat Pro L300.
 
HL-340 drivers!

Went into Device Manager and found the VID/PID for my cable (1A86:7523). Searched and searched and found it was a HL-340 device.

Found working drivers for HL-340 on WinChipHead.com. It's Chinese but following the various links I found the download page. I found a PDF for the CH340, but only found a driver link for CH341. Downloaded, installed and VOILA! My HL-340 USB-Serial adapter now works using the CH341 drivers.

Winchiphead.com/index.htm

Drivers - winchiphead.com/download/CH341/CH341SER.ZIP
 
I just bought also HL 340 usb to serial cable and have tried all above mentioned drivers and it still does not work. When the device connected to usb port of my notebook the error mesage is "USB device not recognized. One of the usb devices attached to computer has malfunctioned and windows does not recognizes it". In device manager it only recognizes the device as unknown device without driver installed. I tried various way to install driver just still does not work.
 
Thank you jools1976!!!

I was having the exact same problem with my Toshiba Satellite laptop. Same OS, etc. I desperately needed to connect my generic HL340 USB to DB9 serial cable to my laptop, so I could connect to my router's console port through HyperTerminal. I've been looking for a solution for several days, to no avail, and then found your post. I cannot say enough about what a great help you've been!
 
HL-340 drivers for Vista 64

HL-340 drivers: winchiphead.com/download/CH341/CH341SER.ZIP

Thanks Kimsland

I am a complete novice so please forgive my naivity. I downloaded your file to my desktop, it appeared as a type of blank read file, no exe. or similar. I installed Winzip as I use Winrar, just in case that was the problem but still same. How do I open the file?.
I am running Vista 64 and cannot use the usb-serial adapter as mentioned in previous comments.
I purchased it from Amazon, they sent me a disc with the driver on, but it doesn`t work, I think it`s because I`m using Vista 64.
Many thanks for your patience.
 

kimsland

Posts: 13,810   +3
I just downloaded the attachment above (oh, one page back now), then right dragged it to a blank area on my Desktop, and un-zipped with WinRar.

All seems to be in there, so please try again ;)

I don't think the driver works with Vista though :(
 
Thanks Kimsland
I downloaded it again , played around a bit (as you do) and finally got it. I had to decompress it twice so to speak, Unzipped your file, which left the file I mentioned earlier, When I tried to open that, windows asked which programme to use (could not browse to winrar for love nor money) so opened winrar prog` browsed winrar to desktop, found the ch341ser file (unzipped) and unzipped again, there were the drivers etc, as you mentioned.(a bit long winded I know)
Thank you again for your help.
 

kimsland

Posts: 13,810   +3
That is so strange
I have now seen that 3 times, and it's the one thing I can't work out why it's happening

You unzip
Then add the zip extension to it again (but because there are now two files of the same name, you are best to originally unzip to it's own folder)
Anyway, after putting "Zip" back on as the extension, you unzip again, and everything shows :confused:

Well its got me beat, because it's only zipped up once (and I just proved that a few mins ago)
I'll find out one of these days :suspiciou :D
 
i am having problems with the HL-340 drivers links you guys published on this site. Can someone help me please, kimsland
 
Status
Not open for further replies.