1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Vaio VGN-A190: Reboot and select proper boot device error

By NoxVenom · 6 replies
Aug 13, 2008
  1. Hello Everyone,

    This is my first post here... in regards to an issue with my Sony Vaio Laptop (VGN-A190 model.) I have spent the past six hours searching for similar problems but have not came close to a resolution. I hope that I can find my answer here.

    Anyway, here it goes...

    Intel Pentium M 735 / 1.7 GHz
    512 MB DDR SDRAM
    80 GB - 4200 rpm
    DVD±RW - Integrated
    Windows XP Home
    Ownership 4 years

    Laptop began having issues with spontaneous reboots and shutdowns.... at first I assumed that the system was overheating... soon after windows was no longer able to boot and I was presented with, "Reboot and select proper boot device or insert boot media in selected boot device and press any key." At or around this time I noticed a very distinct pattern of "clicks and scrapes". Surely that must be the hard drive that has failed!

    I went ahead and replaced the hard drive with a WD1600BEVE 160GB 5400 RPM ATA. I had nothing to lose on the original 80GB and justified the repair further with a larger hdd along the way. I was prepared for formatting and a fresh installation of Windows XP using the System Recovery Discs. However, I was still seeing the "Reboot and select proper boot device..." screen again. The "clicks and scrapes" sound did go away though... ;->

    I have gone into BIOS to see what was going on with this whole drive issue and noticed that it was not detecting any of my drives, (which explained the error and issues with reading the CDROM) the entire "boot" tab is blank as well. I tried to search for further info on this version of BIOS (AMI 2.42 R0040F1) but have not found much... I did come across alot of forums stating that perhaps BIOS would need to be flashed... but how can flash if it does not even read any drives? Don't know if it matters... but it is still able to read memory at least.

    I went over the simple solutions that Sony provides ifor BIOS in re-setting the date and time, restore defaults, save and quit.... but still no boot. I don't see any other options that I can "tinker" with and feel that I have hit a brick wall with this one. First I thought it was the hard drive, then BIOS and now I am thinking that it may be the mobo but I am uncertain... Sending it off to Sony is out of the question for the time being due to their high priced repairs.

    If anyone can offer any help or ideas I would greatly appreciate it.... I am not ready to scrap this system just yet.

    Thank you!
  2. terminator911

    terminator911 TS Rookie

    Found this at another site:

    Recheck the jumper on the HDD and make sure it is configured right.
    Also check the BIOS setting for LBA Enabled on the HDD.

    Check to see if there is a legacy controller option enabled in the BIOS. Disable it and then try booting up.

    3 more options:

    1) Boot sequence is performed through a ROM memory module...as such there may be an issue with the memory not releasing and locking up the system...remove all power systems and batteries to reset the BIOS and ROM memory modules.

    2) You could have a faulty power supply and is keeping it from booting properly

    3) Faulty mobo

    Both 2 and 3 are possible even if it does accept a BIOS update.
  3. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

    Yes disperse all voltage by removing all power, and holding down ON button for 30secs

    But I believe it's "DVD±RW - Integrated" faulty or "512 MB DDR SDRAM" faulty
    Which at least is not as bad as the Mobo

    Although faulty CPUs can cause strange behaviour too.

    I'd go Ram then DVD Drive then CPU
  4. NoxVenom

    NoxVenom TS Rookie Topic Starter

    terminator911 & kimsland,

    Thank you for the troubleshooting ideas! I am going to take a stab at this tonight and see how it pans out. I will definitely send an update on the progress... Can't express how happy I am to have new options in hopes to correct the issue.

    Thanks again!
  5. NoxVenom

    NoxVenom TS Rookie Topic Starter


    Here is my progress so far....

    I went ahead and removed all power sources from the laptop and RAM... pieced it all back together again, started power and noticed that I have lost video, audio and keyboard... I then hooked up the laptop to a monitor to see if it would pick anything up, but no signal was detected.

    On a positive note....(I hope)... I was able to hear the system attempt to access the hdd and and noticed that the led light was finally showing signs of life for the cdrom. However I was unable to gain access to the cdrom without having to manually open it. I tried to slip the start up disc in there and restarted but it was not reading of course.

    Once again... I do appreciate any further assistance regarding this system.

    Thank you!
  6. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

    So you did All power out, and then hold in ON button for 30 secs?
    Id also say leave the battery out, and just put the Power Adaptor in to test.

    If this is done, and it's still the same
    Then you may need to dismantle the Laptop and reseat all internal connections
  7. lamo

    lamo TS Rookie

    the lost of HDD is the key to problem solving. SATA and IDE port leads right into southbridge chip. since, you've lost the CD-ROM and HDD drives in your system, it's a southbridge chip(82801DBM) faulty. this is common problem for first centrino systems.
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...