Vista Home Basic uses 100% of CPU

By rwc1969 ยท 15 replies
Jul 13, 2009
  1. I've searched for three days for an answer to this problem.


    A lot of people have or had this problem, but no one seems to know the answer to fixing it. I've searched endless threads on endless forums and found zero answers to the problem. Most people responded by saying they have the same problem and it eventually just went away, came back or they switched to XP/ Linux OS.


    The system was non functional from day one. Brand new system. Only internet access was to mfg. websites. i.e. Nero, Windows update, Dell. I doubt I have a virus and KIS 2009 was installed after MS updates and prior to connecting to above websites. I have since reformatted C:, reinstalled the OS from the hidden Dell recovery partition, removed the Nero stuff, KIS 2009, DVD drive, and floppy drive. I have not accessed the internet since other than MS update.

    Prior to installing this stuff the system was still dead dog slow. I was very careful installing and removing the drives as to not short anything out, no wires are loose, memory is secure and in place. CPU fan is working, case fan is working, DVD rom is working. HDD? I haven't tested it. Maybe it was bunk from the factory. I'm not sure how to test it. My Dell warranty expired two days ago.

    I have not messed w' this system since I bought it a year ago because it was so slow. I figured it was the memory and would wait to mess with it until I got more memory. I don't need the system, have others, but intended to get it functional and give it to my kid as a gift. He needs a system.

    Problem: every aspect of operation is extremely slow, almost non-operational.

    processes running in tskmgr are consuming 100% of the CPU, 100% of the time. The memory is between 47 and 70% used up. tskmger.exe, System, and one or two other MS processes are listed as consuming the CPU, mainly tskmgr and system! The only non MS services are google desktop, Google search, and Dell suport center? It takes 5 minutes or more to startup or shutdown, open control panel, event viewer, etc. Lots of (not responding)! There are alot of errors, warnings, etc. in the event viewer for Windows. System boot, system shutdown, etc. All errors apparently relate to the OS. Also, when I shut the system down, the power button on the case stays lit as if it's in sleep or hibernation. I've set Windows to shut down, not sleep or hibernate. It won't restart unless I hold the power button down for a few seconds to shut it off, then repress the power button to start it up. Windows update takes forever, 8 hours or more and the internet connection seems dead dog slow as well. Other systems on same cable work fine!


    Dell vostro 200, Windows Vista Home Basic, celeron 430 1.8 GHz, G33/G31 express chipset family, 1 GB DDR2 memory, integrated sound, NIC and video w' shared memory of 128 MB or so? 80 Gb, 7200rpm SATA HDD, DVD rom.


    Reformatted C: and re-installed OS from Dell recovery partition. Ran memtest86+ in STD mode for 8 hours w' no errors. Tried using Ubuntu Live CD and it just stalled after asking for language, etc. Black screen! I disabled Windows search, indexing, Google desktop, search. Set system for maximum performance, i.e. It looks like windows 98, 2000??! No improvement! I've physically inspected the memory, MB and all hardware and connections. Everything "looks" fine.

    I have the System disk and drivers from Dell and at this point my only option is to test the HDD? and/ or wipe the HDD, hidden partition and all, reinstall, OS, sp1, and drivers and utilities from disk.

    Please help!

    I realize the Celeron w' 1Gb shared memory w' video is probably undersized but it should function, shouldn't it? Others have said it does. There is nothing installed on the computer other than Dell support stuff and Google desktop stuff that it came with from factory. I can't rule out a defective HDD or MB, malware, virus, but have had no bluescreens and very limited internet access, as stated above, all while fully protected via KIS 2009.
  2. rwc1969

    rwc1969 TS Rookie Topic Starter Posts: 33

    Update: I checked the HDD w' HDtune and it checks out A-ok. I'm planning on running chkdsk and scannow. Is that advisable? Any help is appreciated.
  3. mrturtle

    mrturtle TS Rookie Posts: 43

    Have you tried using a different cd for testing with Linux (I'm only saying this because I had a problem with a messed up DVD the other day, might not help but it's woth a shot). Maybe try without the hard drive connected or just one stick/another stick of ram in case it is one of these items causing the problem.

    You're right it shouldn't be that slow, I have had Vista running with only 512MB of memory before. But that had Pentium 4 proccessor.

    It may be worth trying to reinstall the OS from disk like you said, but that would destroy the recovery partition (plus you said that it could not boot into a live linux cd). It could have been a bad image put on the machine by Dell without them knowing?!? If you can get your hands on an actual Vista disk might be worth trying the repair installation function.

    Good luck with getting it working.
  4. mrturtle

    mrturtle TS Rookie Posts: 43

    Don't know about scannow but chkdsk should be fine. Here's some info on chkdsk for you just so that you know what it is (if you didn't already know), seems correct but I only glanced through it.
  5. rwc1969

    rwc1969 TS Rookie Topic Starter Posts: 33

    Thanks Mrturtle,

    I ran memtest and it stated memory was OK.

    HDtune said HDD was OK.

    I disabled indexing on C: and D: via properties of Drive.

    I've disabled the windows sidebar and Google add ons that came w' Vista.

    Still using 100%

    I ran Process explorer.

    Results: I'm not 100% sure what I'm looking at, but...

    DPCs- 50-77% CPU
    interrupts- 15-33%
    System- 1.5-10%
    procexp- 3%
    svchost and explorer occasionally 1.5%

    It appears the DPCs and hardware interrupts are consuming most on a regular basis. As a whole I'm still at 100% CPU usage.

    Now, what to do with these numbers?

    I agree that it might be a bunked up OS that was shipped w' the system. I do have the Dell Vista disk, vista sp1 and drivers and utilities disks that came w' the system. Before I try that I want to see if I can get it working. I have a strong feeling there is a small glitch in the OS and might be a simple fix. Just gotta figure out what it is. That's where you folks come in. :)
  6. rwc1969

    rwc1969 TS Rookie Topic Starter Posts: 33

    OK, I've done a little research on the above and it appears that something is hogging up the CPU, DPCs and interrupts are using all available CPU.

    Does anyone know anything about this? I'm getting the impression it's driver or service related, most likely driver. I don't know how to proceed further and narrow this down.

    Please help! :)
  7. mrturtle

    mrturtle TS Rookie Posts: 43

    It may help if you give the exact name of the .exe's that are taking up the largest amount of system resources.

    Do you know if the interrupts are a hardware or software interrupt, more wikipedia for you, lol, As I said before only had a quick glance but seems to be correct, may give you a resonable idea if you don't already know.

    You said about DCP's and not being able to access the internet very well. The only articles I can find at the moment about DCP's (device control protocol??? you may want to view this with no script as I have never used this site before) are about networking and other internet related stuff (for lack of a better word).

    I really am not sure about what the exact problem is either to be honest (open invitation to other techspot members?). But I will try and help you as much as I can.
  8. mrturtle

    mrturtle TS Rookie Posts: 43

    Just out of curiostiy have you checked the event manager?
  9. rwc1969

    rwc1969 TS Rookie Topic Starter Posts: 33

    Yes, I have checked event viewer, ther ea re errors, etc. but the Microsoft website gives no solution to the errors, mostly stating they are not critical or something to that effect. is DPCs

    They are Hardware interrupts. It's as if the hardware is saying " I need CPU" and the OS is saying "too bad". There is a conflict somewhere. the interrupt request priorities are out of whack or something. The OS is not allowing interrupts to the CPU for the background OS stuff like it's supposed to. Or so it seems to this newb!

    This problem is all over the net w' no solutions available. Most people suggest reinstalling, changing OS, performing common tasks to speed up Vista, etc. etc. I've done everyrthing , but change OS.

    The issue is with a driver, hardware, or OS setting that is out of whack. I'm almost certain of this.
  10. rwc1969

    rwc1969 TS Rookie Topic Starter Posts: 33


    I went thru each individual device in "device manager" to check for "device working properly" and "conflicts". Only one device showed a conflict and several said there was no driver installed.

    The conflict: High Precision Event Timer shows a conflict w' memory range FED0000-FED003FF, which is used by: ACPI x86-based PC. HPET has no driver installed as well.

    Other devices with no driver installed are as follows: Intel ICH9 Family SmBUS controller-2930, Direct Memory Access Controller, Intel 82802 Firmware Device Hub, Numeric Data Processor, Programmable Interrupt Controller, System Speaker, System Timer.

    I have no clue if these things should have drivers, be disabled, or if the conflict is a problem or not. I'm in over my head!

    Does anyone think this could be the problem?
  11. rwc1969

    rwc1969 TS Rookie Topic Starter Posts: 33

    I should point out that this OP was posted in several other forums as well. I thought I made that clear in the OP, and subsequent posts, but members of other forums have taken offense to the fact that I seeked help across the internet from other sources than their own.

    I apologize if this is unnacceptable. I would think one would search for answers everywhere possible, but that's just me.
  12. rwc1969

    rwc1969 TS Rookie Topic Starter Posts: 33

    In an effort to keep everyone up to date and hopefully avoid ruffling feathers of other forum members here is a link to waht I've done today.

    I'm trying to determine if the above listed devices need drivers for the system to operate and where to get those drivers.
  13. rwc1969

    rwc1969 TS Rookie Topic Starter Posts: 33

    I posted the event viewer errors in the link above. Also, I checked out the driverless devices and they don't require drivers in Device Manager.

    I still haven't sorted it out, but figured I'd post this link for anyone else who may have a similar problem. There is a lot of good info relating to High DPCs and hardware interrupts consuming up to 100% of CPU.

    I disabled LAN, FDC and sound in BIOS to no avail. I updated the OS to SP2, fully patched to no avail. I checked msinfo32 and everything checks out A-OK. No IRQ conflicts, etc, and status on everything there is listed as OK.

    My next step was to diasble the integrated video, but then there would be no video. The only other Video card I have is AGP and all my slots on this system are PCI.

    Also, hijackthislog showed nothing funny.

    The problem appears to be hardware/ driver related, but I can't figure it out. What has worked for others isn't working for me.
  14. rwc1969

    rwc1969 TS Rookie Topic Starter Posts: 33

    If anyone has any suggestions to fix this pleases let me know.

    I figured I'd start from scratch and reinstall from the dell vista 32bit setup dvd disk. That failed because the system wouldn't shut down after the initial required restart. Got a BSOD instead! Drive_power_state_failure. Stop 0x0000009f (0x00000003, 0x80b58c78, 0x80c4d790, 0x819e6008) I couldn't find anything Vista specific for this stop code. So, I reformatted and reinstalled again using the other Dell supplied Vista dvd disk, 32 bit sp1. For some reason Dell supplied 2 disks. One labeled Vista 32bit and the other labeled Vista 32bit sp1. I got the exact same results with a slightly different 0x9f stop code. Then,I tried repairing vista using the supplied sp1 disk, same result w' a slightly different 0x9f stop code again. Plus it now showed 2 instances of Vista on C drive. That is strange, because I reformatted C after every reinstall.

    So then the system would not turn off and would never fully boot. After the initial scrolling windows bar at the bottom I would just get a black screen with a blinking cursor in the upper left corner of the screen.

    I then tried using the Dell recovery partition again to restore to factory default, but couldn't access it from BIOS. Found an article on how to manually do this from the elevated command prompt in BIOS boot options. So, I managed to get the system restored once again to the factory default.

    Upon the initial restart an error box popped up and stated Rundll32.exe "windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the system."

    this jogged my memory and I now recall getting that same error box after the initial install way back in September 'ish and again a week or so back when I reinstalled from Dell partition to factory default.

    At this point the system is back to the point when I first started this thread. I looked into the rundll32 error and couldn't find it in the appropriate folder in Windows. So, I ran sfc /scannow from an elevated command prompt. The process took over 4 hours and it stated when finished. "found errors and couldn't repair some of the files" or something to the like. I researched that and it was stated that upon restart sfc /scannow usually fixes them. I checked after restart and the rundll32.exe file is now in the system32 folder along with many more that weren't there before I ran sfc /scannow.

    This makes me think that the factory default install is missing many files. The system will now shutdown and restart on it's own, but it takes 10 minutes or longer to do so. It pretty much takes 10 minutes to do any one task. i.e. opening "computer", "C:", "Windows", "system32". I no longer get the bluescreen error code 0x9f, or the rundll32.exe pop up box when I restart.

    On the previous factory default restore I updated my video, sound and lan drivers to the latest available with no results. In fact the latest Intel chipset driver kept giving me a "Vista" pop up asking me to run in legacy mode, so I went to Dell and got their latest driver update which was an earlier version, the pop up went away. As of now all drivers are factory default. Other than running sfc /scannow the system is as it was the day I bought it.

    The thing I don't understand is why Ubuntu live won't run and even the restores from dvd disk took forever and failed. I'm starting to think the driver for, dvd-rom or psu to dvd is defective. What gets me even more is the fact that every error I've researched eventually leads to a Microsoft website that states the problem was in an earlier version of Windows, nothing specific to Vista, and that the problem was corrected with XP sp2 or the like.

  15. rwc1969

    rwc1969 TS Rookie Topic Starter Posts: 33

    After going to the sysinternals forum I was able to narrow down the problem, but not yet a solution. I ran many diagnostics, re-installed, etc. etc. I updated the BIOS too. It's a Dell/ foxconn g33mo2 motherboard. It seems they had some firmware issues. I updated to the latest Dell provides and it still doesn't work. Something to do with ACPI not functioning properly. ACPI.SYS overwhelms the cpu with hardware interrupts and DPCs making it impossible for anything else to access the cpu. ACPI.SYS is the driver for "Microsoft ACPI-compatible system" in Device Manager. I've tried disabling and uninstalling this device, but Vista just re-installs it automatically upon reboot.

    Thanks for the help mturtle.
  16. rwc1969

    rwc1969 TS Rookie Topic Starter Posts: 33

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...