Western Digital external hard drive problem

By delux269 · 77 replies
Nov 27, 2008
  1. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1. As for Acronis, no don't install. Didn't mean to sound like i was asking about the Acronis tool i previously mentioned, just meant to ask if you have any Acronis products installed. Don't install any just yet.

    2. You can put any still open questions/data requests i made on HOLD (needn't do anything more just yet). Before collecting any more of that info, i think it worthwhile to run a trace through the plug-and-play / device install process. So i'll post some new instructions tomorrow on what to do. Based on what i see as the result, it may answer some issues or at least help narrow what i'm looking for.

    3. just fyi... to help the TechSpot moderators (who've been merging posts when you've been posting replies to your own post) if you want to add new info and your last post hasn't been replied to yet, just click Edit button to edit that post and add info to end. And just indicated something like *** EDIT *** as you've seen me do.
  2. delux269

    delux269 TS Rookie Topic Starter

    Okay I will condense my posts. I really think that the whole problem may lie in the plug and play install process.
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OK. I think this is the last question so that i can finish writing the steps for our trace test. Could you please look in your registry and tell me about this key

    - Does it exist?
    - If it does exist, what value is it assigned currently?
  4. delux269

    delux269 TS Rookie Topic Starter

    No that directory does not exist
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Included below:
    - Instructions to collect trace data for me when connecting the drive
    - A few new things also worth looking at / noting / you should also try
    I'll let you decide the to-do order of things. You can decide if you want to respond when all's done or any points along the way.

    Check Windows System Services
    There are two Windows services that must work correctly for your drive to be detected and appear in Disk Management.

    Start->Run, enter: services.msc. When services window opens, click Standard tab. Scroll to find these entries:
    - Logical Disk Manager and
    - Logical Disk Manager Administrator Service

    Look at Status and Startup Type value for each service
    ==> If either service Startup Type = Disabled it’s a problem.
    ==> If either service Status = Stopped AND Startup Type= Automatic it’s a problem.

    Otherwise the values should be OK. Just tell me what values you see for each service. (Status might have a blank value is OK too)

    Hard Drive not secured within the enclosure
    There are many possible causes of your problem. When surfing online this morning I happened across some interesting things.
    Someone who wrote of having identical problem. They indicated they opened the HD enclosure and found the screws which secure the drive within the enclosure had loosened. (The drive had actually shifted a small fraction of distance off of its mount) They tightened all the screws, put the enclosure back on and now things worked!

    Someone else replied to say after reading the solution they checked their own external HD. They also discovered loosened screws. After following same action, the their problem went away as well!​

    Check Windows Event Logs
    Realized I hadn’t yet asked you to check the Windows Event Logs for relevant error reports. Click for general info about how to use Windows Event Logs.

    Start->Run, eventvwr.msc. You mainly want to check the System log but may as well look at Application log also. Click on the log to open it. All the entries where Event Type= Information occur normally. To filter them out from the log view: Click View->Filter. Uncheck Information. Check Warning and Error. (We don’t care checked or unchecked for Types= Success and Failure.) Hit OK

    Generate/Capture a device install trace
    First some setup to download a tool to help with trace. Also, uninstall any related devices to assure Windows has to reload them.
    • Remove your SD card. Unplug all USB stuff from computer
    • Download Plug and Play Monitor
    • To uninstall devices, set Device Manager to display unconnected devices (again). Here’s the MS “howto” link again
      • Open Device Manager. Click View->Show hidden devices
      • Scroll to category: Universal Serial Bus Controllers and expand. (You should again see entries with semi-transparent icons.) Look for entries USB Mass Storage. Rt click-> Uninstall each USB Mass Storage
      • Scroll to Disk Drives. Find the WD drive entry and uninstall it.
    Now trace file and logging setup
    • Make a backup copy of file C:\Windows\setupapi.log
    • Next, Start->Run, notepad.exe. Open file C:\Windows\setupapi.log. In File Open dialog box, change File Type to *, All files so the .log file appears among file choices) Once file opened Edit->Select All, Edit->Cut to empty the file, then save it. It should now be 0KB size. (Do not delete the file. Instead, we want it to exist but with 0KB size. If you repeat these steps you don't have to empty setupapi.log other times. Can leave as is)
    • Set the logging level
      • Get attachment to this post Loglevel.txt.
      • Change its file extenstion so it’s now file: Loglevel.reg
      • Double click the file. Answer Yes when prompted about updating your registry
      • When all done, you can edit this file using notepad. Set the loglevel back to dword:00000000

    Now let's trace!
    • Run Plug and Play monitor tool you downloaded at start of instructions. Check the box Monitor all device types. Click Start
    • Plug the USB drive into the computer
    • You should see the usual on the computer. You should also see some output from the monitor
    • When done, click Close on Monitor then click Copy. Paste the monitor output into a text file you can attach to your TS post.
    • Make another copy of C:\Windows\setupapi.log. Change its file extension so it's now C:\Windows\setupapi.txt and attach this as well

    And done!
  6. delux269

    delux269 TS Rookie Topic Starter

    Okay, I'll just work from the top-down here, that seems like the most logical way to do things. For "logical disk manager", the status is started and the startup type is automatic. For "logical disk manager administrative service, the status is blank, and the startup type is manual.

    I am getting an error message when I try to download the plug and play tool. I will try again later.

    I am also having a lot of trouble figuring out how to open the case on this drive. It is a WD MyBook Essential Edition 2.0. I have seen in doing some research that most forums say that this deive has a screw on the upper left hand corner, however mine is nothing like this and I cannot find any way to open it. I don't want to just pry it open for fear that I will completely destroy the drive.
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    See if this helps on how to open that enclosure

    If you refer back [post=690511]to this post[/post]. Look at #3 and #4 about downloading/running two WD programs. I know i had said you can put a hold on prior to-do-list but if you haven't tried these two things yet.. is worth adding these to the current to-do "things to try" list
  8. delux269

    delux269 TS Rookie Topic Starter

    I attached the new setupapi file. I must have done something wrong with the plug and play monitor because it didn't do anything when I plugged in the device.

    Those intructions do not work for my drive. I must have anewer model or something because there is no screw on my drive.
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Well, a quick eyeball of the file you sent:
    - I didn't notice any failure messages (but still need go thru it in detail to see what it is doing)
    - No worries on monitor tool. It appears all the plug and play traffic did happen (but again, need a more detailed look)
    - So will start looking at file (will take awhile) and let me know as you complete the remaing to-do's on the list

    btw.. those Windows services settings don't (by themselves) indicate any error.
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OK. So i'm double posting now myself but want to make sure you catch this post sooner then later.

    Please add this at the top of current "to-do" list......

    I had referred back to Everest Report and noticed you have a firewire (IEEE 1394) connector on your laptop??? Please Control Panel->Network Connections and there should be entry for the Firewire/1394 connection. Rt click Disable the Firewire/1394 connection. Leave it disabled if you can through out tests (or do you need it?). Then reboot. And then try connecting USB drive again to see if any difference.
  11. delux269

    delux269 TS Rookie Topic Starter

    I disabled the 1394 connection and plugged the WD drive in with the same result. Should I uninstall the drivers again to see if it makes a difference?
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    General observations about problem: External USB hard drive not recognized
    • Often seen this problem reported in the past but never before dug into it like now
    • After digging in the last several days I’m really surprised at
      • The frequency and number of people who report the problem
      • Both number of and how different the various reported problem causes can be
      • Yet at the same time, still seems to be many, many people who never find a problem cause

    That said, getting back to your case
    • To best of my knowledge, I haven't found any thing wrong/surprising in the plug-and-play / device installation trace data provided (tho am still looking)
    • The above statement is consistent with
      • You said Windows reported no problem devices in msinfo32 tool (implying all devices installed correctly)
      • Trace data shows 2 devices installed (each successfully) which is consistent with you having looked at for me before: Disk Drives - WD device, and the USB Mass Storage device (these are the 2 that the trace show were installed)
      • So am also very curious as to a) Windows' next steps after device installation. This is where the two different Logical Disk Management services come into play b) Possible interactions with Power Management (which also follows device install)
    Best next step priority: Look into the Windows Event logs (prior post instructions). Especially System log (is where i'd expect problems with system services or other USB related problem might be reported). If unsure about log data, just filter out Information records (describe in prior post) and capture all the other Event Data (including Event Detaill) in a file you can post back here

    /*** EDIT ***/
    And sure, try uninstalling the devices the connecting usb device as well just to see. This cause was noted with some computers (or maybe just Dells) so figured was worth a shot

    /*** EDIT ***/
    And, ah-ha. not that i found the cause but i did finally find a download site for an elusive tool i've been looking for to help interpret some of the registry crap. Click here to download UVCView. Run it. Click Options and check Show Config Descriptors and Show Descriptor Annotations. Click File to Save to disk text file and let me see that too please
  13. delux269

    delux269 TS Rookie Topic Starter

    Okay. I will get to these things tomorrow.
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    no problem. when you have time (and energy!). am gonna bag it myself soon for night
  15. delux269

    delux269 TS Rookie Topic Starter

    I uninstalled the drivers and restarted the computer with the 1394 connection disabled, then plugged in the hard drive, I had the same result but it took Windows a lot longer to recognize the device and install the hardware, I'm not sure if that means anything or not but I just thought I would mention it.
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    An interesting point to know and always good to mention stuff like that as never know when can prove to be useful.

    May come back to it (and run a trace) but for now, most interested in the Windows Event System Log.

    ==> In general, see what ERRORs or WARNINGs appear and if any of them are occuring about the time we did a USB connect or disconnect (fyi. you started the trace connect 2008/12/02 15:06:49 and it run 90secs.

    ==> In particular, see if any entries about those two LDM (Logical Disk Manager) services. (These 2 services help get the disk into Disk Management - which isn't happening.) So would be interesting if there are event entries where TYPE= ERROR or WARNING and Source= Service Control Manager. Then you double click the entry to see event detail which tells which service and the actual error.
    ===> You can take a look but still good to generate a System log as a text file without any filtering (changed my mind about filtering out INFORMATION records) and post the system log text file.

    I'll also be updating this post either sometime soon or much later on how to check so we can make sure your drive is really getting sufficient power from the AC adapter and we don't find a Power Management issue involved if it's drawing to much from the USB port.

    i bet you never knew how many different things could trigger this problem. In fact, I didn't know that myself until looking into this!

    /*** EDIT ***/
    In fact, instructions to check power usage is easy. Here:
    Open Device Manager. Look under USB. For each USB Hub, rt click Properties. Click Power tab. You'll see power draw/usage for each. You should also see which hub the disk is on. see attachment for example

    Attached Files:

  17. delux269

    delux269 TS Rookie Topic Starter

    I see that the USB mass storage device is using 2 mA. Is this about right?
  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    A 2mA draw for the USB Mass Storage device is just fine. The drive's external AC adapter and power source are not part of the problem.

    While we still haven't identified the cause, we have been able to rule several things out. To the point where I'm anxious to now focus on the 2 different Logical Disk Management (LDM) services and how different software, config and data issues might prevent them working correctly.

    Question: Do you use Damon Tools? Or ever had the software installed on laptop? I've found reports that certain versions caused LDM issues.

    The next two priority items
    1. Windows Event System Log
    Here's simpler instructions as
    a) I changed my mind and don't want you to filter any INFORMATION records
    b) You only need create the attachment. Not necessary you look at the file yourself (tho your welcome to if you want)
    => Start->Run, eventvwr.msc to open Windows Event Log Viewer
    => Double click on System to open the Event System log
    => click Action->Save Log File As, Save as type should be Event Log (*.evt)
    => Compress the file into a .zip file and attach to TS

    2. System Change History
    When you checked this last time, you saw it display No History (which is misleading). But i didn't clarify then and ask you try again as the data was less important to have then as now. So try this
    => Start->Run, msinfo32
    => Click View->System History
    => The first windows display says No History. But just ignore that.
    => Click File->Export to save it as a text file you can then attach
  19. delux269

    delux269 TS Rookie Topic Starter

    Here is the report from #1 in your post above. I also editied this post and added the history report.
  20. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    And next....

    Windows System Event Log indicates that both LDM services start/run/stop as they're supposed to.

    This only rules out something which prevents the LDM services from starting/stopping when told to. That still leaves the case that some Windows device/disk/etc. data is corrupted/inconsistent/missing/etc.

    Let's try a quick change and test first. Start with no SD cards or USB devices connected.
    1. Run->Start, regedit. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices. Then rt click to Export to type .reg file. Close regedit
    2. Run->Start, diskmgmt.msc. Note the disks listed in lower pane. Insert the SD card. A new disk should appear for the SD card. Confirm you see the SD card mapped to drive letter E:
    3. Rt click on the SD card E: volume. Select Change Drive Letter and change it to a letter you've probably never used like Z: Close out of Disk Management.
    4. Repeat step 1 to create a new MountedDevices registry key export file after you changed the SD card volume letter.
    5. Remove SD card. Reboot. Connect your USB device. Anything different?
    You can either zip the two export files or will need to change .reg to .txt extension so you can post the files as attachments
  21. delux269

    delux269 TS Rookie Topic Starter

    I attached the report from #1. For #2, I do not see the SD card appear in the disk management, even after restarting it. So I cannot do #3, #4 or #5 yet.

    I do see the SD card appear in "My Computer". However I cannot change the drive letter from there.
  22. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    What drive letter do you see assigned then in My Computer? is it E?

    When you are in Disk Management the top pane should be open Volumes (and drive letter) if you don't see volume list, click View->Top->Volume List

    Is the SD card drive letter in the Volume List? then rt click and change drive letter from there
  23. delux269

    delux269 TS Rookie Topic Starter

    Yes, it is assigned drive letter E: in My Computer. I see the volume list, but it just does not display the SD card for some reason.
  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Here's something i just stumbled across today:
    - I found several online reports of people stating problems with USB hard drive after installing XP SP3
    - Which was interesting cause when looking at your System Event Log i noticed you installed XP SP3 on 11/23/08. Don't know if you can recall if this is about when the problem started
    - Tho i don't the common denominator for the problem as many (myself included) run XP3 and usb drives without problem

    That said
    • Is the desktop PC you also tried testing on also running SP3? If you know someone running other then SP3 you might try your drive there as well
    • Might also be a good time to try downloading/burning/booting from Acronis Disk Director and use that 15day free trial (it can be handy for a tool to keep as well). Question then being: when you boot from Acronis (i.e. no Windows) can it read the drive?
    • If you want to continue looking at what;s up with current SP3 install i don't mind continuing (been educational for me as well!)
      • I can see the SD card mounted on E: as well in the registry export you provided. Not sure why it's not showing up in Disk Management (fyi... drive letter conflicts between things like network drives/sdreaders and USB often a problem)
      • You might also want to try downloading then run this tool. It reports on physical disks (among other things) tho not certain if it makes a difference for it to work if LDM not working. But can see and find out.

    /**** EDIT ***********/
    Hmm.. i wonder if Dell is hiding that drive letter. Use TweakUI to make sure you don't have any hidden volumes on your system. You can look here for how to do that
  25. Codine

    Codine TS Rookie

    Is your USB 1.0 or 2.0, it might not matter but you never know. Also did you get any drivers for your hdd?? you might need them also.. :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...