1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Western Digital external hard drive problem

By delux269 · 77 replies
Nov 27, 2008
  1. Hello everyone,
    I have a WD 500GB external hard drive that is not being recognized by my computer anymore. It just stopped working. When I plug the USB cable in, Windows recognizes that the device is there, and says that it has installed the approapriate software for the device and it is ready to use. However, the drive does not appear in My Computer. Also, I have right-clicked on my computer and then the Manage option, and under Disk Management, I do not see the drive. I have all of my sports games and music on the drive. I just need some help on how to solve this problem.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

    Firstly confirm the external drive and USB cable works in another computer
    This will eliminate the Drive and cable, from your computer
  3. delux269

    delux269 TS Rookie Topic Starter

    okay let me try that

    I have many slots for external devices on my desktop PC, but I think it is not showing up there either.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    1. It's unusual for Windows to recognize the device, say it's installed and NOT see it under Disk Management (not unusual that it doesn't appear as a logical drive)

    2. Look again under Disk Management. It may appear different or unassigned. Do you recognize every disk listed?

    3. Disconnect every USB device from your computer.
    - Open Device Manager. Expand USB devices.
    - Connect the drive directly to the computer USB port
    - Device Manager should refresh as Windows says it sees a device installed etc.
    - Look through Device Manager under Disk Drives and USB devices for new devices or anything that appears with a yellow icon.
    - See anything?
  5. delux269

    delux269 TS Rookie Topic Starter

    ok i will try this and get back to you tomorrow

    Lookin Around, I see a disk under "Disk drives" that is titled "WD". This should be what I am looking for. It still does not show up in My Computer
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    Common cause is there is a drive letter conflict and some other device is using the drive letter previously mapped to the WD. In disk management, rt click on the WD drive, and assign it a new drive letter. Does it work now?
  7. delux269

    delux269 TS Rookie Topic Starter

    I see the WD under "disk drives" however I do not see the disk under "disk management". In "disk management" I only see the internal hard drive in my laptop, and the CD/DVD drive.
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    If you could do the following may be easiest way to be certain of just what you should seeing where and then follow up with you
    Click to download then run Everest Home. From top of Everest window:
    • Click File->Preferences
      • Check English
      • Then (still under Preferences) click Report and uncheck Include Debug Information
      • Close Preferences window
    • Click Reports->Report Wizard. Get a Custom Report report in plain text. Check these items
      • Computer
      • Storage
    • Attach the report file to a TechSpot post. When you create your TechSpot post, use the paper clip icon to attach the report. (If you don't see it among your icons, you need to click the TechSpot Go Advanced button towards bottom of window)
    Report all installed and uninstalled USB devices
    Run USBDeview
    From the USBDeview menu bar,
    => Edit->Select All
    => File->Save Selected Devices, use pull down menu to set Save As Type to .csv (comma delimited text)
    => Then save to a file and also attach this file to your TechSpot post

    Check if Windows reports any problem devices
    • Click Start->Run, enter: msinfo32. (It may take a short while till a second window opens)
    • Expand Components (click + sign next to it)
    • Click Problem Devices. Anything appear?
    • If yes, click it, then Edit->Select All then Edit->Copy and then paste into your next post
  9. delux269

    delux269 TS Rookie Topic Starter

    Okay I attached the report to this post. I looked at the report, and it shows the WD drive as only being 7 MB. That is way wrong, as the capacity of the drive is actually 500GB.

    The website is not allowing me to upload a file with the .csv extension like you said

    Attached Files:

  10. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

  11. delux269

    delux269 TS Rookie Topic Starter

    and no devices appeared under the "problem devices" category

    I believe all of my drivers are updated, I went on that link and everything looked to be okay. I also inserted my drivers CD that came with the laptop and checked everything on there.

    I attached my device report
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    Thanks for uploading all reports
    (i forgot TechSpot doesn't like .csv extension and should have asked you to rename to .txt. Thanks to kimsland for the .zip advice)

    A look at the USB and Everest reports appears OK as far as the USB connection to Windows and Windows recognizing it as a disk device. So please take a second and closer look at Disk Management.

    When you open Disk Management
    - click View->Top->Volume List
    - click View->Bottom->Disk List

    In the bottom view,
    - How many disk are listed?
    - On each disk listed, rt click Properties, what device is it for? (should see on General tab)

    And I see you have a removable SD card inserted. Try this:
    - Shutdown your computer
    - Remove SD card
    - Power up computer and plug in your USB drive

    At the moment i'm still guessing a drive letter conflict. And i'll guess it was caused when the SD card was inserted and recognized before the USB drive so it was assigned the USB drive letter!
    /** EDIT **/
    Did your USB drive used to appear as drive E:???
  13. delux269

    delux269 TS Rookie Topic Starter

    I removed the SD card and restarted like you said. On the bottom view in disk management, I see two disks: "Disk 0" which is my internal hard drive, I can tell by the 37.25 GB capacity. The second is "CD-ROM 0" which is my CD drive. I believe this is the same as when the SD card was not inserted as well.

    I can't be sure about the drive letter when it worked, it was a few weeks ago when the drive stopped working correctly, but my guess would be that drive letter E: sounds correct for what is was when the hard drive was working.
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    (EDIT: Never mind my question but i see you did reboot above. I'll post again when i can with instructions to uninstall all devices involved here so we can get Windows a fresh chance to get this right)

    /*** EDIT ****/
    After rebooting you can also re-run Everest as we want to resolve / understand devices it reports as logical and physical. In old report (see below) am confused as it reports the physical drive but you say it's not appearing in Disk Management. And i was guessing logical drive E: was SD card.. or you think it is something else?
    --------[ Logical Drives ]----------------------------------------------------------------------------------------------
        C:                                        Local Disk          NTFS          38146 MB      10582 MB      27563 MB   72 %  D44C-A7B2
        D:                                        Optical Drive                                                                           
        E:                                        Removable Disk      FAT             243 MB        175 MB      70288 KB   28 %  FC30-3DA9
    --------[ Physical Drives ]---------------------------------------------------------------------------------------------
      [ Drive #1 - SAMSUNG MP0402H (37 GB) ]
        #1 (Active)      NTFS             C:                                              0 MB    38146 MB
      [ Drive #2 - WD (8 MB) ]
      [ Drive #3 (2048 GB) ]
    --------[ Optical Drives ]----------------------------------------------------------------------------------------------
      [ TSSTcorp CDRW/DVD TSL462C ]
  15. delux269

    delux269 TS Rookie Topic Starter

    The SD card was drive E: in that report, I know that for a fact. Would you like me to generate another report?
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    It is very strange that Everest report the physical drive yet it not appear in Disk Management. Here's instructions to uninstall the drivers. Then we'll give Windows another shot to reinstall and hope it get's it right! We should AT LEAST see the disk in Disk Management.
    1. Make sure your SD card is removed as well as all USB devices.
    2. See this so Device Manager will display unconnected devices
    3. Open device manager. Click View->Show Hidden Devices
      • Under Disk Drives you’ll see entries with semi-transparent icons. These are devices not currently connected. You should see an entry for the WD drive. Rt click->Uninstall
      • If you see other unconnected HARDWARE drives you can uninstall them as well but not virtual (software) drives. Example: See attached image. Acronis is a virtual drive. The other semi-transparent icons are disconnected hardware drives. If not certain, you can also capture an image/ask
    4. In device manager, uncheck View->Show Hidden Devices. Then expand your USB devices. Note: I’m assuming no assuming no USB devices attached including any USB mice/keyboard as next steps will disconnect them
      • You’ll see several USB entries with the word Controller. For each USB controller entry, rt click->Uninstall
      • Click Action->Scan for Hardware Changes. You should see each of the controllers get reinstalled
    5. Reboot your computer
    6. Your external USB drive should be powered off before you connect the USB cable to your computer
    7. After connecting USB cable, then turn on your USB drive
    8. Check Device Manager, Disk Management and what Everest reports for logical/physical drives and I sure hope that this one works!

    /********** EDIT **************/
    Have you also tried plugging the USB drive into each of the different USB ports on the computer?
    And recheck if Windows is still NOT reporting any problem devices (instructions prior post)

    /*********** EDIT 2 **************/
    Hmmm.. i had never heard of it before but apparently there are other cases where the drive appears in Device Manager but not Disk Management (btw.. you do have an external power supply for your hard drive, right?). If all else has continued to fail... have you yet verified that USB drive using a different computer as kimsland 1st asked? Best to do that before trying anything else if you haven't

    Attached Files:

  17. delux269

    delux269 TS Rookie Topic Starter

    Same things after following the instruction on your last post. When Windows recognized the device, it just said it found a "WD" it did not say "Mass Storage device" like it did when the external drice was working. Just a note I thought I would throw in. Yes the power supply for the device is external. I plug it into a regular power outlet. I will try plugging the device into all USB ports, but I am not too confident in that. I will update you on my progress

    I am going to check the device on my desktop PC right now. Be back in a few minutes.

    Same result on the desktop PC.
  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    1. Use a different USB cable and try connecting the drive on both computers. Drive should be powered off, plug in cable, then power on
    2. There should be a tag on your WD drive. Can you tell me the exact model number?
    3. Just tell me if this file exists on your computer. If yes, what size is it? C:\WINDOWS\setupapi.log
  19. delux269

    delux269 TS Rookie Topic Starter

    setupapi.txt is 556 KB size. The P/N is WD5000H1U-00

    The S/N is WMASY0367807

    There is also another number that says 3808A. And below this number there is R/N A0C
  20. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186


    Try the test with different cable when you have a chance. Probably won't be able to follow up with anything further till tomorrow (i.e. 12+ hours from now)
  21. delux269

    delux269 TS Rookie Topic Starter

    I will have to buy another one from Best Buy tomorrow - so I will probably get back to you at like 2 pm Eastern time at the earliest.

    Okay I bought the new USB cord, with the same result after following all of your steps. I'm extremely frustrated now - one of these steps should have worked
  22. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    OK. Whenever you can do it is OK. Just make sure it's a USB 2.0 cable (i think that's probably all they sell these days) and it's returnable. Once you do the cable test, here’s the new checklist.
    1. Took awhile to find your USB drive (Good ol’ WD calls it WDH1U5000-00 on their web site) Click here and confirm this is your drive
    2. I believe the drive came formatted as a FAT32 disk. Did you convert/reformat to NTFS? Or is it still FAT32?
    3. Did you ever install the WD Drive Manager (PC version)? WD website has Version 2.107a, Sept, 2008. Make sure this is the version installed. After the install do a reboot. (you'll find the download on the link i provided above)
    4. Have you tried WD diagnostic program yet? (don’t know if it may or may not help in this case). But you can also download it from the web site I provided and give it a shot
    5. Next, I’d like you to capture some data for me from Device Manager. XP doesn’t allow Copy/Paste to make getting/saving this data straight forward BUT see this [post=690492] post about the SysExporter tool[/post]
      • With the USB drive connected to computer USB and powered on, open Device Manager
      • Scroll to USB Serial Bus and expand. Any entries marked USB Mass Storage? For each one, rt click->Properties.
        ==> On General tab, verify Device Status says working properly
        ==> Click Details tab. Use pull down menu to display Device Instance Id. Use SysExporter to copy/paste that entire string (starting USB\VID into a text file for me
      • Scroll to Disk Drives and expand. For the WD disk do the same, look at General tab (device is workig?) then go to Details tab and use SysExporter to grab the string (starting UBSTOR\DISK)
      • Click View->Show Hidden devices (we want to see connected and disconnected devices now. Go to previous post if you need instructions again on how to do that). Scroll to Storage Volumes and expand. There will be many entries named Generic Volume. Look at each one. Do they all simply read Generic Volume? Do any of them have garbage (non-printing or gibberish characters following the words Generic Volume
    6. As a note: it is very important that you never abrubtly disconnect the USB drive before properly stopping it or shutting down the computer. E.g. simply pulling out the USB cables when computer is running is a DO NOT DO. This can cause corruption and may (or may not) be behind your problem. Tho do u recall last time u used the drive, did you abruptly disconnect the drive?
    7. Finally, if still no progress let’s take advantage of a 15day free trial with Acronis Disk Director. Download it and install. When you start it, it offers an option to create a rescue CD. Create the rescue CD. Thinking is: whatever the current problem in Windows, if we boot directly into Acronis Disk Director rescue CD (and not boot Windows) , maybe Acronis can manage to see and recover that darn disk drive!
    While you go through the other steps I’ll prepare some steps for Acronis.

    If we come up short here, the last thing to try (as i'm running out of ideas) is to setup your system so next time we plug in the disk drive it generates detailed trace info about Windows plug-and-play actions and Windows driver search/install process to see just what exactly is occuring "under the covers". Hoping it might reveal the fail point in the process

    /********* EDIT **************/
    One additional thing i just thought of.....
    - Start->Run, enter regedit. Expand keys till you get to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\STORAGE
    - Click on STORAGE so that subkey is highlighted, then from regedt menu bar File->Export
    - At bottom of Export window verify Selected branch is chosen and should show the key i noted above.
    - Change the Save as Type to .txt files
    - Then save it somewhere so you can attach it to TechSpot post
  23. delux269

    delux269 TS Rookie Topic Starter

    Lookin Around, I thank you for all of your help and your dedication for helping me solve this problem.

    All devices were reported to be working correctly. I only have one entry under "Storage Volumes". There is one "Generic Volume". It says it is working correctly. There are no garbage characterse after it.

    I do not believe I ever abruptly disconnected the device, I am very careful with this drive since I paid a lot for it.

    I am attaching the two text files that you requested.

    I am attaching the report from regedit you requested. Hopefully we find what the problem is from one of these things.

    Attached Files:

  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    Some tackle Sunday newspaper crossword puzzles. i prefer this instead! ;)
    I just hope we can fill in some of the still missing pieces to this puzzle. (i've seen many posts in different forums about similar USB hard drive problems without resolution. Will make my best effort to try and figure this out ....)

    Will take me awhile to figure out how to interpret all the registry data. But I also i realized my prior instructions missed two registry exports i still need. Could you also please create similar exports for:
    (i don't need USBPRINT)

    Also other thoughts....
    1. Will help to know: had you left the drive as FAT32 or do you remember re-formatting it to NTFS? (you can go thru the other questions/things to do in prior post as you find the time as i know will take more time on your part as well)

    2. The desktop PC you tested your drive on yesterday (or maybe it was today).. What operating system is it running? and is it a 32 or 64 bit operating system? (On the desktop PC, do Start->Run, msinfo32. When window opens, look at right display panel. It indicates Operating System. And also look there for and tell me what it says for System Type (will tell me if 32- or 64- bit)

    3. I remembered that Windows keeps a system change history. It can also be displayed by msinfo32. Let's see if it tells anything interesting.

    - Start->Run, enter msinfo32 Will take 15secs or so for the window to come up.
    - Click View->System History, click on System Summary, then File->Export and save as a text file.
    - Check if the file output is larger then 200KB (TechSpot attachment limit)
    - Why don't you eyeball the file also and see if you can see around the date when the drive stopped working and tell me as well as attaching the file

    /*** EDIT ****/
    One more question (i know.. lots of questions...!) Do you have any Acronis products installed? Which ones? Do you have Norton Ghost installed?
  25. delux269

    delux269 TS Rookie Topic Starter

    Here are two of the things you requested, I will get to the others in a little while.

    I never reformatted the drive from its original format. So it should still be FAT-32

    The System Summary just said No changes

    I do not have Norton ghost installed, and I have not yet installed Acronis - I will do that once you have run out of ideas. Or would you like for me to install it now?

    on the desktop PC I tested the drive on, it says that it is an x-86 based computer
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...